aboutsummaryrefslogtreecommitdiff
path: root/mail/qmailmrtg7
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
commit01c588a6357d8452a3e0af157e9c1250c067db2f (patch)
treefb26bf418ea8791ab4d308a7931c623124611c3c /mail/qmailmrtg7
parentf484c99df79f169bf954fc4b0ed83e59279a596a (diff)
downloadports-01c588a6357d8452a3e0af157e9c1250c067db2f.tar.gz
ports-01c588a6357d8452a3e0af157e9c1250c067db2f.zip
- Fix 'all-depends-list' target in cases if dependencies list is
very long and if some dependencies can't be added into the list. [1] - Fix FAM support. Make gamin the default FAM system. [2] - Introduce new 'quicksearch' target to show only port, path and info section of the matching ports. [3] - Introduce new category - rubygems. [4] - Fix stale dependencies while installing qmail slaveport and another port that depends on qmail. [5] - Add commentary for describes target in bsd.port.mk. [6] - Fix warning issued during make index on archs !368. [7] - Add USE_DOS2UNIX variable. If set to "YES", remove the ^M from all files under ${WRKSRC}. If set to a string, remove in all files under ${WRKSRC} with one of these names the ^Ms. [8] - Add new variables PERL_RUN_DEPENDS and PERL_BUILD_DEPENDS by checking the existance of the Perl modules with the "perl -e 'use module;'" command. [9] - Fix bsd.port.mk variable quoting issues. No quoting is necessary anymore either in the Makefile or on the command line. Affected variables include: BROKEN FORBIDDEN IGNORE MANUAL_PACKAGE_BUILD NO_CDROM NO_PACKAGE RESTRICTED [10] - Add NOFETCHFILES variable. If set, don't download these files from the ${MASTER_SITES} or ${MASTER_SITE_BACKUP} (but do from ${MASTER_SITE_OVERRIDE}). [11] - Improve 'search' target output. [12] - Add a new virtual category for Amateur Radio - hamradio. [13] - Cleanup some old/unused pathes in bsd.port.mk. [14] - Add @dirrmtry for plists which does the same as: "@unexec rmdir %D/foo 2>/dev/null || true" [15] - Remove virtual category - offix. [16] - Use portsnap instead of cvsup or cvs on "make update" in /usr/ports. [17] - Move location of bsd.autotools.mk within bsd.port.mk [18] - Add bsd.linux-rpm.mk, fix INSTALLS_SHLIB for Linux ports [19] - Use new USE_RC_SUBR format for FreeBSD version >= 700007 [20] - Replace the string "FreeBSD" by "The FreeBSD Project" in the security warning [21] - Add bsd.local.mk for local modification to ports framework. [22] - Replace rcNG spelling by rc.d [23] - Remove superfluous USE_REINPLACE. [24] Special thanks to: linimon for spending hours with all these patches clement for fixes kris for help with pointyhat PR: ports/86310 [1], ports/89498 [2], ports/83530 [3], ports/83789 [4], ports/84053 [5], ports/86281 [6], ports/87214 [7], ports/87234 [8], ports/87318 [9], ports/87396 [10], ports/87605 [11], ports/87840 [12], ports/88230 [13], ports/88493 [14], ports/88711 [15], ports/88751 [16], ports/89281 [17], ports/89999 [18], ports/90031 [19], ports/90150 [20], ports/90668 [21], ports/91433 [23], ports/88754 [24] Submitted by: mi [1], marcus [2], Lars Engels <lars.engels@0x20.net> [3], pav [4, 16, 20, 24], garga [5], cperciva [6], vd [7], edwin [8, 9, 11, 15, 21], fenner [10], Arseny Nasokin <tarc.po.cs.msu.su@tarc.po.cs.msu.su> [12], Carl Makin <carl@stagecraft.cx> [13], arved [14], NIIMI Satoshi <sa2c@sa2c.net> [17], thierry [18], jylefort [19], linimon [22], dougb [23]
Notes
Notes: svn path=/head/; revision=154065
Diffstat (limited to 'mail/qmailmrtg7')
-rw-r--r--mail/qmailmrtg7/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/mail/qmailmrtg7/Makefile b/mail/qmailmrtg7/Makefile
index d66de2663568..21f098a14111 100644
--- a/mail/qmailmrtg7/Makefile
+++ b/mail/qmailmrtg7/Makefile
@@ -7,29 +7,23 @@
PORTNAME= qmailmrtg7
PORTVERSION= 4.2
+PORTREVISION= 1
CATEGORIES= mail net-mgmt
MASTER_SITES= http://www.inter7.com/qmailmrtg7/
MAINTAINER= ale@FreeBSD.org
COMMENT= A program to create mrtg graphs for qmail activity
-BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-queue:${PORTSDIR}/mail/qmail
-RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-queue:${PORTSDIR}/mail/qmail \
- mrtg:${PORTSDIR}/net-mgmt/mrtg
+RUN_DEPENDS= mrtg:${PORTSDIR}/net-mgmt/mrtg
+USE_QMAIL= yes
USE_REINPLACE= yes
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/qmail/bin/qmail-queue)
-QMAIL_DIR?= ${LOCALBASE}/qmail
-.else
-QMAIL_DIR?= /var/qmail
-.endif
-
post-patch:
@${REINPLACE_CMD} "s|cc|${CC}|g;s|-s -O|${CFLAGS}|g" ${WRKSRC}/Makefile
- @${REINPLACE_CMD} "s|/usr/local|${PREFIX}|g;s|/var/qmail|${QMAIL_DIR}|g" \
+ @${REINPLACE_CMD} "s|/usr/local|${PREFIX}|g;s|/var/qmail|${QMAIL_PREFIX}|g" \
${WRKSRC}/checkq.c ${WRKSRC}/qmail.mrtg.cfg
do-install: