aboutsummaryrefslogtreecommitdiff
path: root/mail/qmqtool/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-26 09:36:11 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-26 09:36:11 +0000
commit9c87896de5b5816dbb5ba640956a991cf6506423 (patch)
treeb437277c32179cff18998eeb4dfa62d1c637e804 /mail/qmqtool/Makefile
parentb324aeea4a61dcfd4847105003ae9f9c6028ad19 (diff)
downloadports-9c87896de5b5816dbb5ba640956a991cf6506423.tar.gz
ports-9c87896de5b5816dbb5ba640956a991cf6506423.zip
Support staging
Notes
Notes: svn path=/head/; revision=346167
Diffstat (limited to 'mail/qmqtool/Makefile')
-rw-r--r--mail/qmqtool/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/mail/qmqtool/Makefile b/mail/qmqtool/Makefile
index bc7ecceb2e60..c5b947b246cd 100644
--- a/mail/qmqtool/Makefile
+++ b/mail/qmqtool/Makefile
@@ -16,15 +16,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
USES= perl5
-NO_STAGE= yes
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/qmqtool ${PREFIX}/bin
+OPTIONS_DEFINE= DOCS
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/qmqtool ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in Artistic ChangeLog FAQ README
- ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>