aboutsummaryrefslogtreecommitdiff
path: root/mail/qpopper/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1997-10-07 20:37:24 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1997-10-07 20:37:24 +0000
commit40239124bb89589c608141ef44e09d578dc7610d (patch)
tree64061d3dcaf0cb8189938a9de3dfe63cb686bc65 /mail/qpopper/Makefile
parentaa806e0b60e1411609330fd51a6564837443109f (diff)
downloadports-40239124bb89589c608141ef44e09d578dc7610d.tar.gz
ports-40239124bb89589c608141ef44e09d578dc7610d.zip
Upgrade to 2.4b2
Fix two longstanding bugs in Return-Path patch: 1) possible uninitialized "rpath" variable usage 2) wrong message size, return_path not counted
Notes
Notes: svn path=/head/; revision=8161
Diffstat (limited to 'mail/qpopper/Makefile')
-rw-r--r--mail/qpopper/Makefile40
1 files changed, 36 insertions, 4 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 3de4965704fa..6a1aab2ad6f1 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: popper
-# Version required: 2.3
+# Version required: 2.4b2
# Date created: 1 April 1995
# Whom: pst
#
-# $Id: Makefile,v 1.14 1997/04/02 01:38:22 ache Exp $
+# $Id: Makefile,v 1.15 1997/04/23 04:27:18 ache Exp $
#
-DISTNAME= qpopper2.3
-PKGNAME= qpopper-2.3
+DISTNAME= qpopper2.4b2
+PKGNAME= qpopper-2.4b2
CATEGORIES= mail
MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/
EXTRACT_SUFX= .tar.Z
@@ -21,4 +21,36 @@ MAINTAINER= pst@freebsd.org
NO_PACKAGE= "Needs POP UID"
+O_DEFS= -DSETPROCTITLE -DKEEP_TEMP_DROP -DBSD44_DBM -DBIND43 \
+ -DAPOP='\"'${PREFIX}'/etc/popper/pop.auth\"' \
+ -DPOPUID='\"pop\"' \
+ -DNONAUTHFILE='\"/etc/ftpusers\"'
+
+.if !defined(APOP_ONLY)
+.if exists(/usr/lib/libskey.a)
+P_LIBS= -lskey
+O_DEFS+= -DSKEY
+.endif
+.else
+O_DEFS+= -DAPOP_ONLY
+.endif
+
+P_LIBS+= -lmd -lcrypt -lutil
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LIBS="${P_LIBS}" O_DEFS="${O_DEFS}"
+
+MAN8= popauth.8 popper.8
+
+post-patch:
+ $(RM) ${WRKSRC}/md5.h
+
+do-install:
+ cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} -o pop -m 4111 popauth ${PREFIX}/bin
+ cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} -g mail -m 2111 popper ${PREFIX}/libexec
+ cd ${WRKSRC} && \
+ ${INSTALL_MAN} ${MAN8} ${PREFIX}/man/man8
+
.include <bsd.port.mk>