aboutsummaryrefslogtreecommitdiff
path: root/mail/raysfilter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-05-10 06:01:35 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-05-10 06:01:35 +0000
commit2029c61d646c54777665670f0c9eb34ef43de0e2 (patch)
tree38d75507922a8964a05e8dcf179d32afb2f956f1 /mail/raysfilter
parentb90c5cf707d65a38a955a3c0676958c11defad6b (diff)
downloadports-2029c61d646c54777665670f0c9eb34ef43de0e2.tar.gz
ports-2029c61d646c54777665670f0c9eb34ef43de0e2.zip
Add an option: SENDMAIL_MILTER_IN_BASE=yes
This does not build yet, as the ports need more than libmilter. PR: 37908
Notes
Notes: svn path=/head/; revision=58846
Diffstat (limited to 'mail/raysfilter')
-rw-r--r--mail/raysfilter/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/mail/raysfilter/Makefile b/mail/raysfilter/Makefile
index 3a5fca21957e..6823e72625e9 100644
--- a/mail/raysfilter/Makefile
+++ b/mail/raysfilter/Makefile
@@ -13,12 +13,17 @@ DISTNAME= rays-filter-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
+.if !defined(SENDMAIL_MILTER_IN_BASE)
BUILD_DEPENDS= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
+.endif
CTARGETS+= rays-filter
-CFLAGS+= -Wall -I$(LOCALBASE)/include ${PTHREAD_CFLAGS:S=""==}
-FLAGS+= ${PTHREAD_LIBS}
+CFLAGS+= -Wall ${PTHREAD_CFLAGS:S=""==}
+LIBS+= ${PTHREAD_LIBS}
+.if !defined(SENDMAIL_MILTER_IN_BASE)
+CFLAGS+= -I$(LOCALBASE)/include
LDFLAGS+= -L$(LOCALBASE)/lib
+.endif
ETCFILES= header-list.conf mail-filter.conf string-list.conf
BINFILES= mf-reset mf-start mf-stop mf-archive mf-analyze mf-memory
DOCSFILES= rays-filter.html install.html configure.html operate.html \
@@ -26,7 +31,8 @@ DOCSFILES= rays-filter.html install.html configure.html operate.html \
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/libmilter/mfdef.h)
+.if exists(${LOCALBASE}/include/libmilter/mfdef.h) \
+|| defined(SENDMAIL_MILTER_IN_BASE)
LIBS+= -lmilter -lsm -lsmutil
.else
LIBS+= -lmilter -lsmutil