aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube-mobilecube
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-27 22:12:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-27 22:12:11 +0000
commita571331cf2189bd112e0fc71b970bf0ab2998595 (patch)
tree3a0e58b7b4bcdc9741593b2282cc5f69cb0b71b6 /mail/roundcube-mobilecube
parent82ec68f6e6b67c7ca24d8495364553304a70b2ea (diff)
downloadports-a571331cf2189bd112e0fc71b970bf0ab2998595.tar.gz
ports-a571331cf2189bd112e0fc71b970bf0ab2998595.zip
MobileCube is a simple and clean theme that fits perfect with the Roundcube
Mail system. It includes mail, contacts, and calendar that displays it in a simple, yet elegant way. MobileCube works with RoundCube 0.3.1+ so if you have RoundCube set up and installed, download MobileCube today and try it out! It's free! We hope you enjoy it! WWW: http://phireware.com/projects/mobilecube/ PR: ports/145014 Submitted by: Alexey V. Degtyarev <alexey at renatasystems.org>
Notes
Notes: svn path=/head/; revision=251591
Diffstat (limited to 'mail/roundcube-mobilecube')
-rw-r--r--mail/roundcube-mobilecube/Makefile44
-rw-r--r--mail/roundcube-mobilecube/distinfo3
-rw-r--r--mail/roundcube-mobilecube/pkg-descr7
-rw-r--r--mail/roundcube-mobilecube/pkg-plist248
4 files changed, 302 insertions, 0 deletions
diff --git a/mail/roundcube-mobilecube/Makefile b/mail/roundcube-mobilecube/Makefile
new file mode 100644
index 000000000000..436bb8a78328
--- /dev/null
+++ b/mail/roundcube-mobilecube/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: mobilecube
+# Date created: Wed 24 Mar 2010
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mobilecube
+PORTVERSION= ${THEME_VERSION}.${THEME_BUILD}
+CATEGORIES= mail
+MASTER_SITES= SF/${PORTNAME}/${THEME_VERSION}%20Beta/Build%20%23${THEME_BUILD}/
+PKGNAMEPREFIX= roundcube-
+DISTNAME= MobileCubeBeta%23${THEME_BUILD}
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Theme for RoundCube Web Mail
+
+RUN_DEPENDS= roundcube>=0.3:${PORTSDIR}/mail/roundcube
+
+THEME_VERSION?= 3.1.0
+THEME_BUILD?= 030110A
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/MobileCubeBeta\#${THEME_BUILD}
+WWWDIR?= ${PREFIX}/www/roundcube/skins/MobileCube
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist: build
+ cd ${WRKSRC}/MobileCube; \
+ ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
+ ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
+ -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
+post-patch:
+ ${FIND} ${WRKSRC} -type f -name '*.orig' -or -name '.DS_Store' -delete
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ cd ${WRKSRC}/MobileCube && ${PAX} -r -w . ${WWWDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-mobilecube/distinfo b/mail/roundcube-mobilecube/distinfo
new file mode 100644
index 000000000000..7b099418c59a
--- /dev/null
+++ b/mail/roundcube-mobilecube/distinfo
@@ -0,0 +1,3 @@
+MD5 (MobileCubeBeta%23030110A.zip) = 24fb49a9946a2268540d49fcf73ef535
+SHA256 (MobileCubeBeta%23030110A.zip) = 4e555ff5d58c94af5af17fb2699e96af06d04e3901cabb314100988318c01293
+SIZE (MobileCubeBeta%23030110A.zip) = 3167103
diff --git a/mail/roundcube-mobilecube/pkg-descr b/mail/roundcube-mobilecube/pkg-descr
new file mode 100644
index 000000000000..4d2497270804
--- /dev/null
+++ b/mail/roundcube-mobilecube/pkg-descr
@@ -0,0 +1,7 @@
+MobileCube is a simple and clean theme that fits perfect with the Roundcube
+Mail system. It includes mail, contacts, and calendar that displays it in a
+simple, yet elegant way. MobileCube works with RoundCube 0.3.1+ so if you have
+RoundCube set up and installed, download MobileCube today and try it out! It's
+free! We hope you enjoy it!
+
+WWW: http://phireware.com/projects/mobilecube/
diff --git a/mail/roundcube-mobilecube/pkg-plist b/mail/roundcube-mobilecube/pkg-plist
new file mode 100644
index 000000000000..eb4de08dbe49
--- /dev/null
+++ b/mail/roundcube-mobilecube/pkg-plist
@@ -0,0 +1,248 @@
+%%WWWDIR%%/README.txt
+%%WWWDIR%%/addresses.css
+%%WWWDIR%%/calendar.css
+%%WWWDIR%%/colorpicker.css
+%%WWWDIR%%/common.css
+%%WWWDIR%%/editor_content.css
+%%WWWDIR%%/functions.js
+%%WWWDIR%%/googiespell.css
+%%WWWDIR%%/images/bg.png
+%%WWWDIR%%/images/bgblue.png
+%%WWWDIR%%/images/bggray.png
+%%WWWDIR%%/images/border.png
+%%WWWDIR%%/images/border_horizontal.png
+%%WWWDIR%%/images/border_vertical.png
+%%WWWDIR%%/images/buttons/add_act.png
+%%WWWDIR%%/images/buttons/add_contact_act.png
+%%WWWDIR%%/images/buttons/add_contact_pas.png
+%%WWWDIR%%/images/buttons/add_contact_sel.png
+%%WWWDIR%%/images/buttons/add_pas.png
+%%WWWDIR%%/images/buttons/add_sel.png
+%%WWWDIR%%/images/buttons/address_act.png
+%%WWWDIR%%/images/buttons/address_pas.png
+%%WWWDIR%%/images/buttons/address_sel.png
+%%WWWDIR%%/images/buttons/addressbook.png
+%%WWWDIR%%/images/buttons/addressbook_hover.png
+%%WWWDIR%%/images/buttons/arrow_act.png
+%%WWWDIR%%/images/buttons/arrow_sel.png
+%%WWWDIR%%/images/buttons/attach_act.png
+%%WWWDIR%%/images/buttons/attach_pas.png
+%%WWWDIR%%/images/buttons/attach_sel.png
+%%WWWDIR%%/images/buttons/back_act.png
+%%WWWDIR%%/images/buttons/back_pas.png
+%%WWWDIR%%/images/buttons/back_sel.png
+%%WWWDIR%%/images/buttons/button.png
+%%WWWDIR%%/images/buttons/button_press.png
+%%WWWDIR%%/images/buttons/buttonbg.png
+%%WWWDIR%%/images/buttons/buttonbg_press.png
+%%WWWDIR%%/images/buttons/buttonbgblue.png
+%%WWWDIR%%/images/buttons/buttonbgblue_press.png
+%%WWWDIR%%/images/buttons/buttonbgblueleft.png
+%%WWWDIR%%/images/buttons/buttonbgblueright.png
+%%WWWDIR%%/images/buttons/buttonbgcenter.png
+%%WWWDIR%%/images/buttons/buttonbgleft.png
+%%WWWDIR%%/images/buttons/buttonbgright.png
+%%WWWDIR%%/images/buttons/buttonblue.png
+%%WWWDIR%%/images/buttons/buttonblue_press.png
+%%WWWDIR%%/images/buttons/cal.png
+%%WWWDIR%%/images/buttons/cal_hover.png
+%%WWWDIR%%/images/buttons/compose_act.png
+%%WWWDIR%%/images/buttons/compose_pas.png
+%%WWWDIR%%/images/buttons/compose_sel.png
+%%WWWDIR%%/images/buttons/contacts_act.png
+%%WWWDIR%%/images/buttons/contacts_pas.png
+%%WWWDIR%%/images/buttons/contacts_sel.png
+%%WWWDIR%%/images/buttons/delete_act.png
+%%WWWDIR%%/images/buttons/delete_pas.png
+%%WWWDIR%%/images/buttons/delete_sel.png
+%%WWWDIR%%/images/buttons/down_arrow.png
+%%WWWDIR%%/images/buttons/drafts_act.png
+%%WWWDIR%%/images/buttons/drafts_pas.png
+%%WWWDIR%%/images/buttons/drafts_sel.png
+%%WWWDIR%%/images/buttons/edit_act.png
+%%WWWDIR%%/images/buttons/edit_contact_act.png
+%%WWWDIR%%/images/buttons/edit_contact_pas.png
+%%WWWDIR%%/images/buttons/edit_contact_sel.png
+%%WWWDIR%%/images/buttons/edit_pas.png
+%%WWWDIR%%/images/buttons/edit_sel.png
+%%WWWDIR%%/images/buttons/first_act.png
+%%WWWDIR%%/images/buttons/first_pas.png
+%%WWWDIR%%/images/buttons/first_sel.png
+%%WWWDIR%%/images/buttons/forward_act.png
+%%WWWDIR%%/images/buttons/forward_pas.png
+%%WWWDIR%%/images/buttons/forward_sel.png
+%%WWWDIR%%/images/buttons/inbox_act.png
+%%WWWDIR%%/images/buttons/inbox_pas.png
+%%WWWDIR%%/images/buttons/inbox_sel.png
+%%WWWDIR%%/images/buttons/last_act.png
+%%WWWDIR%%/images/buttons/last_pas.png
+%%WWWDIR%%/images/buttons/last_sel.png
+%%WWWDIR%%/images/buttons/logout.png
+%%WWWDIR%%/images/buttons/logout_hover.png
+%%WWWDIR%%/images/buttons/mail.png
+%%WWWDIR%%/images/buttons/mail_hover.png
+%%WWWDIR%%/images/buttons/mark_menu_act.png
+%%WWWDIR%%/images/buttons/mark_menu_sel.png
+%%WWWDIR%%/images/buttons/markread_act.png
+%%WWWDIR%%/images/buttons/mobileme_logo2.png
+%%WWWDIR%%/images/buttons/next2_act.png
+%%WWWDIR%%/images/buttons/next2_pas.png
+%%WWWDIR%%/images/buttons/next2_sel.png
+%%WWWDIR%%/images/buttons/next_act.png
+%%WWWDIR%%/images/buttons/next_pas.png
+%%WWWDIR%%/images/buttons/next_sel.png
+%%WWWDIR%%/images/buttons/previous2_act.png
+%%WWWDIR%%/images/buttons/previous2_pas.png
+%%WWWDIR%%/images/buttons/previous2_sel.png
+%%WWWDIR%%/images/buttons/previous_act.png
+%%WWWDIR%%/images/buttons/previous_pas.png
+%%WWWDIR%%/images/buttons/previous_sel.png
+%%WWWDIR%%/images/buttons/print_act.png
+%%WWWDIR%%/images/buttons/print_pas.png
+%%WWWDIR%%/images/buttons/print_sel.png
+%%WWWDIR%%/images/buttons/reply_act.png
+%%WWWDIR%%/images/buttons/reply_pas.png
+%%WWWDIR%%/images/buttons/reply_sel.png
+%%WWWDIR%%/images/buttons/replyall_act.png
+%%WWWDIR%%/images/buttons/replyall_pas.png
+%%WWWDIR%%/images/buttons/replyall_sel.png
+%%WWWDIR%%/images/buttons/send_act.png
+%%WWWDIR%%/images/buttons/send_pas.png
+%%WWWDIR%%/images/buttons/send_sel.png
+%%WWWDIR%%/images/buttons/settings.png
+%%WWWDIR%%/images/buttons/settings_hover.png
+%%WWWDIR%%/images/buttons/source_act.png
+%%WWWDIR%%/images/buttons/source_pas.png
+%%WWWDIR%%/images/buttons/source_sel.png
+%%WWWDIR%%/images/buttons/spacer.gif
+%%WWWDIR%%/images/buttons/spacer.png
+%%WWWDIR%%/images/buttons/spellcheck_act.png
+%%WWWDIR%%/images/buttons/spellcheck_pas.png
+%%WWWDIR%%/images/buttons/spellcheck_sel.png
+%%WWWDIR%%/images/buttons/up_arrow.png
+%%WWWDIR%%/images/cleardot.png
+%%WWWDIR%%/images/detail_header_thumbnail.png
+%%WWWDIR%%/images/dimple.png
+%%WWWDIR%%/images/display/confirm.png
+%%WWWDIR%%/images/display/info.png
+%%WWWDIR%%/images/display/loading.gif
+%%WWWDIR%%/images/display/warning.png
+%%WWWDIR%%/images/favicon.ico
+%%WWWDIR%%/images/glass_roll.png
+%%WWWDIR%%/images/googiespell/change_lang.gif
+%%WWWDIR%%/images/googiespell/change_lang.png
+%%WWWDIR%%/images/googiespell/indicator.gif
+%%WWWDIR%%/images/googiespell/indicator.png
+%%WWWDIR%%/images/googiespell/ok.gif
+%%WWWDIR%%/images/googiespell/ok.png
+%%WWWDIR%%/images/googiespell/spellc.gif
+%%WWWDIR%%/images/googiespell/spellc.png
+%%WWWDIR%%/images/icons/abcard.png
+%%WWWDIR%%/images/icons/attachment.png
+%%WWWDIR%%/images/icons/blank.png
+%%WWWDIR%%/images/icons/card.png
+%%WWWDIR%%/images/icons/collapsed.png
+%%WWWDIR%%/images/icons/compact.png
+%%WWWDIR%%/images/icons/contacts.png
+%%WWWDIR%%/images/icons/deleted.png
+%%WWWDIR%%/images/icons/dot.png
+%%WWWDIR%%/images/icons/expanded.png
+%%WWWDIR%%/images/icons/export.png
+%%WWWDIR%%/images/icons/family.png
+%%WWWDIR%%/images/icons/flagged.png
+%%WWWDIR%%/images/icons/folder-closed.png
+%%WWWDIR%%/images/icons/folder-drafts.png
+%%WWWDIR%%/images/icons/folder-inbox.png
+%%WWWDIR%%/images/icons/folder-junk.png
+%%WWWDIR%%/images/icons/folder-open.png
+%%WWWDIR%%/images/icons/folder-sent.png
+%%WWWDIR%%/images/icons/folder-trash.png
+%%WWWDIR%%/images/icons/folders.png
+%%WWWDIR%%/images/icons/forwarded.png
+%%WWWDIR%%/images/icons/glass.png
+%%WWWDIR%%/images/icons/glass_roll.png
+%%WWWDIR%%/images/icons/holiday.png
+%%WWWDIR%%/images/icons/identities.png
+%%WWWDIR%%/images/icons/minus.png
+%%WWWDIR%%/images/icons/other.png
+%%WWWDIR%%/images/icons/personal.png
+%%WWWDIR%%/images/icons/plus.gif
+%%WWWDIR%%/images/icons/plus.png
+%%WWWDIR%%/images/icons/preferences.png
+%%WWWDIR%%/images/icons/purge.png
+%%WWWDIR%%/images/icons/remove-attachment.png
+%%WWWDIR%%/images/icons/rename.png
+%%WWWDIR%%/images/icons/replied.png
+%%WWWDIR%%/images/icons/reset.png
+%%WWWDIR%%/images/icons/silhouette.png
+%%WWWDIR%%/images/icons/unread.png
+%%WWWDIR%%/images/icons/unread1.png
+%%WWWDIR%%/images/icons/work.png
+%%WWWDIR%%/images/listheader.png
+%%WWWDIR%%/images/listheader_dark.png
+%%WWWDIR%%/images/listselected.png
+%%WWWDIR%%/images/login/login.jpg
+%%WWWDIR%%/images/login/login2.jpg
+%%WWWDIR%%/images/login/login3.jpg
+%%WWWDIR%%/images/login/login4.jpg
+%%WWWDIR%%/images/login/login5.jpg
+%%WWWDIR%%/images/loginbg.jpg
+%%WWWDIR%%/images/loginbg.png
+%%WWWDIR%%/images/mail_footer.png
+%%WWWDIR%%/images/messageactions.png
+%%WWWDIR%%/images/mobileme_logo.png
+%%WWWDIR%%/images/mobileme_logo2.png
+%%WWWDIR%%/images/pagenav.gif
+%%WWWDIR%%/images/previewpane.png
+%%WWWDIR%%/images/rounded.png
+%%WWWDIR%%/images/roundedsm.png
+%%WWWDIR%%/images/searchfield.png
+%%WWWDIR%%/images/sort_asc.png
+%%WWWDIR%%/images/sort_desc.png
+%%WWWDIR%%/images/tab_act.gif
+%%WWWDIR%%/images/tab_act.png
+%%WWWDIR%%/images/tab_pas.gif
+%%WWWDIR%%/images/tab_pas.png
+%%WWWDIR%%/images/watermark.png
+%%WWWDIR%%/includes/header.html
+%%WWWDIR%%/includes/ldapscripts.html
+%%WWWDIR%%/includes/links.html
+%%WWWDIR%%/includes/messagemenu.html
+%%WWWDIR%%/includes/taskbar.html
+%%WWWDIR%%/includes/taskbarcal.html
+%%WWWDIR%%/includes/taskbarsingle.html
+%%WWWDIR%%/login.css
+%%WWWDIR%%/mail.css
+%%WWWDIR%%/pngbehavior.htc
+%%WWWDIR%%/print.css
+%%WWWDIR%%/settings.css
+%%WWWDIR%%/splitter.js
+%%WWWDIR%%/templates/addcontact.html
+%%WWWDIR%%/templates/addidentity.html
+%%WWWDIR%%/templates/addressbook.html
+%%WWWDIR%%/templates/compose.html
+%%WWWDIR%%/templates/editcontact.html
+%%WWWDIR%%/templates/editidentity.html
+%%WWWDIR%%/templates/error.html
+%%WWWDIR%%/templates/identities.html
+%%WWWDIR%%/templates/login.html
+%%WWWDIR%%/templates/mail.html
+%%WWWDIR%%/templates/managefolders.html
+%%WWWDIR%%/templates/message.html
+%%WWWDIR%%/templates/messagepart.html
+%%WWWDIR%%/templates/messagepreview.html
+%%WWWDIR%%/templates/plugin.html
+%%WWWDIR%%/templates/printmessage.html
+%%WWWDIR%%/templates/settings.html
+%%WWWDIR%%/templates/settingsedit.html
+%%WWWDIR%%/templates/showcontact.html
+%%WWWDIR%%/watermark.html
+@dirrm %%WWWDIR%%/templates
+@dirrm %%WWWDIR%%/includes
+@dirrm %%WWWDIR%%/images/login
+@dirrm %%WWWDIR%%/images/icons
+@dirrm %%WWWDIR%%/images/googiespell
+@dirrm %%WWWDIR%%/images/display
+@dirrm %%WWWDIR%%/images/buttons
+@dirrm %%WWWDIR%%/images
+@dirrmtry %%WWWDIR%%