aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-05-07 13:51:52 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-05-07 13:51:52 +0000
commit4aa109a0dc1ba0fa59f2b015878b24dc02b54b42 (patch)
tree58855a05bcc5b2d91f5f28f23e197404fd7725ed /mail/roundcube
parent9d1a0529337fbc8b2236839451a78defdc387337 (diff)
downloadports-4aa109a0dc1ba0fa59f2b015878b24dc02b54b42.tar.gz
ports-4aa109a0dc1ba0fa59f2b015878b24dc02b54b42.zip
Update to 0.9.0 release.
Notes
Notes: svn path=/head/; revision=317607
Diffstat (limited to 'mail/roundcube')
-rw-r--r--mail/roundcube/Makefile14
-rw-r--r--mail/roundcube/distinfo4
-rw-r--r--mail/roundcube/files/patch-program_include_iniset.php10
-rw-r--r--mail/roundcube/files/patch-program_include_rcube_session.php91
-rw-r--r--mail/roundcube/files/patch-program_lib_Roundcube_rcube_message.php (renamed from mail/roundcube/files/patch-program_include_rcube_message.php)4
-rw-r--r--mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php103
6 files changed, 119 insertions, 107 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index 111e5e12cd1e..e46cb3f544c2 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= roundcube
-DISTVERSION= 0.8.6
+DISTVERSION= 0.9.0
PORTEPOCH= 1
CATEGORIES?= mail www
MASTER_SITES= SF/${PORTNAME}mail/${PORTNAME}mail/${DISTVERSION:U}
@@ -23,8 +23,8 @@ SCRIPTS_ENV= SHAREOWN=${SHAREOWN} SHAREGRP=${SHAREGRP} \
WWWDIR=${WWWDIR}
WANT_PHP_WEB= yes
-USE_PHP= pcre mbstring session iconv dom xml json intl
-IGNORE_WITH_PHP=4
+USE_PHP= pcre mbstring session iconv dom xml json intl zip
+IGNORE_WITH_PHP=52
OPTIONS_DEFINE= SSL LDAP GD PSPELL NSC
OPTIONS_SINGLE= DB
@@ -33,7 +33,7 @@ OPTIONS_DEFAULT=MYSQL
MYSQL_DESC= Use MySQL backend
PGSQL_DESC= Use PostgreSQL backend
-SQLITE_DESC= Use SQLite backend (needs PHP 5.3 or below)
+SQLITE_DESC= Use SQLite backend
SSL_DESC= Enable SSL support (imaps or google spellcheck)
LDAP_DESC= Enable LDAP support (address book)
GD_DESC= Enable GD support (image conversion)
@@ -43,15 +43,15 @@ NSC_DESC= Install network spellchecker
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
+USE_PHP+= pdo_mysql
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pgsql
+USE_PHP+= pdo_pgsql
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite
+USE_PHP+= pdo_sqlite
.endif
.if ${PORT_OPTIONS:MSSL}
diff --git a/mail/roundcube/distinfo b/mail/roundcube/distinfo
index c64789d533a8..cb75bd145ace 100644
--- a/mail/roundcube/distinfo
+++ b/mail/roundcube/distinfo
@@ -1,2 +1,2 @@
-SHA256 (roundcubemail-0.8.6.tar.gz) = 88128db0dc57651e08beb3c4811bc9e33aca1c39a50cfc9efb5d14b0baa17704
-SIZE (roundcubemail-0.8.6.tar.gz) = 3724565
+SHA256 (roundcubemail-0.9.0.tar.gz) = 7edab9579cd2a6353c30de3fcfc86da231f0a46f7ad4ce707090813173f662c2
+SIZE (roundcubemail-0.9.0.tar.gz) = 3711615
diff --git a/mail/roundcube/files/patch-program_include_iniset.php b/mail/roundcube/files/patch-program_include_iniset.php
index aab818353fee..014c1b7f682d 100644
--- a/mail/roundcube/files/patch-program_include_iniset.php
+++ b/mail/roundcube/files/patch-program_include_iniset.php
@@ -1,10 +1,10 @@
---- program/include/iniset.php.orig 2012-08-06 18:18:13.000000000 +0200
-+++ program/include/iniset.php 2012-08-13 12:37:50.000000000 +0200
-@@ -29,7 +29,6 @@
+--- program/include/iniset.php.orig 2013-04-15 22:42:21.000000000 +0200
++++ program/include/iniset.php 2013-05-07 12:40:34.000000000 +0200
+@@ -28,7 +28,6 @@
+ // Some users are not using Installer, so we'll check some
// critical PHP settings here. Only these, which doesn't provide
// an error/warning in the logs later. See (#1486307).
- 'mbstring.func_overload' => 0,
- 'suhosin.session.encrypt' => 0,
'session.auto_start' => 0,
'file_uploads' => 1,
- 'magic_quotes_runtime' => 0,
+ );
diff --git a/mail/roundcube/files/patch-program_include_rcube_session.php b/mail/roundcube/files/patch-program_include_rcube_session.php
deleted file mode 100644
index 6797dfebd9c7..000000000000
--- a/mail/roundcube/files/patch-program_include_rcube_session.php
+++ /dev/null
@@ -1,91 +0,0 @@
---- program/include/rcube_session.php.orig 2012-08-06 18:18:13.000000000 +0200
-+++ program/include/rcube_session.php 2012-08-13 12:44:54.000000000 +0200
-@@ -37,7 +37,6 @@
- private $ip;
- private $start;
- private $changed;
-- private $unsets = array();
- private $gc_handlers = array();
- private $cookiename = 'roundcube_sessauth';
- private $vars;
-@@ -134,7 +133,7 @@
- if ($sql_result && ($sql_arr = $this->db->fetch_assoc($sql_result))) {
- $this->changed = strtotime($sql_arr['changed']);
- $this->ip = $sql_arr['ip'];
-- $this->vars = base64_decode($sql_arr['vars']);
-+ $this->vars = $sql_arr['vars'];
- $this->key = $key;
-
- return !empty($this->vars) ? (string) $this->vars : '';
-@@ -170,13 +169,13 @@
- }
-
- if ($oldvars !== null) {
-- $newvars = $this->_fixvars($vars, $oldvars);
-+ $newvars = $vars;
-
- if ($newvars !== $oldvars) {
- $this->db->query(
- sprintf("UPDATE %s SET vars=?, changed=%s WHERE sess_id=?",
- get_table_name('session'), $now),
-- base64_encode($newvars), $key);
-+ $newvars, $key);
- }
- else if ($ts - $this->changed > $this->lifetime / 2) {
- $this->db->query("UPDATE ".get_table_name('session')." SET changed=$now WHERE sess_id=?", $key);
-@@ -187,7 +186,7 @@
- sprintf("INSERT INTO %s (sess_id, vars, ip, created, changed) ".
- "VALUES (?, ?, ?, %s, %s)",
- get_table_name('session'), $now, $now),
-- $key, base64_encode($vars), (string)$this->ip);
-+ $key, $vars, (string)$this->ip);
- }
-
- return true;
-@@ -195,29 +194,6 @@
-
-
- /**
-- * Merge vars with old vars and apply unsets
-- */
-- private function _fixvars($vars, $oldvars)
-- {
-- if ($oldvars !== null) {
-- $a_oldvars = $this->unserialize($oldvars);
-- if (is_array($a_oldvars)) {
-- foreach ((array)$this->unsets as $k)
-- unset($a_oldvars[$k]);
--
-- $newvars = $this->serialize(array_merge(
-- (array)$a_oldvars, (array)$this->unserialize($vars)));
-- }
-- else
-- $newvars = $vars;
-- }
--
-- $this->unsets = array();
-- return $newvars;
-- }
--
--
-- /**
- * Handler for session_destroy()
- *
- * @param string Session ID
-@@ -296,7 +272,7 @@
- else // else read data again
- $oldvars = $this->mc_read($key);
-
-- $newvars = $oldvars !== null ? $this->_fixvars($vars, $oldvars) : $vars;
-+ $newvars = $vars;
-
- if ($newvars !== $oldvars || $ts - $this->changed > $this->lifetime / 2)
- return $this->memcache->set($key, serialize(array('changed' => time(), 'ip' => $this->ip, 'vars' => $newvars)), MEMCACHE_COMPRESSED, $this->lifetime);
-@@ -376,7 +352,6 @@
- if (empty($var))
- return $this->destroy(session_id());
-
-- $this->unsets[] = $var;
- unset($_SESSION[$var]);
-
- return true;
diff --git a/mail/roundcube/files/patch-program_include_rcube_message.php b/mail/roundcube/files/patch-program_lib_Roundcube_rcube_message.php
index d5396549aa92..836d2429784e 100644
--- a/mail/roundcube/files/patch-program_include_rcube_message.php
+++ b/mail/roundcube/files/patch-program_lib_Roundcube_rcube_message.php
@@ -1,5 +1,5 @@
---- program/include/rcube_message.php.orig 2010-11-26 13:41:16.000000000 +0100
-+++ program/include/rcube_message.php 2010-12-13 17:20:59.000000000 +0100
+--- program/lib/Roundcube/rcube_message.php.orig 2010-11-26 13:41:16.000000000 +0100
++++ program/lib/Roundcube/rcube_message.php 2010-12-13 17:20:59.000000000 +0100
@@ -452,9 +452,7 @@
}
// part is a file/attachment
diff --git a/mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php b/mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php
new file mode 100644
index 000000000000..1854ea3038c1
--- /dev/null
+++ b/mail/roundcube/files/patch-program_lib_Roundcube_rcube_session.php
@@ -0,0 +1,103 @@
+--- program/lib/Roundcube/rcube_session.php.orig 2013-04-15 22:42:22.000000000 +0200
++++ program/lib/Roundcube/rcube_session.php 2013-05-07 12:49:19.000000000 +0200
+@@ -33,7 +33,6 @@
+ private $start;
+ private $changed;
+ private $reloaded = false;
+- private $unsets = array();
+ private $gc_handlers = array();
+ private $cookiename = 'roundcube_sessauth';
+ private $vars;
+@@ -131,7 +130,7 @@
+ if ($sql_result && ($sql_arr = $this->db->fetch_assoc($sql_result))) {
+ $this->changed = strtotime($sql_arr['changed']);
+ $this->ip = $sql_arr['ip'];
+- $this->vars = base64_decode($sql_arr['vars']);
++ $this->vars = $sql_arr['vars'];
+ $this->key = $key;
+
+ return !empty($this->vars) ? (string) $this->vars : '';
+@@ -168,13 +167,13 @@
+ }
+
+ if ($oldvars !== null) {
+- $newvars = $this->_fixvars($vars, $oldvars);
++ $newvars = $vars;
+
+ if ($newvars !== $oldvars) {
+ $this->db->query(
+ sprintf("UPDATE %s SET vars=?, changed=%s WHERE sess_id=?",
+ $this->db->table_name('session'), $now),
+- base64_encode($newvars), $key);
++ $newvars, $key);
+ }
+ else if ($ts - $this->changed > $this->lifetime / 2) {
+ $this->db->query("UPDATE ".$this->db->table_name('session')
+@@ -186,7 +185,7 @@
+ sprintf("INSERT INTO %s (sess_id, vars, ip, created, changed) ".
+ "VALUES (?, ?, ?, %s, %s)",
+ $this->db->table_name('session'), $now, $now),
+- $key, base64_encode($vars), (string)$this->ip);
++ $key, $vars, (string)$this->ip);
+ }
+
+ return true;
+@@ -194,40 +193,6 @@
+
+
+ /**
+- * Merge vars with old vars and apply unsets
+- */
+- private function _fixvars($vars, $oldvars)
+- {
+- if ($oldvars !== null) {
+- $a_oldvars = $this->unserialize($oldvars);
+- if (is_array($a_oldvars)) {
+- // remove unset keys on oldvars
+- foreach ((array)$this->unsets as $var) {
+- if (isset($a_oldvars[$k])) {
+- unset($a_oldvars[$k]);
+- }
+- else {
+- $path = explode('.', $var);
+- $k = array_pop($path);
+- $node = &$this->get_node($path, $a_oldvars);
+- unset($node[$k]);
+- }
+- }
+-
+- $newvars = $this->serialize(array_merge(
+- (array)$a_oldvars, (array)$this->unserialize($vars)));
+- }
+- else {
+- $newvars = $vars;
+- }
+- }
+-
+- $this->unsets = array();
+- return $newvars;
+- }
+-
+-
+- /**
+ * Handler for session_destroy()
+ *
+ * @param string Session ID
+@@ -308,7 +273,7 @@
+ else // else read data again
+ $oldvars = $this->mc_read($key);
+
+- $newvars = $oldvars !== null ? $this->_fixvars($vars, $oldvars) : $vars;
++ $newvars = $vars;
+
+ if ($newvars !== $oldvars || $ts - $this->changed > $this->lifetime / 2) {
+ return $this->memcache->set($key, serialize(array('changed' => time(), 'ip' => $this->ip, 'vars' => $newvars)),
+@@ -416,8 +381,6 @@
+ return $this->destroy(session_id());
+ }
+
+- $this->unsets[] = $var;
+-
+ if (isset($_SESSION[$var])) {
+ unset($_SESSION[$var]);
+ }