aboutsummaryrefslogtreecommitdiff
path: root/mail/sendmail-old
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-10-02 05:47:59 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-10-02 05:47:59 +0000
commit240b393ed3a17f0890eaa557810ca8329db8c34c (patch)
treebe28f939b893a91197ad69e751bc0a2f1e9c0600 /mail/sendmail-old
parent26510e100b6ec0d853f01d4642135fbc5a0f8c9d (diff)
downloadports-240b393ed3a17f0890eaa557810ca8329db8c34c.tar.gz
ports-240b393ed3a17f0890eaa557810ca8329db8c34c.zip
- Add a patch for some nameserver problems
sendmail 8.11.6, failing DNS AAAA lookups Has been mentioned on freebsd-stable Subject: something strange with sendmail 8.11.6 on FreeBSD Submitted by: gshapiro@freebsd.org
Notes
Notes: svn path=/head/; revision=48329
Diffstat (limited to 'mail/sendmail-old')
-rw-r--r--mail/sendmail-old/Makefile1
-rw-r--r--mail/sendmail-old/files/patch-daemon.c39
2 files changed, 40 insertions, 0 deletions
diff --git a/mail/sendmail-old/Makefile b/mail/sendmail-old/Makefile
index dd00a414b7cc..d9ccf963e7dd 100644
--- a/mail/sendmail-old/Makefile
+++ b/mail/sendmail-old/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sendmail
PORTVERSION= 8.11.6
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/mail/sendmail/&,}
diff --git a/mail/sendmail-old/files/patch-daemon.c b/mail/sendmail-old/files/patch-daemon.c
new file mode 100644
index 000000000000..5ed34a14e2c8
--- /dev/null
+++ b/mail/sendmail-old/files/patch-daemon.c
@@ -0,0 +1,39 @@
+--- sendmail/daemon.c 2001/08/01 03:19:45 1.1.1.3.2.6
++++ sendmail/daemon.c 2001/09/09 19:31:37
+@@ -1877,17 +1877,6 @@
+ gothostent:
+ if (hp == NULL)
+ {
+-# if NAMED_BIND
+- /* check for name server timeouts */
+- if (errno == ETIMEDOUT || h_errno == TRY_AGAIN ||
+- (errno == ECONNREFUSED && UseNameServer))
+- {
+- save_errno = errno;
+- mci_setstat(mci, EX_TEMPFAIL, "4.4.3", NULL);
+- errno = save_errno;
+- return EX_TEMPFAIL;
+- }
+-# endif /* NAMED_BIND */
+ # if NETINET6
+ /*
+ ** Try v6 first, then fall back to v4.
+@@ -1903,6 +1892,17 @@
+ if (v6found)
+ goto v6tempfail;
+ # endif /* NETINET6 */
++# if NAMED_BIND
++ /* check for name server timeouts */
++ if (errno == ETIMEDOUT || h_errno == TRY_AGAIN ||
++ (errno == ECONNREFUSED && UseNameServer))
++ {
++ save_errno = errno;
++ mci_setstat(mci, EX_TEMPFAIL, "4.4.3", NULL);
++ errno = save_errno;
++ return EX_TEMPFAIL;
++ }
++# endif /* NAMED_BIND */
+ save_errno = errno;
+ mci_setstat(mci, EX_NOHOST, "5.1.2", NULL);
+ errno = save_errno;
+