aboutsummaryrefslogtreecommitdiff
path: root/mail/sendmail-old
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-05-01 12:10:05 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-05-01 12:10:05 +0000
commit3e48e0246ddd7176bb7a6d75b754be9d64930f58 (patch)
tree9d020cc3adea95e4cc664bea28a6ede6045a7fe8 /mail/sendmail-old
parent461d152738d98fda74ed4a8a759b28a069796001 (diff)
downloadports-3e48e0246ddd7176bb7a6d75b754be9d64930f58.tar.gz
ports-3e48e0246ddd7176bb7a6d75b754be9d64930f58.zip
- Option to add LDAP Support
- Cleanup dublicate labels - Allow to build a package manually. Submitted by: phantom@ark.cris.net (Alexey Zelkin)
Notes
Notes: svn path=/head/; revision=42128
Diffstat (limited to 'mail/sendmail-old')
-rw-r--r--mail/sendmail-old/Makefile19
-rw-r--r--mail/sendmail-old/files/site.config.m4.ldap5
2 files changed, 16 insertions, 8 deletions
diff --git a/mail/sendmail-old/Makefile b/mail/sendmail-old/Makefile
index 2572f957af7d..398c22bfe85c 100644
--- a/mail/sendmail-old/Makefile
+++ b/mail/sendmail-old/Makefile
@@ -13,7 +13,9 @@ DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= dirk.meyer@dinoex.sub.org
+.if defined(BATCH)
NO_PACKAGE= "sendmail included in base system"
+.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WCONF= ${WRKSRC}/devtools/Site
@@ -25,6 +27,7 @@ PLIST= ${WRKDIR}/.PLIST.more
# SENDMAIL_WITH_SASL=YES
# SENDMAIL_WITH_SFIO=YES
# SENDMAIL_WITH_MILTER=YES
+# SENDMAIL_WITH_LDAP=YES
.if defined(SENDMAIL_WITH_TLS)
USE_OPENSSL= yes
@@ -35,6 +38,10 @@ BUILD_DEPENDS= ${LOCALBASE}/sbin/pwcheck:${PORTSDIR}/security/cyrus-sasl
.if defined(SENDMAIL_WITH_SFIO)
BUILD_DEPENDS= ${LOCALBASE}/lib/libsfio.a:${PORTSDIR}/devel/sfio
.endif
+.if defined(SENDMAIL_WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap2
+.endif
.if exists(${DESTDIR}/etc/mail/mailer.conf)
pre-configure:
@@ -59,6 +66,10 @@ pre-configure:
${SED} -e "s=%%LOCALBASE%%=${LOCALBASE}=" \
${FILESDIR}/site.config.m4.ssl >> ${WCONF}/site.config.m4
.endif
+.if defined(SENDMAIL_WITH_LDAP)
+ ${SED} -e "s=%%LOCALBASE%%=${LOCALBASE}=" \
+ ${FILESDIR}/site.config.m4.ldap >> ${WCONF}/site.config.m4
+.endif
.if exists(${FILESDIR}/site.config.m4.local)
${SED} -e "s=%%LOCALBASE%%=${LOCALBASE}=" \
${FILESDIR}/site.config.m4.local >> ${WCONF}/site.config.m4
@@ -143,12 +154,4 @@ mailer.conf:
${MV} ${DESTDIR}/etc/mail/mailer.conf.new ${DESTDIR}/etc/mail/mailer.conf
.endif
-.if defined(SENDMAIL_WITH_MILTER)
-post-configure:
- ${CAT} ${FILESDIR}/site.config.m4.milter >>${WCONF}/site.config.m4
-
-post-build:
- ( cd ${WRKSRC}/libmilter && ${MAKE} )
-.endif
-
.include <bsd.port.mk>
diff --git a/mail/sendmail-old/files/site.config.m4.ldap b/mail/sendmail-old/files/site.config.m4.ldap
new file mode 100644
index 000000000000..c03a8749c808
--- /dev/null
+++ b/mail/sendmail-old/files/site.config.m4.ldap
@@ -0,0 +1,5 @@
+APPENDDEF(`confLIBDIRS', `-L%%LOCALBASE%%/lib')
+APPENDDEF(`conf_sendmail_ENVDEF', `-I%%LOCALBASE%%/include')
+APPENDDEF(`conf_sendmail_ENVDEF', `-DLDAPMAP')
+APPENDDEF(`conf_sendmail_LIBS', `-lldap')
+APPENDDEF(`conf_sendmail_LIBS', `-llber')