aboutsummaryrefslogtreecommitdiff
path: root/mail/slapd-cyrus
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /mail/slapd-cyrus
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'mail/slapd-cyrus')
-rw-r--r--mail/slapd-cyrus/Makefile6
-rw-r--r--mail/slapd-cyrus/pkg-plist6
2 files changed, 3 insertions, 9 deletions
diff --git a/mail/slapd-cyrus/Makefile b/mail/slapd-cyrus/Makefile
index 6c63346950d1..fdf24ba525fc 100644
--- a/mail/slapd-cyrus/Makefile
+++ b/mail/slapd-cyrus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slapd-cyrus
PORTVERSION= 1.00
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail net
MASTER_SITES= SF/${PORTNAME}
DISTNAME= Slapd-Backend-Cyrus-${PORTVERSION}
@@ -29,9 +29,9 @@ PLIST_SUB= SITE_PERL_REL=${SITE_PERL_REL} \
PORTDOCS= slapd-cyrus.conf.sample
do-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${SITE_PERL}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
${INSTALL_DATA} -m 0444 ${WRKSRC}/t/etc/slapd.conf.dist \
${STAGEDIR}${DOCSDIR}/slapd-cyrus.conf.sample
- cd ${WRKSRC}/lib && ${PAX} -r -w . ${STAGEDIR}${SITE_PERL}
+ cd ${WRKSRC}/lib && ${PAX} -r -w . ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
.include <bsd.port.mk>
diff --git a/mail/slapd-cyrus/pkg-plist b/mail/slapd-cyrus/pkg-plist
index 150d3a94c322..f73baf7db9e7 100644
--- a/mail/slapd-cyrus/pkg-plist
+++ b/mail/slapd-cyrus/pkg-plist
@@ -7,9 +7,3 @@
%%SITE_PERL_REL%%/Slapd/Backend/Proxy.pm
%%SITE_PERL_REL%%/Slapd/Backend/Proxy/Store.pm
%%SITE_PERL_REL%%/Slapd/Backend/Proxy/Store/BerkeleyDB.pm
-@dirrmtry %%SITE_PERL_REL%%/Slapd/Backend/Proxy/Store
-@dirrmtry %%SITE_PERL_REL%%/Slapd/Backend/Proxy
-@dirrmtry %%SITE_PERL_REL%%/Slapd/Backend/Cyrus
-@dirrmtry %%SITE_PERL_REL%%/Slapd/Backend
-@dirrmtry %%SITE_PERL_REL%%/Slapd
-@dirrmtry %%SITE_PERL_REL%%