aboutsummaryrefslogtreecommitdiff
path: root/mail/smtpd
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-07-03 23:30:35 +0000
committerSteve Price <steve@FreeBSD.org>1998-07-03 23:30:35 +0000
commitfda894de422b4100d585950a41f2aa23d44edd4d (patch)
treef90c8ce71ffe43ff2e4ddb63f883c5e624b917fa /mail/smtpd
parent3beadf2660ca14f0d691aff5bd26fe1eb14fc255 (diff)
downloadports-fda894de422b4100d585950a41f2aa23d44edd4d.tar.gz
ports-fda894de422b4100d585950a41f2aa23d44edd4d.zip
Make this compile again in -current.
PR: 6977 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=11694
Diffstat (limited to 'mail/smtpd')
-rw-r--r--mail/smtpd/Makefile6
-rw-r--r--mail/smtpd/files/patch-ab16
-rw-r--r--mail/smtpd/files/smtpd.sh2
3 files changed, 20 insertions, 4 deletions
diff --git a/mail/smtpd/Makefile b/mail/smtpd/Makefile
index d45778afa73a..e4061eefcbe0 100644
--- a/mail/smtpd/Makefile
+++ b/mail/smtpd/Makefile
@@ -1,9 +1,9 @@
# Ports collection makefile for: smtpd
# Version required: 2.0
# Date created: 06 Feb 1998
-# Whom: Joao Carlos Mendes Luis <jonny@coppe.ufrj.br>
+# Whom: Joao Carlos Mendes Luis <jonny@jonny.eng.br>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/03/01 01:58:51 obrien Exp $
#
DISTNAME= smtpd-2.0
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.obtuse.com/pub/smtpd/
PATCH_SITES= ${MASTER_SITES}
PATCHFILES= patch-smtpd-2.0-RBL.gz
-MAINTAINER= jonny@coppe.ufrj.br
+MAINTAINER= jonny@jonny.eng.br
# Directory where smtpd will chroot to, and put the received mail
# If you change it here, change also patches/patch-aa
diff --git a/mail/smtpd/files/patch-ab b/mail/smtpd/files/patch-ab
new file mode 100644
index 000000000000..a59be0babfff
--- /dev/null
+++ b/mail/smtpd/files/patch-ab
@@ -0,0 +1,16 @@
+--- smtpfwdd.c.org Wed Jun 17 21:21:10 1998
++++ smtpfwdd.c Wed Jun 17 21:21:22 1998
+@@ -43,12 +43,12 @@
+ "Copyright 1996 - Obtuse Systems Corporation - All rights reserved.";
+ char *obtuse_rcsid = "$Id: smtpfwdd.c,v 1.35 1997/12/12 04:07:49 beck Exp $";
+
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <signal.h>
+ #include <dirent.h>
+ #include <pwd.h>
+ #include <grp.h>
+-#include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <sys/stat.h>
diff --git a/mail/smtpd/files/smtpd.sh b/mail/smtpd/files/smtpd.sh
index a902971eb00d..3aaf433a31d4 100644
--- a/mail/smtpd/files/smtpd.sh
+++ b/mail/smtpd/files/smtpd.sh
@@ -3,7 +3,7 @@
if [ $# -eq 0 -o "$1" = "start" ]; then
if [ -x !!PREFIX!!/sbin/smtpfwdd ] ; then
!!PREFIX!!/sbin/smtpfwdd
- echo " smtpfwdd"
+ echo -n " smtpfwdd"
fi
fi
if [ "$1" = "stop" ]; then