aboutsummaryrefslogtreecommitdiff
path: root/mail/softfail
diff options
context:
space:
mode:
authorJean Milanez Melo <jmelo@FreeBSD.org>2007-02-08 15:48:39 +0000
committerJean Milanez Melo <jmelo@FreeBSD.org>2007-02-08 15:48:39 +0000
commitd111774445b076083dbe5d83aecd0afb747d8d1c (patch)
tree86b66aa30aa3a46bf218a96167e3e2dc71fb3189 /mail/softfail
parentfeb679cb9eea5fcf3980c978f4a764fe0ed11c44 (diff)
downloadports-d111774445b076083dbe5d83aecd0afb747d8d1c.tar.gz
ports-d111774445b076083dbe5d83aecd0afb747d8d1c.zip
- Fix to don't add crontab entry automatically. Now the user should type 'make crontab-entry' to do it.
PR: ports/108931 Submitted by: Patrick Tracanelli <eksffa@freebsdbrasil.com.br> (maintainer)
Notes
Notes: svn path=/head/; revision=184582
Diffstat (limited to 'mail/softfail')
-rw-r--r--mail/softfail/Makefile7
-rw-r--r--mail/softfail/files/pkg-message.in10
2 files changed, 13 insertions, 4 deletions
diff --git a/mail/softfail/Makefile b/mail/softfail/Makefile
index e67ad7db0572..000cb7cca998 100644
--- a/mail/softfail/Makefile
+++ b/mail/softfail/Makefile
@@ -34,6 +34,9 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
+crontab-entry: extract
+ @cd ${WRKSRC} && ${MAKE} crontab-entry
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You can use the following build options:"
@@ -107,15 +110,13 @@ post-patch:
${WRKSRC}/rotate-softfail.sh
.endif
-post-install:
- @cd ${WRKSRC} && ${MAKE} crontab-entry
-
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/softfail.sql ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
+post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/mail/softfail/files/pkg-message.in b/mail/softfail/files/pkg-message.in
index f12b67538ceb..08768ba322a1 100644
--- a/mail/softfail/files/pkg-message.in
+++ b/mail/softfail/files/pkg-message.in
@@ -10,9 +10,17 @@ SQL sample was installed on
You can use this sample as root user for MySQL:
- mysql -uroot -p < %%DOCSDIR%%/softfail.sql
+ mysql -uroot -p < %%DOCSDIR%%/softfail.sql
To use it you should configure SMTPEXTFORK's enviroment variable on qmail
according to the instructions available on
%%DOCSDIR%%/README
+
+You are also suggested to add the following entries to /etc/crontab:
+
+ @daily root %%PREFIX%%/bin/rotate-softfail-db
+ @daily root %%PREFIX%%/bin/rotate-softfail.sh
+
+I can do it for you. Just type `make crontab-entry' if you wish me to add it.
+