aboutsummaryrefslogtreecommitdiff
path: root/mail/spamass-ixhash/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2010-11-24 10:25:51 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2010-11-24 10:25:51 +0000
commit5643c568b4112b1f96b1f9d4a55ddbf9bc989a0a (patch)
tree22be118d8e5bbd4dded28c12a37e41fb0bf4ef29 /mail/spamass-ixhash/Makefile
parent981c58316a8f9022e3e9ac7769a792e142e12240 (diff)
downloadports-5643c568b4112b1f96b1f9d4a55ddbf9bc989a0a.tar.gz
ports-5643c568b4112b1f96b1f9d4a55ddbf9bc989a0a.zip
Add spamass-ixhash, a plugin for Spamassassin, that
computes MD5 checksums of fragments of the body of an e-mail and compares them to those of know spam. PR: 152216 Submitted by: Michael Ranner
Notes
Notes: svn path=/head/; revision=265077
Diffstat (limited to 'mail/spamass-ixhash/Makefile')
-rw-r--r--mail/spamass-ixhash/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/mail/spamass-ixhash/Makefile b/mail/spamass-ixhash/Makefile
new file mode 100644
index 000000000000..b7aef99ee3df
--- /dev/null
+++ b/mail/spamass-ixhash/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: spamass-ixhash
+# Date created: 2010-11-12
+# Whom: Michael Ranner <michael@ranner.eu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iXhash
+PORTVERSION= 1.5.5
+CATEGORIES= mail
+MASTER_SITES= SF/ixhash/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
+PKGNAMEPREFIX= spamass-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= michael@ranner.eu
+COMMENT= The iXhash plugin for SpamAssassin
+
+RUN_DEPENDS= spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Net-DNS>=0.63:${PORTSDIR}/dns/p5-Net-DNS
+
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+SUB_FILES= pkg-message
+NO_BUILD= yes
+SPAMASS_CONF= etc/mail/spamassassin
+SPAMASS_FILES= iXhash.cf iXhash.pm
+INSTALL_DIR= ${PREFIX}/${SPAMASS_CONF}
+
+PORTDOCS= CHANGELOG LICENSE WHERE_ARE_THE_OTHER_FILES INSTALL README
+PLIST_FILES= ${SPAMASS_CONF}/iXhash.cf.sample ${SPAMASS_CONF}/iXhash.pm
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/etc/mail,${LOCALBASE}/etc/mail," \
+ ${WRKSRC}/iXhash/iXhash.cf
+
+do-install:
+ @${MKDIR} ${INSTALL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/iXhash/iXhash.cf ${INSTALL_DIR}/iXhash.cf.sample
+ ${INSTALL_DATA} ${WRKSRC}/iXhash/iXhash.pm ${INSTALL_DIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+. for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+. endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>