aboutsummaryrefslogtreecommitdiff
path: root/mail/spfval
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-25 05:51:35 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-25 05:51:35 +0000
commit89752096b879a50bff84792bdde6824b9605b4ac (patch)
treefd4d2689113e23330c6e7c49ebe15660e5527e58 /mail/spfval
parentd075de0076e4717e10e1452fc769ed1c451dc2fc (diff)
downloadports-89752096b879a50bff84792bdde6824b9605b4ac.tar.gz
ports-89752096b879a50bff84792bdde6824b9605b4ac.zip
Add spfval.
Spfval validates SPF records. It does not check them via the network, this was intentionally omitted in favour of focusing purely on syntactically validating SPF records. Simply pass the validator a string and it will see if it validates as an SPFv1 or SPF-Classic record. If an error is found, it tries its best to report the error in question and the specific location in the record where the error occured. WWW: http://spfval.codeshare.ca/ PR: ports/83899 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=140057
Diffstat (limited to 'mail/spfval')
-rw-r--r--mail/spfval/Makefile24
-rw-r--r--mail/spfval/distinfo2
-rw-r--r--mail/spfval/files/patch-src_spfval_spfval.c10
-rw-r--r--mail/spfval/files/patch-src_spfval_util.h10
-rw-r--r--mail/spfval/pkg-descr12
5 files changed, 58 insertions, 0 deletions
diff --git a/mail/spfval/Makefile b/mail/spfval/Makefile
new file mode 100644
index 000000000000..c060dc91b93d
--- /dev/null
+++ b/mail/spfval/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: spfval
+# Date created: 22 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spfval
+PORTVERSION= 0.0.1
+CATEGORIES= mail
+MASTER_SITES= http://spfval.codeshare.ca/files/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A SPF validator
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/spfval
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/spfval ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/spfval/distinfo b/mail/spfval/distinfo
new file mode 100644
index 000000000000..c4dc45c471fc
--- /dev/null
+++ b/mail/spfval/distinfo
@@ -0,0 +1,2 @@
+MD5 (spfval-0.0.1.tar.bz2) = 512b0c3cb4020a6a1b2584f7e4b85700
+SIZE (spfval-0.0.1.tar.bz2) = 131635
diff --git a/mail/spfval/files/patch-src_spfval_spfval.c b/mail/spfval/files/patch-src_spfval_spfval.c
new file mode 100644
index 000000000000..93a8f4ae0e8d
--- /dev/null
+++ b/mail/spfval/files/patch-src_spfval_spfval.c
@@ -0,0 +1,10 @@
+--- src/spfval/spfval.c.orig Mon Jul 25 07:46:21 2005
++++ src/spfval/spfval.c Mon Jul 25 07:46:30 2005
+@@ -44,6 +44,7 @@
+ #include <stdio.h> /* printf */
+ #include <stdlib.h> /* malloc / free */
+ #include <string.h> /* printf */
++#include <sys/types.h>
+ #include <sys/socket.h> /* inet_ntoa */
+ #include <netinet/in.h> /* inet_ntoa / ntohl */
+ #include <arpa/inet.h> /* inet_ntoa */
diff --git a/mail/spfval/files/patch-src_spfval_util.h b/mail/spfval/files/patch-src_spfval_util.h
new file mode 100644
index 000000000000..9b7fb240101f
--- /dev/null
+++ b/mail/spfval/files/patch-src_spfval_util.h
@@ -0,0 +1,10 @@
+--- src/spfval/util.h.orig Mon Jul 25 07:43:56 2005
++++ src/spfval/util.h Mon Jul 25 07:44:25 2005
+@@ -45,6 +45,7 @@
+ #define _UTIL_H 1
+
+ #include <stdlib.h> /* malloc / free */
++#include <sys/types.h>
+ #include <netinet/in.h> /* in_addr struct fBSD */
+ #include <arpa/inet.h> /* in_addr struct */
+
diff --git a/mail/spfval/pkg-descr b/mail/spfval/pkg-descr
new file mode 100644
index 000000000000..a4a5ec5effe5
--- /dev/null
+++ b/mail/spfval/pkg-descr
@@ -0,0 +1,12 @@
+Spfval validates SPF records. It does not check them via the network, this was
+intentionally omitted in favour of focusing purely on syntactically validating
+SPF records. Simply pass the validator a string and it will see if it validates
+as an SPFv1 or SPF-Classic record.
+
+If an error is found, it tries its best to report the error in question and the
+specific location in the record where the error occured.
+
+WWW: http://spfval.codeshare.ca/
+
+- ehaupt
+ehaupt@critical.ch