aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-calendar_file_backend-plugin
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2012-11-10 01:37:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2012-11-10 01:37:24 +0000
commit14f5b9b330ef0eb94af8a844fc910d5589592ec6 (patch)
tree45fdb1d9af176a1041803788fbf5c9c2a0db4cbd /mail/squirrelmail-calendar_file_backend-plugin
parent90461f79f59a492dde6eba53a6d8c35ebed79c04 (diff)
downloadports-14f5b9b330ef0eb94af8a844fc910d5589592ec6.tar.gz
ports-14f5b9b330ef0eb94af8a844fc910d5589592ec6.zip
Convert remaining squirrelmail plugins to bsd.squirrelmail.mk. Because they
were duplicating the content there, php version mismatches were created and package building broke. Also includes a few whitespace and header fixes due to OCD. Feature safe: yes
Notes
Notes: svn path=/head/; revision=307260
Diffstat (limited to 'mail/squirrelmail-calendar_file_backend-plugin')
-rw-r--r--mail/squirrelmail-calendar_file_backend-plugin/Makefile63
1 files changed, 4 insertions, 59 deletions
diff --git a/mail/squirrelmail-calendar_file_backend-plugin/Makefile b/mail/squirrelmail-calendar_file_backend-plugin/Makefile
index 6698b6e63e20..d31904a004bf 100644
--- a/mail/squirrelmail-calendar_file_backend-plugin/Makefile
+++ b/mail/squirrelmail-calendar_file_backend-plugin/Makefile
@@ -1,73 +1,18 @@
-# New ports collection makefile for: squirrelmail-calendar_file_backend-plugin
-# Date created: 02 Jan 2008
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
PORTNAME= calendar_file_backend
PORTVERSION= 1.0
PORTREVISION= 1
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-PKGNAMEPREFIX= squirrelmail-
-PKGNAMESUFFIX= -plugin
DISTNAME= ${PORTNAME}-${PORTVERSION}-2.0
DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= File backend for SquirrelMail Calendar plugin
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
-
SQUIRREL_PLUGIN_NAME= ${PORTNAME}
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-USE_PHP= yes
-WANT_PHP_WEB= yes
-
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>