aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-compatibility-plugin/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-24 21:17:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-24 21:17:41 +0000
commit05ddfaecde4e8918206e128dbf4c9f40c01a726d (patch)
tree81b8ef2931e31bd3abf1a6511d03924a376efc83 /mail/squirrelmail-compatibility-plugin/Makefile
parent879b41a2ea4705c06c3c984abe8b82fcc9704cfc (diff)
downloadports-05ddfaecde4e8918206e128dbf4c9f40c01a726d.tar.gz
ports-05ddfaecde4e8918206e128dbf4c9f40c01a726d.zip
- Update to 2.0.6
PR: 108279 Submitted by: Alexander Wittig <alexander@wittig.name> (maintainer)
Notes
Notes: svn path=/head/; revision=183205
Diffstat (limited to 'mail/squirrelmail-compatibility-plugin/Makefile')
-rw-r--r--mail/squirrelmail-compatibility-plugin/Makefile45
1 files changed, 23 insertions, 22 deletions
diff --git a/mail/squirrelmail-compatibility-plugin/Makefile b/mail/squirrelmail-compatibility-plugin/Makefile
index 0a6c036d07f1..343ca851e76a 100644
--- a/mail/squirrelmail-compatibility-plugin/Makefile
+++ b/mail/squirrelmail-compatibility-plugin/Makefile
@@ -1,39 +1,40 @@
# New ports collection makefile for: squirrelmail-compatibility-plugin
-# Date created: 3 Jul 2005
-# Whom: Alexander Wittig <alexander@wittig.name>
+# Date created: 3 Jul 2005
+# Whom: Alexander Wittig <alexander@wittig.name>
#
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 2.0.4
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
-DIST_SUBDIR= squirrelmail
+PORTNAME= squirrelmail
+PORTVERSION= 2.0.6
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMESUFFIX= -${SQUIRREL_PLUGIN_NAME}-plugin
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
-MAINTAINER= alexander@wittig.name
-COMMENT= Required by many plugins for compatibility with SquirrelMail
+MAINTAINER= alexander@wittig.name
+COMMENT= Required by many plugins for compatibility with SquirrelMail
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+RUN_DEPENDS= squirrelmail>=1.4.9:${PORTSDIR}/mail/squirrelmail
-SQUIRREL_PLUGIN_NAME= compatibility
+SQUIRREL_PLUGIN_NAME= compatibility
.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
.else
. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
. endif
.endif
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-WANT_PHP_WEB= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+WANT_PHP_WEB= yes
pre-everything::
@${ECHO} ""
@@ -54,7 +55,7 @@ do-install:
post-install:
@${ECHO} "Patching SquirrelMail for compatibility plugin"
@${ECHO} ""
- ${PATCH} -sN -p0 -d ${SQUIRRELDIR}/plugins < ${SQUIRRELDIR}/plugins/compatibility/patches/compatibility_patch-1.4.5.diff
+ ${PATCH} -sN -p0 -d ${SQUIRRELDIR}/plugins/compatibility < ${SQUIRRELDIR}/plugins/compatibility/patches/compatibility_patch-1.4.9.diff
@${ECHO} ""
.ifndef WITHOUT_ACTIVATE