aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-squirrel_logger-plugin
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-08-05 14:13:30 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-08-05 14:13:30 +0000
commita9bbc1e33d66db6d37eaf3681d03f226812dd6c9 (patch)
treec2cfc4ddfa786fc2bc217bc87c76f890ceeb24cd /mail/squirrelmail-squirrel_logger-plugin
parent3758539769534e1b10243fa686d649e11b066f31 (diff)
downloadports-a9bbc1e33d66db6d37eaf3681d03f226812dd6c9.tar.gz
ports-a9bbc1e33d66db6d37eaf3681d03f226812dd6c9.zip
This plugin implements logging functionality for your webmail interface.
You can choose to log to a database, a file, your system log, or any combination thereof. You can also choose which kinds of events to log, including login events, logout events, login error events, all outgoing messages, possible outgoing spam messages, and other error events. Also included is monitoring functionality that will send alert emails to the administrator when certain events trigger. If you use the timeout_user plugin, logout events caused by user timeouts will be captured. Log message format is also completely custom-defined to meet your needs in the configuration file. WWW: http://www.squirrelmail.org/plugin_view.php?id=52 PR: ports/148587 Submitted by: Satoru Suzuki <xsuzu at yokohama.riken.jp>
Notes
Notes: svn path=/head/; revision=258810
Diffstat (limited to 'mail/squirrelmail-squirrel_logger-plugin')
-rw-r--r--mail/squirrelmail-squirrel_logger-plugin/Makefile26
-rw-r--r--mail/squirrelmail-squirrel_logger-plugin/distinfo3
-rw-r--r--mail/squirrelmail-squirrel_logger-plugin/files/pkg-message.in7
-rw-r--r--mail/squirrelmail-squirrel_logger-plugin/pkg-descr16
-rw-r--r--mail/squirrelmail-squirrel_logger-plugin/pkg-plist18
5 files changed, 70 insertions, 0 deletions
diff --git a/mail/squirrelmail-squirrel_logger-plugin/Makefile b/mail/squirrelmail-squirrel_logger-plugin/Makefile
new file mode 100644
index 000000000000..fbc5665cd0dd
--- /dev/null
+++ b/mail/squirrelmail-squirrel_logger-plugin/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: squirrelmail-squirrel_logger-plugin
+# Date created: 2010-07-13
+# Whom: Satoru Suzuki <xsuzu@yokohama.riken.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squirrel_logger
+PORTVERSION= 2.3
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.7
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= morinaga@riken.jp
+COMMENT= Logging functionality for your webmail interface
+
+USE_SM_COMPAT= yes
+
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
+
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-squirrel_logger-plugin/distinfo b/mail/squirrelmail-squirrel_logger-plugin/distinfo
new file mode 100644
index 000000000000..32aba99f95d6
--- /dev/null
+++ b/mail/squirrelmail-squirrel_logger-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/squirrel_logger-2.3-1.2.7.tar.gz) = d60ea7389ad948f4ecb82dc91894ba37
+SHA256 (squirrelmail/squirrel_logger-2.3-1.2.7.tar.gz) = 3ba2341f2cf028e01c7faa4545f2d0ead0adf4b25d1176eae0a3d8ce30547cfa
+SIZE (squirrelmail/squirrel_logger-2.3-1.2.7.tar.gz) = 28872
diff --git a/mail/squirrelmail-squirrel_logger-plugin/files/pkg-message.in b/mail/squirrelmail-squirrel_logger-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..9e45ad70bb2e
--- /dev/null
+++ b/mail/squirrelmail-squirrel_logger-plugin/files/pkg-message.in
@@ -0,0 +1,7 @@
+================================================================
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_example.php
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
+and edit the configuration to meet your needs.
+================================================================
diff --git a/mail/squirrelmail-squirrel_logger-plugin/pkg-descr b/mail/squirrelmail-squirrel_logger-plugin/pkg-descr
new file mode 100644
index 000000000000..a55bb8c65209
--- /dev/null
+++ b/mail/squirrelmail-squirrel_logger-plugin/pkg-descr
@@ -0,0 +1,16 @@
+This plugin implements logging functionality for your webmail interface.
+You can choose to log to a database, a file, your system log, or any
+combination thereof. You can also choose which kinds of events to log,
+including login events, logout events, login error events, all outgoing
+messages, possible outgoing spam messages, and other error events.
+
+Also included is monitoring functionality that will send alert emails to
+the administrator when certain events trigger.
+
+If you use the timeout_user plugin, logout events caused by user timeouts
+will be captured.
+
+Log message format is also completely custom-defined to meet your needs
+in the configuration file.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=52
diff --git a/mail/squirrelmail-squirrel_logger-plugin/pkg-plist b/mail/squirrelmail-squirrel_logger-plugin/pkg-plist
new file mode 100644
index 000000000000..319da8c6680e
--- /dev/null
+++ b/mail/squirrelmail-squirrel_logger-plugin/pkg-plist
@@ -0,0 +1,18 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin squirrel_logger; fi
+%%SQUIRRELDIR%%/plugins/squirrel_logger/COPYING
+%%SQUIRRELDIR%%/plugins/squirrel_logger/INSTALL
+%%SQUIRRELDIR%%/plugins/squirrel_logger/README
+%%SQUIRRELDIR%%/plugins/squirrel_logger/alert_functions.php
+%%SQUIRRELDIR%%/plugins/squirrel_logger/config_example.php
+%%SQUIRRELDIR%%/plugins/squirrel_logger/contrib/index.php
+%%SQUIRRELDIR%%/plugins/squirrel_logger/contrib/fail2ban
+%%SQUIRRELDIR%%/plugins/squirrel_logger/database_functions.php
+%%SQUIRRELDIR%%/plugins/squirrel_logger/functions.php
+%%SQUIRRELDIR%%/plugins/squirrel_logger/getpot
+%%SQUIRRELDIR%%/plugins/squirrel_logger/index.php
+%%SQUIRRELDIR%%/plugins/squirrel_logger/make_release.sh
+%%SQUIRRELDIR%%/plugins/squirrel_logger/setup.php
+%%SQUIRRELDIR%%/plugins/squirrel_logger/show_stats.php
+%%SQUIRRELDIR%%/plugins/squirrel_logger/version
+@dirrmtry %%SQUIRRELDIR%%/plugins/squirrel_logger/contrib
+@dirrmtry %%SQUIRRELDIR%%/plugins/squirrel_logger