aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-timeout_user-plugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-16 12:55:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-16 12:55:58 +0000
commit543f63cc535c90a286c1c71e5795655e2b681d16 (patch)
tree2fa56a5de4ce4c74772618ed4d40112b8fe43171 /mail/squirrelmail-timeout_user-plugin
parent2f7d3dc362899f3df8ab0df2379bd8ae35b7ccfa (diff)
downloadports-543f63cc535c90a286c1c71e5795655e2b681d16.tar.gz
ports-543f63cc535c90a286c1c71e5795655e2b681d16.zip
- Fix automatic activation
- Move toward new SM plugin configuration standard - Bump PORTREVISION PR: 110311 Submitted by: Thomas Abthorpe <thomas@goodking.ca> (maintainer)
Notes
Notes: svn path=/head/; revision=187511
Diffstat (limited to 'mail/squirrelmail-timeout_user-plugin')
-rw-r--r--mail/squirrelmail-timeout_user-plugin/Makefile13
-rw-r--r--mail/squirrelmail-timeout_user-plugin/pkg-plist4
2 files changed, 11 insertions, 6 deletions
diff --git a/mail/squirrelmail-timeout_user-plugin/Makefile b/mail/squirrelmail-timeout_user-plugin/Makefile
index f3e476366ed4..5d80fb3a247f 100644
--- a/mail/squirrelmail-timeout_user-plugin/Makefile
+++ b/mail/squirrelmail-timeout_user-plugin/Makefile
@@ -5,12 +5,14 @@
# $FreeBSD$
#
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTNAME= timeout_user
PORTVERSION= 1.1.1
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-0.5
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}-${PORTVERSION}-0.5
DIST_SUBDIR= squirrelmail
MAINTAINER= thomas@goodking.ca
@@ -19,7 +21,7 @@ COMMENT= Automatically logs a user out if they're idle for a set amount of time
RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-SQUIRREL_PLUGIN_NAME= timeout_user
+SQUIRREL_PLUGIN_NAME= ${PORTNAME}
.ifdef SQUIRRELDIR
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
@@ -35,6 +37,7 @@ PLIST_SUB+= SQUIRRELDIR=squirrelmail
SUB_LIST+= "SQUIRRELDIR=squirrelmail"
.endif
.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -42,6 +45,8 @@ USE_PERL5_BUILD= yes
USE_PHP= yes
WANT_PHP_WEB= yes
+.include <bsd.port.pre.mk>
+
pre-everything::
@${ECHO} ""
.ifndef WITHOUT_ACTIVATE
@@ -71,4 +76,4 @@ post-install:
.endif
@${ECHO} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-timeout_user-plugin/pkg-plist b/mail/squirrelmail-timeout_user-plugin/pkg-plist
index 37afab935a51..8b4aee35b7b7 100644
--- a/mail/squirrelmail-timeout_user-plugin/pkg-plist
+++ b/mail/squirrelmail-timeout_user-plugin/pkg-plist
@@ -1,4 +1,4 @@
-@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin timeout_user; fi
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin %%SQUIRREL_PLUGIN_NAME%%; fi
%%SQUIRRELDIR%%/plugins/timeout_user/version
%%SQUIRRELDIR%%/plugins/timeout_user/README
%%SQUIRRELDIR%%/plugins/timeout_user/index.php
@@ -7,4 +7,4 @@
%%SQUIRRELDIR%%/plugins/timeout_user/functions.php
%%SQUIRRELDIR%%/plugins/timeout_user/config.php
@dirrm %%SQUIRRELDIR%%/plugins/timeout_user
-@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin timeout_user; fi
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi