aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-websearch-plugin
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-06-07 20:33:22 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-06-07 20:33:22 +0000
commit10757b20e22cf7f20c5ea539749d401f8eec3ae2 (patch)
treee1305892420ce79f7ed2adacb09cc78d84942ac2 /mail/squirrelmail-websearch-plugin
parent537f6b1cb05c2b032b0254310aa8955c38537293 (diff)
downloadports-10757b20e22cf7f20c5ea539749d401f8eec3ae2.tar.gz
ports-10757b20e22cf7f20c5ea539749d401f8eec3ae2.zip
- Utilise common bsd.squirrelmail.mk
- Add LICENSE - No PORTREVISION bump, as there is no change in functionality Requested by: itetcu
Notes
Notes: svn path=/head/; revision=256047
Diffstat (limited to 'mail/squirrelmail-websearch-plugin')
-rw-r--r--mail/squirrelmail-websearch-plugin/Makefile76
1 files changed, 12 insertions, 64 deletions
diff --git a/mail/squirrelmail-websearch-plugin/Makefile b/mail/squirrelmail-websearch-plugin/Makefile
index 9ce8b8a1da8b..786e93ce2788 100644
--- a/mail/squirrelmail-websearch-plugin/Makefile
+++ b/mail/squirrelmail-websearch-plugin/Makefile
@@ -4,73 +4,21 @@
#
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 0.1.6
+PORTNAME= websearch
+PORTVERSION= 0.1.6
PORTREVISION= 1
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
-DIST_SUBDIR= squirrelmail
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
-MAINTAINER= tabthorpe@FreeBSD.org
-COMMENT= Plugin for Websearch
+MAINTAINER= tabthorpe@FreeBSD.org
+COMMENT= Plugin for Websearch
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+LICENSE= GPLv2
-SQUIRREL_PLUGIN_NAME= web_search
-
-SUB_FILES= pkg-message
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-USE_PHP= yes
-WANT_PHP_WEB= yes
+RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
+SQUIRREL_PLUGIN_NAME= web_search
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>