aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-05-01 16:36:47 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-05-01 16:36:47 +0000
commiteea372244ffcd0b4997b558efb39cc9a4fea243d (patch)
tree603c29074f43101e1fb9b1f14d775bf990bbeda7 /mail/squirrelmail/Makefile
parentb83ffb5777c44a87dcd188f476c2ca3b9d2bb791 (diff)
downloadports-eea372244ffcd0b4997b558efb39cc9a4fea243d.tar.gz
ports-eea372244ffcd0b4997b558efb39cc9a4fea243d.zip
Small cleanups, let pkg-create do permissions and ownerships its own
way rather than invoking chown and chmod ourselves.
Notes
Notes: svn path=/head/; revision=352759
Diffstat (limited to 'mail/squirrelmail/Makefile')
-rw-r--r--mail/squirrelmail/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index 3e9b023e6ab0..3f78524d5acc 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -97,13 +97,11 @@ do-install:
@${MKDIR} ${STAGEDIR}${SQUIRRELDIR}
${INSTALL_DATA} ${WRKSRC}/index.php ${STAGEDIR}${SQUIRRELDIR}
${INSTALL_SCRIPT} ${WRKSRC}/configure ${STAGEDIR}${SQUIRRELDIR}
- cd ${WRKSRC} && \
+ (cd ${WRKSRC} && \
${FIND} attach class config data functions help images include locale plugins po scripts src themes \
- | ${CPIO} -pdmu --quiet ${STAGEDIR}${SQUIRRELDIR}
- ${CHMOD} 730 ${STAGEDIR}${SQUIRRELDIR}/attach
- ${CHMOD} 750 ${STAGEDIR}${SQUIRRELDIR}/data
+ | ${CPIO} -pdmu --quiet ${STAGEDIR}${SQUIRRELDIR})
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${FIND} . | ${CPIO} -pdmu --quiet ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>