aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail/bsd.squirrelmail.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-18 12:40:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-18 12:40:01 +0000
commitafba8532545bd6ca702dc2ca350449887b802e0f (patch)
treef34c56ca58922eaf318d9ba19128e95c2c27c0a6 /mail/squirrelmail/bsd.squirrelmail.mk
parent5445cec046409fa7c0170177ddce30e7c780fdc0 (diff)
downloadports-afba8532545bd6ca702dc2ca350449887b802e0f.tar.gz
ports-afba8532545bd6ca702dc2ca350449887b802e0f.zip
- Stage support
- While here cleanup some whitespaces / dependencys
Notes
Notes: svn path=/head/; revision=344880
Diffstat (limited to 'mail/squirrelmail/bsd.squirrelmail.mk')
-rw-r--r--mail/squirrelmail/bsd.squirrelmail.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/mail/squirrelmail/bsd.squirrelmail.mk b/mail/squirrelmail/bsd.squirrelmail.mk
index d65bbb255af1..7fe1f235f58b 100644
--- a/mail/squirrelmail/bsd.squirrelmail.mk
+++ b/mail/squirrelmail/bsd.squirrelmail.mk
@@ -55,7 +55,7 @@ SUB_LIST+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
# As with mail/squirreldir, if you were using WITHOUT_WWWDIR=yes,
# set SQUIRRELDIR=${PREFIX}/squirrelmail
-SQUIRRELDIR?= ${PREFIX}/www/squirrelmail
+SQUIRRELDIR?= ${PREFIX}/www/squirrelmail
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR:S,${PREFIX}/,,}
SUB_LIST+= SQUIRRELDIR=${SQUIRRELDIR}
@@ -92,19 +92,19 @@ _SMSRCDIR?= ${SQUIRREL_PLUGIN_NAME}
.if !target(do-install)
do-install:
cd ${WRKSRC}/${_SMSRCDIR} && ${FIND} -d . | \
- ${CPIO} -dump ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME} >/dev/null 2>&1 && \
- ${FIND} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME} \
+ ${CPIO} -dump ${STAGEDIR}${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME} >/dev/null 2>&1 && \
+ ${FIND} ${STAGEDIR}${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME} \
-type d -exec chmod 755 {} \; && \
- ${FIND} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME} \
+ ${FIND} ${STAGEDIR}${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME} \
-type f -exec chmod 644 {} \;
.endif
.if !target(post-install)
post-install:
.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
+.if exists( ${STAGEDIR}${SQUIRRELDIR}/config/config.php )
@${ECHO_CMD} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+ ${STAGEDIR}${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
.endif
.else
@${ECHO_CMD} "To activate the plug-in in SquirrelMail use"