aboutsummaryrefslogtreecommitdiff
path: root/mail/sympa
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-03-16 22:06:04 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-03-16 22:06:04 +0000
commit0cc9f05aa75ed2bc10043d62adeacad186c77c94 (patch)
treec5cc3bf70777936eef4f2843e712f3fd8210e93f /mail/sympa
parenta4209ed25df1593b7911a55ead34f987b3d47331 (diff)
downloadports-0cc9f05aa75ed2bc10043d62adeacad186c77c94.tar.gz
ports-0cc9f05aa75ed2bc10043d62adeacad186c77c94.zip
bento reported that amd64 built incorrectly; kris@
suggested that changing HAS_CONFIGURE to GNU_CONFIGURE will fix it. also, etc/rc.d/sympa.sh was disabled and now works. PR: ports/64340 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=104215
Diffstat (limited to 'mail/sympa')
-rw-r--r--mail/sympa/Makefile5
-rw-r--r--mail/sympa/files/patch-src-etc-script-sympa2
-rw-r--r--mail/sympa/pkg-install4
-rw-r--r--mail/sympa/pkg-plist2
4 files changed, 10 insertions, 3 deletions
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index 0b7c321f0159..156e9bd634a6 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -56,7 +56,7 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-
.endif
.endif
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_PERL5= yes
CONFIGURE_ARGS+=--prefix=${PREFIX}/sympa \
--with-confdir=${PREFIX}/etc \
@@ -74,6 +74,9 @@ pre-fetch:
pre-install:
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+post-install:
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
post-deinstall:
PKG_PREFIX=${PREFIX} ${SH} ${PKGDEINSTALL} ${PKGNAME} POST-DEINSTALL
diff --git a/mail/sympa/files/patch-src-etc-script-sympa b/mail/sympa/files/patch-src-etc-script-sympa
index c3a70f43cbb6..5e142c30d009 100644
--- a/mail/sympa/files/patch-src-etc-script-sympa
+++ b/mail/sympa/files/patch-src-etc-script-sympa
@@ -36,7 +36,7 @@
- if [ ${OSTYPE} = "IRIX" ]; then
- $sympadir/$1.pl $startparam && echo "success" || echo "failure"
+ if [ ${OSTYPE} = "IRIX" -o ${OSTYPE} = "FreeBSD" ]; then
-+ su sympa -c "$sympadir/$1.pl $startparam" && echo "success" || echo "failure"
++ su -m sympa -c "$sympadir/$1.pl $startparam" && echo "success" || echo "failure"
else
$sympadir/$1.pl $startparam && success || failure
fi
diff --git a/mail/sympa/pkg-install b/mail/sympa/pkg-install
index 037816623aec..3bf3e5292d11 100644
--- a/mail/sympa/pkg-install
+++ b/mail/sympa/pkg-install
@@ -2,6 +2,10 @@
# $FreeBSD$
#
+if [ "$2" = "POST-INSTALL" ]; then
+ mv ${PKG_PREFIX}/etc/rc.d/sympa ${PKG_PREFIX}/etc/rc.d/sympa.sh 2>/dev/null
+fi
+
if [ "$2" != "PRE-INSTALL" ]; then
exit 0
fi
diff --git a/mail/sympa/pkg-plist b/mail/sympa/pkg-plist
index d7c2eba5a403..e52efbc0469f 100644
--- a/mail/sympa/pkg-plist
+++ b/mail/sympa/pkg-plist
@@ -1,6 +1,6 @@
etc/sympa.conf
etc/wwsympa.conf
-etc/rc.d/sympa
+etc/rc.d/sympa.sh
sympa/bin/etc/scenari/access_web_archive.closed
sympa/bin/etc/scenari/visibility.private
sympa/bin/etc/scenari/visibility.noconceal