aboutsummaryrefslogtreecommitdiff
path: root/mail/sympa
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2004-05-17 13:31:37 +0000
committerErwin Lansing <erwin@FreeBSD.org>2004-05-17 13:31:37 +0000
commit05c10f8e191848ca3f8a23bedd7043d1818a0be8 (patch)
tree9068cbaee74533073f5f5dbf21dc05e5498040fd /mail/sympa
parent9af3f466a06e757a3d943eb5650a1cb5094f85d3 (diff)
downloadports-05c10f8e191848ca3f8a23bedd7043d1818a0be8.tar.gz
ports-05c10f8e191848ca3f8a23bedd7043d1818a0be8.zip
Conditionalize dependency on DBI so this port choose the right
p5-DBI port with perl < 5.6 PR: 66735 Approved by: maintainer
Notes
Notes: svn path=/head/; revision=109339
Diffstat (limited to 'mail/sympa')
-rw-r--r--mail/sympa/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index 1f42ad2d2c51..7dfc6a02cfd5 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -24,7 +24,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/Mail/Mailer.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/${PERL_ARCH}/Locale/Msgcat.pm:${PORTSDIR}/misc/p5-Locale-Msgcat \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -82,4 +81,14 @@ post-install:
post-deinstall:
PKG_PREFIX=${PREFIX} ${SH} ${PKGDEINSTALL} ${PKGNAME} POST-DEINSTALL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>