aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird-esr/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-04 06:31:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-04 06:31:09 +0000
commit37e90a90a1a7f29745a20c2bb530e2e3b25c88f6 (patch)
tree257334b20ee3b798b64ce5c03cc974ddb9ac9930 /mail/thunderbird-esr/Makefile
parent6ae3de6b3d5f38495593fd9de61af773c69c4bcf (diff)
downloadports-37e90a90a1a7f29745a20c2bb530e2e3b25c88f6.tar.gz
ports-37e90a90a1a7f29745a20c2bb530e2e3b25c88f6.zip
Add mozilla-thunderbird, a mail application based on the Mozilla mail
component. More details on this project as well as the 0.2 release notes can be found at: http://www.mozilla.org/projects/thunderbird/
Notes
Notes: svn path=/head/; revision=88486
Diffstat (limited to 'mail/thunderbird-esr/Makefile')
-rw-r--r--mail/thunderbird-esr/Makefile153
1 files changed, 153 insertions, 0 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
new file mode 100644
index 000000000000..39b6266a7b38
--- /dev/null
+++ b/mail/thunderbird-esr/Makefile
@@ -0,0 +1,153 @@
+# New ports collection makefile for: mozilla-thunderbird
+# Date created: 4 September 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thunderbird
+PORTVERSION= 0.2
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_MOZILLA}
+MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}
+PKGNAMEPREFIX= mozilla-
+DISTNAME= ${PORTNAME}-source-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Mozilla Thunderbird is standalone mail and news that stands above
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ mng.1:${PORTSDIR}/graphics/libmng \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ nspr4.1:${PORTSDIR}/devel/nspr
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ freetype-config:${PORTSDIR}/print/freetype2
+
+USE_X_PREFIX= yes
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+ALL_TARGET= default
+
+.if defined(WITH_GTK2)
+USE_GNOME= gtk20 libidl
+PKGNAMESUFFIX= -gtk2
+PLIST= ${PKGDIR}/pkg-plist.gtk2
+.else
+USE_GNOME= gtk12 orbit
+PLIST= ${PKGDIR}/pkg-plist.gtk1
+.endif
+
+NO_MTREE= yes
+WRKSRC= ${WRKDIR}/mozilla
+LOCAL_SUBDIR= lib/${PORTNAME}
+LOCAL_PREFIX= ${PREFIX}/${LOCAL_SUBDIR}
+
+.include <bsd.port.pre.mk>
+
+SORT?=/usr/bin/sort
+
+.if ${ARCH} == "i386"
+CONFIGURE_ENV+= WITH_REORDER=yes
+.endif # ${ARCH} == "i386"
+
+.if defined(WITH_DEBUG)
+WITH_LOGGING= yes
+CONFIGURE_ENV+= WITH_DEBUG=yes
+.endif # defined(WITH_DEBUG)
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O2
+.endif # defined(WITH_OPTIMIZED_CFLAGS)
+
+.if defined(WITH_LOGGING)
+CONFIGURE_ENV+= WITH_LOGGING=yes
+.endif # defined(WITH_LOGGING)
+
+.if defined(WITHOUT_XFT)
+CONFIGURE_ENV+= WITHOUT_XFT=yes
+.else
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/Xft
+.endif # !defined(WITHOUT_XFT)
+
+.if defined(WITH_GTK2)
+CONFIGURE_ENV+= WITH_GTK2=yes
+.endif # defined(WITH_GTK2)
+
+CPPFLAGS+= -I${X11BASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${X11BASE}/lib
+LIBS+= ${PTHREAD_LIBS}
+
+pre-extract::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Extracting source (this takes a while) ..."
+ @${ECHO_MSG}
+
+post-extract::
+ @${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
+ -e 's|@CFLAGS@|${CFLAGS}|' \
+ -e 's|@LDFLAGS@|${LDFLAGS}|' \
+ -e 's|@LIBS@|${LIBS}|' \
+ -e 's|@X11BASE@|${X11BASE}|' \
+ -e 's|@LOCALBASE@|${LOCALBASE}|' \
+ -e 's|@PREFIX@|${LOCAL_PREFIX}|' \
+ -e 's|@PERL@|${PERL5}|' \
+ <${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/build/unix/run-mozilla.sh
+
+pre-install:
+ ${RM} -fr ${LOCAL_PREFIX}
+
+link-bins:
+ ${RM} -f ${PREFIX}/bin/thunderbird
+ ${LN} -s ${LOCAL_PREFIX}/bin/thunderbird \
+ ${PREFIX}/bin/thunderbird
+ ${RM} -f ${PREFIX}/bin/thunderbird-config
+ ${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
+ ${PREFIX}/bin/thunderbird-config
+
+cleanup-install:
+ ${RM} -fr ${LOCAL_PREFIX}/share/idl
+ ${RM} -fr ${LOCAL_PREFIX}/include
+
+cons-plist:
+ -${RM} -f ${PLIST}
+ ${TOUCH} ${PLIST}
+ ${ECHO_CMD} bin/thunderbird >>${PLIST}
+ ${ECHO_CMD} bin/thunderbird-config >>${PLIST}
+.for i in ${EXTRA_SCRIPTS}
+ ${ECHO_CMD} bin/${i} >>${PLIST}
+.endfor # i in ${EXTRA_SCRIPTS}
+ cd ${PREFIX}; \
+ ${FIND} ${LOCAL_SUBDIR} ! -type d | ${SORT} >>${PLIST}; \
+ ${FIND} ${LOCAL_SUBDIR} -type d -empty | ${SORT} \
+ | ${SED} -e "s:^:@exec ${MKDIR} %D/:" -e "s:$$: || true:" \
+ >> ${PLIST}; \
+ ${FIND} ${LOCAL_SUBDIR} -type d -empty | ${SORT} -r \
+ | ${SED} -e "s:^:@unexec ${RMDIR} %D/:" -e "s:$$: || true:" \
+ >> ${PLIST}; \
+ ${FIND} ${LOCAL_SUBDIR} -type d ! -empty | ${SORT} -r \
+ | ${SED} -e "s:^:@dirrm :" >> ${PLIST}
+
+.PHONY: link-bins cleanup-install cons-plist
+
+.include <bsd.port.post.mk>
+
+# <alane>
+# Under normal circumstances, you should not put anything after
+# the above line. However, this is the only way I can state the
+# dependency without trashing the actual code of the generate-plist
+# target. This is a limitation of the make(1) program itself.
+# </alane>
+generate-plist: link-bins cleanup-install
+
+#EOF