aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird-esr
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-14 00:37:47 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-14 00:37:47 +0000
commit6b605d422bb99dd96fc65f0b29eceebe8329f899 (patch)
treec881602152475d4a904b77c9aae4c4a40df69ac2 /mail/thunderbird-esr
parent37f2451c9a8eaf957979686c139d3463d64080c9 (diff)
downloadports-6b605d422bb99dd96fc65f0b29eceebe8329f899.tar.gz
ports-6b605d422bb99dd96fc65f0b29eceebe8329f899.zip
Fix build with Perl < 5.6.1.
Notes
Notes: svn path=/head/; revision=119345
Diffstat (limited to 'mail/thunderbird-esr')
-rw-r--r--mail/thunderbird-esr/Makefile4
-rw-r--r--mail/thunderbird-esr/files/extra-patch-config_make-jars.pl10
2 files changed, 14 insertions, 0 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index c9208c79a91d..d8771737fe86 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -57,6 +57,10 @@ OPTIONS= DEBUG "Build a debugging image" off \
IGNORE= "core dumps at runtime"
.endif # ${ARCH} == "alpha" && ${OSVERSION} < 500035
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif # ${PERL_LEVEL} < 500600
+
.if defined(WITH_DEBUG)
WITH_LOGGING= yes
CONFIGURE_ENV+= WITH_DEBUG=yes
diff --git a/mail/thunderbird-esr/files/extra-patch-config_make-jars.pl b/mail/thunderbird-esr/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/mail/thunderbird-esr/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+