aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-03-03 19:38:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-03-03 19:38:13 +0000
commitb0d611aa447013bc4fe9c353f277831880c44fd1 (patch)
tree7d3284e05228817e5a098f0866e33d8843538a73 /mail/thunderbird
parenta3bf534f8daa058155a59935da829fae1c8fc128 (diff)
downloadports-b0d611aa447013bc4fe9c353f277831880c44fd1.tar.gz
ports-b0d611aa447013bc4fe9c353f277831880c44fd1.zip
gecko: attempt to drop RPATH for libxul.so dependencies
Notes
Notes: svn path=/head/; revision=435362
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-bug133679121
2 files changed, 22 insertions, 0 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 9fdd19e2bc6f..2422498f8cce 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 45.7.1
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1336791 b/mail/thunderbird/files/patch-bug1336791
new file mode 100644
index 000000000000..04b014b8b361
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1336791
@@ -0,0 +1,21 @@
+# Allow readelf to print types without parentheses
+
+--- mozilla/toolkit/library/dependentlibs.py
++++ mozilla/toolkit/library/dependentlibs.py
+@@ -57,11 +57,15 @@ def dependentlibs_readelf(lib):
+ for line in proc.stdout:
+ # Each line has the following format:
+ # tag (TYPE) value
++ # or with BSD readelf:
++ # tag TYPE value
+ # Looking for NEEDED type entries
+ tmp = line.split(' ', 3)
+- if len(tmp) > 3 and tmp[2] == '(NEEDED)':
++ if len(tmp) > 3 and 'NEEDED' in tmp[2]:
+ # NEEDED lines look like:
+ # 0x00000001 (NEEDED) Shared library: [libname]
++ # or with BSD readelf:
++ # 0x00000001 NEEDED Shared library: [libname]
+ match = re.search('\[(.*)\]', tmp[3])
+ if match:
+ deps.append(match.group(1))