aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-17 21:40:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-17 21:40:11 +0000
commit3bffe907e1a5ae966c6447db59ca09c5ba3165d1 (patch)
tree898ac33614dec455ab57ff610516ff9e189c6aa5 /mail/thunderbird
parente3a98cbb2d2c1737f7c49110dd7736b2ad516e0b (diff)
downloadports-3bffe907e1a5ae966c6447db59ca09c5ba3165d1.tar.gz
ports-3bffe907e1a5ae966c6447db59ca09c5ba3165d1.zip
* Remove a patch that is no longer needed
* Change an instance of Firefox to Thunderbird [1] * Workaround a potential crash with JavaScript pop-ups [2] * Use Xvfb to initialize the extensions datastore as root [2] https://bugzilla.mozilla.org/show_bug.cgi?id=264557 Sbumitted by: Radek Kozlowski <radek@raadradd.com> [1]
Notes
Notes: svn path=/head/; revision=119693
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile11
-rw-r--r--mail/thunderbird/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp12
-rw-r--r--mail/thunderbird/pkg-install.in5
3 files changed, 12 insertions, 16 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index d8771737fe86..69d04074fac7 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -7,7 +7,7 @@
PORTNAME= thunderbird
PORTVERSION= 0.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}
@@ -21,6 +21,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
mng.1:${PORTSDIR}/graphics/libmng \
nspr4.1:${PORTSDIR}/devel/nspr
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+RUN_DEPENDS= Xvfb:${X_VFBSERVER_PORT}
USE_X_PREFIX= yes
@@ -49,7 +50,7 @@ OPTIONS= DEBUG "Build a debugging image" off \
LOGGING "Enable additional log messages" off \
OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
XFT "Enable support for anti-aliased fonts" on \
- NEW_ICON "Install the new Firefox branding icon" off
+ NEW_ICON "Install the new Thunderbird branding icon" off
.include <bsd.port.pre.mk>
@@ -120,7 +121,8 @@ post-patch:
${WRKSRC}/js/src/Makefile.in
@${REINPLACE_CMD} -E -e 's|libesd\.so\.[0-9]+|${ESD_LIB}|g' \
${WRKSRC}/widget/src/gtk2/nsSound.cpp
- @${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
+ @${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/ ; \
+ /dom.disable_window_open_feature.toolbar/s/false/true/' \
${WRKSRC}/modules/libpref/src/init/all.js \
${WRKSRC}/extensions/sroaming/resources/content/prefs/all.js \
${WRKSRC}/modules/libpref/src/init/all.js
@@ -128,7 +130,8 @@ post-patch:
${WRKSRC}/configure \
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
- @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
+ @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
@${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
< ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
diff --git a/mail/thunderbird/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp b/mail/thunderbird/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
deleted file mode 100644
index bc141062f7c6..000000000000
--- a/mail/thunderbird/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- gfx/src/gtk/nsFontMetricsXft.cpp.orig Wed Mar 17 02:08:01 2004
-+++ gfx/src/gtk/nsFontMetricsXft.cpp Wed Mar 17 02:08:15 2004
-@@ -65,7 +65,8 @@
-
- #include <gdk/gdkx.h>
- #include <freetype/tttables.h>
--#include <freetype/freetype.h>
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
-
- #define FORCE_PR_LOG
- #include "prlog.h"
diff --git a/mail/thunderbird/pkg-install.in b/mail/thunderbird/pkg-install.in
index 048ff1d62da3..415295540dc1 100644
--- a/mail/thunderbird/pkg-install.in
+++ b/mail/thunderbird/pkg-install.in
@@ -15,6 +15,7 @@ PATH=/bin:/usr/bin
MOZDIR=%%MOZDIR%%
REGXPCOM=${MOZDIR}/regxpcom
REGCHROME=${MOZDIR}/regchrome
+THUNDERBIRD=${MOZDIR}/thunderbird-bin
echo "===> Building Chrome's registry..."
rm -rf ${MOZDIR}/chrome/overlayinfo
@@ -27,4 +28,8 @@ cd ${MOZDIR} || exit 1
./run-mozilla.sh ${REGXPCOM} || true
./run-mozilla.sh ${REGCHROME} || true
+# Instantiate the extension space as root.
+su - root -c "%%X11BASE%%/bin/xinit %%MOZDIR%%/run-mozilla.sh ${THUNDERBIRD} -install-global-extension -- %%X11BASE%%/bin/Xvfb :1001" > /dev/null 2>&1
+su - root -c "%%X11BASE%%/bin/xinit %%MOZDIR%%/run-mozilla.sh ${THUNDERBIRD} -install-global-theme -- %%X11BASE%%/bin/Xvfb :1001" > /dev/null 2>&1
+
exit 0