aboutsummaryrefslogtreecommitdiff
path: root/mail/tumgreyspf
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2008-04-13 19:38:18 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2008-04-13 19:38:18 +0000
commit0b07e07484c3b8aedf550d93ee270564924b03f9 (patch)
treef35f20bb91a91ebfb45658efa6eee83b48789de0 /mail/tumgreyspf
parentb376ccb8f1803f11374c6ddb0bcbe632f94dd373 (diff)
downloadports-0b07e07484c3b8aedf550d93ee270564924b03f9.tar.gz
ports-0b07e07484c3b8aedf550d93ee270564924b03f9.zip
- Update to 1.32
- Now tumgreyspf only support mail/py-spf
Notes
Notes: svn path=/head/; revision=211191
Diffstat (limited to 'mail/tumgreyspf')
-rw-r--r--mail/tumgreyspf/Makefile27
-rw-r--r--mail/tumgreyspf/distinfo6
-rw-r--r--mail/tumgreyspf/files/patch-tumgreyspf10
3 files changed, 12 insertions, 31 deletions
diff --git a/mail/tumgreyspf/Makefile b/mail/tumgreyspf/Makefile
index 0f32d717f540..7bb63d15e20e 100644
--- a/mail/tumgreyspf/Makefile
+++ b/mail/tumgreyspf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tumgreyspf
-PORTVERSION= 1.24
+PORTVERSION= 1.32
CATEGORIES= mail
MASTER_SITES= ftp://ftp.tummy.com/pub/tummy/tumgreyspf/ \
ftp://ftp.tummy.com/pub/tummy/tumgreyspf/old-releases/
@@ -14,6 +14,8 @@ MASTER_SITES= ftp://ftp.tummy.com/pub/tummy/tumgreyspf/ \
MAINTAINER= mnag@FreeBSD.org
COMMENT= External policy checker for the postfix mail server
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/spf.py:${PORTSDIR}/mail/py-spf
+
USE_PYTHON= 2.1+
NO_BUILD= yes
@@ -33,23 +35,6 @@ SUB_LIST= TUMGREYSPF_DIR=${TUMGREYSPF_DIR} \
PORTDOCS= *
-OPTIONS= PYSPF "Use mail/py-spf to resolve spf entries" on \
- LIBSPF2 "Use mail/libspf2 (spfquery) to resolve spf entries" off
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_PYSPF)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/spf.py:${PORTSDIR}/mail/py-spf
-.endif
-
-.if defined(WITH_LIBSPF2)
-RUN_DEPENDS+= spfquery:${PORTSDIR}/mail/libspf2
-.endif
-
-.if (!defined(WITHOUT_PYSPF) || defined(WITH_PYSPF)) && defined(WITH_LIBSPF2)
-BROKEN= Select only one spf resolver
-.endif
-
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "You may set following options:"
@@ -65,10 +50,6 @@ post-patch:
${WRKSRC}/tumgreyspf.conf
@${GREP} -r "env python" ${WRKSRC} | ${CUT} -d: -f1 | \
${XARGS} ${REINPLACE_CMD} -e "s|env python|env ${PYTHON_CMD}|"
-.if defined(WITH_LIBSPF2)
- @${REINPLACE_CMD} -e "s|import spf|import spfXXX # Added XXX to disable py-spf if mail/py-spf are installed|" \
- ${WRKSRC}/tumgreyspf
-.endif
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/tumgreyspfsupp.py ${PYTHONPREFIX_SITELIBDIR}
@@ -94,4 +75,4 @@ post-install:
@${SETENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/tumgreyspf/distinfo b/mail/tumgreyspf/distinfo
index 21e7f72366b2..a4b6912e2a8d 100644
--- a/mail/tumgreyspf/distinfo
+++ b/mail/tumgreyspf/distinfo
@@ -1,3 +1,3 @@
-MD5 (tumgreyspf-1.24.tar.gz) = 17a9569d2db226d0d683053a609b76ce
-SHA256 (tumgreyspf-1.24.tar.gz) = 06fab3f51aa7b859170770c7ee2cbd675747ac8b1662f5050844913c90c9d7a3
-SIZE (tumgreyspf-1.24.tar.gz) = 26488
+MD5 (tumgreyspf-1.32.tar.gz) = 13305454cc867aa66d988c637fe07d85
+SHA256 (tumgreyspf-1.32.tar.gz) = 12746d5783707e362eb1b12f398b53acaa78ee8db413595b8989151d7687b0ec
+SIZE (tumgreyspf-1.32.tar.gz) = 28908
diff --git a/mail/tumgreyspf/files/patch-tumgreyspf b/mail/tumgreyspf/files/patch-tumgreyspf
index 647e40af34bc..c630f6509795 100644
--- a/mail/tumgreyspf/files/patch-tumgreyspf
+++ b/mail/tumgreyspf/files/patch-tumgreyspf
@@ -1,9 +1,9 @@
---- tumgreyspf.orig Tue Aug 29 21:07:19 2006
-+++ tumgreyspf Sat Sep 9 22:57:31 2006
-@@ -11,7 +11,6 @@
+--- tumgreyspf.orig 2007-11-29 20:58:31.000000000 -0200
++++ tumgreyspf 2008-04-13 14:18:04.000000000 -0300
+@@ -12,7 +12,6 @@
-
- import syslog, os, sys, string, re, time, popen2, urllib, stat, errno
+ import syslog, os, sys, string, re, time, popen2, urllib, stat, errno, socket
+ import spf
-sys.path.append('/usr/local/lib/tumgreyspf')
import tumgreyspfsupp