aboutsummaryrefslogtreecommitdiff
path: root/mail/vbsfilter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-01-13 04:16:24 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-01-13 04:16:24 +0000
commit66990815ac942616d3c741b102bba56adfdfdae6 (patch)
tree95655a615678503ef67bae5d282efbfe59ccfd02 /mail/vbsfilter
parentd7f59ea8de230bb289b02649cd575560e4c71e0d (diff)
downloadports-66990815ac942616d3c741b102bba56adfdfdae6.tar.gz
ports-66990815ac942616d3c741b102bba56adfdfdae6.zip
- use milter framework
Notes
Notes: svn path=/head/; revision=182276
Diffstat (limited to 'mail/vbsfilter')
-rw-r--r--mail/vbsfilter/Makefile29
1 files changed, 2 insertions, 27 deletions
diff --git a/mail/vbsfilter/Makefile b/mail/vbsfilter/Makefile
index 7daf4932b5a2..c86990300aca 100644
--- a/mail/vbsfilter/Makefile
+++ b/mail/vbsfilter/Makefile
@@ -19,44 +19,19 @@ COMMENT= A vbs-attachment filter for Sendmail Milter
SUB_FILES= vbsfilter.sh
PLIST_FILES= libexec/vbsfilter etc/rc.d/vbsfilter.sh.sample
-.if !defined(SENDMAIL_MILTER_IN_BASE)
-.if defined(SENDMAIL_WITH_SHARED_MILTER)
-LIB_DEPENDS+= milter.3:${PORTSDIR}/mail/${SENDMAIL_MILTER_PORT}
-.else
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/${SENDMAIL_MILTER_PORT}
-.endif
-.endif
-
-SENDMAIL_MILTER_PORT?= sendmail
CTARGETS+= vbsfilter-${PORTVERSION}
LIBS+= ${PTHREAD_LIBS}
+LIBS+= -lmilter
CFLAGS+= -Wall ${PTHREAD_CFLAGS:S=""==}
-.if !defined(SENDMAIL_MILTER_IN_BASE)
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.endif
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/libmilter/mfdef.h) \
-|| defined(SENDMAIL_MILTER_IN_BASE)
-LIBS+= -lmilter
-.else
-LIBS+= -lmilter -lsmutil
-.endif
+.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
.if defined(SENDMAIL_WITH_SFIO)
LIBS+= -lsfio
.endif
-.if defined(SENDMAIL_WITHOUT_MILTER)
-pre-fetch:
- @${ECHO_MSG}
- @${ECHO_MSG} You must unset variable SENDMAIL_WITHOUT_MILTER,
- @${ECHO_MSG} and rebuild sendmail in the ports
- @${FALSE}
-.endif
-
do-extract:
@${MKDIR} ${WRKSRC}
@${CP} ${_DISTDIR}vbsfilter-${PORTVERSION}.c ${WRKSRC}