aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-09-16 07:35:24 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-09-16 07:35:24 +0000
commit41dcdf665292e866c1155aa5f3de09cd39d5fd31 (patch)
treeba8eafbd36710a5e2c055388f84de506d11d6ce0 /mail/vpopmail
parent86fde83af8eabf52753daf4dd4151acb960ca32f (diff)
downloadports-41dcdf665292e866c1155aa5f3de09cd39d5fd31.tar.gz
ports-41dcdf665292e866c1155aa5f3de09cd39d5fd31.zip
Errr... actually add the patch needed for the WITH_SMTP_AUTH_PATCH option
introduced in ports/mail/vpopmail/Makefile rev. 1.57. Submitted by: Nikolay Georgiev <niki@techlab.office1.bg>
Notes
Notes: svn path=/head/; revision=142893
Diffstat (limited to 'mail/vpopmail')
-rw-r--r--mail/vpopmail/files/vchkpw-smtp-auth.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/mail/vpopmail/files/vchkpw-smtp-auth.patch b/mail/vpopmail/files/vchkpw-smtp-auth.patch
new file mode 100644
index 000000000000..d55830ed511c
--- /dev/null
+++ b/mail/vpopmail/files/vchkpw-smtp-auth.patch
@@ -0,0 +1,15 @@
+--- vchkpw.c.orig Thu Dec 16 15:57:34 2004
++++ vchkpw.c Fri Sep 16 06:25:31 2005
+@@ -435,8 +435,10 @@
+ #ifdef CLEAR_PASS
+ /* Check CRAM-MD5 auth */
+ if(ConnType == SMTP_CONN) {
+- /* printf("vchkpw: smtp auth\n"); */
+- cramaccepted = authcram(ThePass,TheChallenge,vpw->pw_clear_passwd);
++ printf("vchkpw: smtp auth\n");
++ /* cramaccepted = authcram(ThePass,TheChallenge,vpw->pw_clear_passwd); */
++ cramaccepted = authcram(TheChallenge,ThePass,vpw->pw_clear_passwd);
++
+ if(cramaccepted == 0) strcpy(AuthType, "CRAM-MD5");
+ }
+