aboutsummaryrefslogtreecommitdiff
path: root/mail/wmmultipop3
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-28 21:30:41 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-28 21:30:41 +0000
commitd0dabff15e306805644cb5b1015533fcbfa29f90 (patch)
tree81bc7b2203398e1d5357a357787a7c607c340016 /mail/wmmultipop3
parent14d612d48dcedb3bd1d5dee6f5d95e6b597ab709 (diff)
downloadports-d0dabff15e306805644cb5b1015533fcbfa29f90.tar.gz
ports-d0dabff15e306805644cb5b1015533fcbfa29f90.zip
new port wmmultipop3 version 0.7: A WindowMaker dockapp that checks
multiple pop3 accounts for new mail PR: 30897 Submitted by: Patrick Li <pat@databits.net>
Notes
Notes: svn path=/head/; revision=48253
Diffstat (limited to 'mail/wmmultipop3')
-rw-r--r--mail/wmmultipop3/Makefile35
-rw-r--r--mail/wmmultipop3/distinfo1
-rw-r--r--mail/wmmultipop3/files/patch-Makefile23
-rw-r--r--mail/wmmultipop3/pkg-comment1
-rw-r--r--mail/wmmultipop3/pkg-descr6
-rw-r--r--mail/wmmultipop3/pkg-message7
-rw-r--r--mail/wmmultipop3/pkg-plist5
7 files changed, 78 insertions, 0 deletions
diff --git a/mail/wmmultipop3/Makefile b/mail/wmmultipop3/Makefile
new file mode 100644
index 000000000000..219518247995
--- /dev/null
+++ b/mail/wmmultipop3/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: wmmultipop3
+# Date created: Fri Sep 28 16:25:34 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmmultipop3
+PORTVERSION= 0.7
+CATEGORIES= mail windowmaker
+MASTER_SITES= http://sumpan.campus.luth.se/software/wmmultipop3/
+DISTNAME= wmMultiPop3-${PORTVERSION}
+
+MAINTAINER= pat@databits.net
+
+BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GMAKE= yes
+
+DOC_FILES= ChangeLog INSTALL README
+
+do-install:
+ @${INSTALL_PROGRAM} ${BUILD_WRKSRC}/wmmultipop3 ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/wmmultipop3/distinfo b/mail/wmmultipop3/distinfo
new file mode 100644
index 000000000000..220018f138a1
--- /dev/null
+++ b/mail/wmmultipop3/distinfo
@@ -0,0 +1 @@
+MD5 (wmMultiPop3-0.7.tar.gz) = e7464e5939a856beff42fd7f414daa34
diff --git a/mail/wmmultipop3/files/patch-Makefile b/mail/wmmultipop3/files/patch-Makefile
new file mode 100644
index 000000000000..c4495ee42b11
--- /dev/null
+++ b/mail/wmmultipop3/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- wmmultipop3/Makefile.orig Sat Sep 22 11:29:50 2001
++++ wmmultipop3/Makefile Fri Sep 28 16:36:39 2001
+@@ -1,16 +1,15 @@
+-LIBDIR = -L/usr/X11R6/lib
++LIBDIR = -L${X11BASE}/lib
+ LIBS = -lXpm -lXext -lX11
+-FLAGS = -O2
+ OBJS = wmmultipop3.o Pop3Client.o ../wmgeneral/wmgeneral.o ../wmgeneral/misc.o ../wmgeneral/list.o
+
+
+ .c.o:
+- cc -I/usr/X11R6/share/include $(FLAGS) -c -Wall $< -o $*.o
++ $(CC) -I${X11BASE}/include -c $< -o $*.o
+
+ wmmultipop3: $(OBJS)
+- cc $(FLAGS) -o wmmultipop3 $^ -lXext $(LIBDIR) $(LIBS)
++ $(CC) -o wmmultipop3 $^ $(LIBDIR) $(LIBS)
+
+-all:: wmpop3
++all:: wmmultipop3
+
+ clean::
+ for i in $(OBJS) ; do \
diff --git a/mail/wmmultipop3/pkg-comment b/mail/wmmultipop3/pkg-comment
new file mode 100644
index 000000000000..93a262036dfd
--- /dev/null
+++ b/mail/wmmultipop3/pkg-comment
@@ -0,0 +1 @@
+A WindowMaker dockapp that checks multiple pop3 accounts for new mail
diff --git a/mail/wmmultipop3/pkg-descr b/mail/wmmultipop3/pkg-descr
new file mode 100644
index 000000000000..7fdcb439f29b
--- /dev/null
+++ b/mail/wmmultipop3/pkg-descr
@@ -0,0 +1,6 @@
+wmMultiPop3 is a WindowMaker dockapp which checks one or more
+pop3-accounts for new mail. It's based on wmPop3 written by Scott
+Helden.
+
+WWW: http://sumpan.campus.luth.se/software/wmmultipop3/
+Author: Daniel Sundberg <dansun-8@student.luth.se>
diff --git a/mail/wmmultipop3/pkg-message b/mail/wmmultipop3/pkg-message
new file mode 100644
index 000000000000..64fe52482e3c
--- /dev/null
+++ b/mail/wmmultipop3/pkg-message
@@ -0,0 +1,7 @@
+
+------------------------------------------------------------------
+WARNING!!! - When you run wmmultipop3 and it automatically creates
+.wmmultipop3rc in your home directory, make sure you set chmod 600
+on that configuration file because passwords will be in plain text
+------------------------------------------------------------------
+
diff --git a/mail/wmmultipop3/pkg-plist b/mail/wmmultipop3/pkg-plist
new file mode 100644
index 000000000000..d1a442fc5f86
--- /dev/null
+++ b/mail/wmmultipop3/pkg-plist
@@ -0,0 +1,5 @@
+bin/wmmultipop3
+%%PORTDOCS%%share/doc/wmmultipop3/ChangeLog
+%%PORTDOCS%%share/doc/wmmultipop3/INSTALL
+%%PORTDOCS%%share/doc/wmmultipop3/README
+%%PORTDOCS%%@dirrm share/doc/wmmultipop3