aboutsummaryrefslogtreecommitdiff
path: root/mail/xmailbox/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-07-04 19:42:45 +0000
committerSteve Price <steve@FreeBSD.org>1998-07-04 19:42:45 +0000
commit47c434f9bb9d52796e193942ae440d660ea3a584 (patch)
tree801b9c1a2b0878072cfe3bc4e6d0b6ebb0d1637c /mail/xmailbox/Makefile
parent16a83387567e7d7889d89a0cda53fe47cfe9980c (diff)
downloadports-47c434f9bb9d52796e193942ae440d660ea3a584.tar.gz
ports-47c434f9bb9d52796e193942ae440d660ea3a584.zip
Initial import of xmailbox version 2.5.
xmailbox - mailbox checker with sound and animation for X PR: 6748 Submitted by: andy@icc.surw.chel.su
Notes
Notes: svn path=/head/; revision=11720
Diffstat (limited to 'mail/xmailbox/Makefile')
-rw-r--r--mail/xmailbox/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail/xmailbox/Makefile b/mail/xmailbox/Makefile
new file mode 100644
index 000000000000..68c8412f98d4
--- /dev/null
+++ b/mail/xmailbox/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xmailbox
+# Version required: 2.5
+# Date created: 23 May 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= xmailbox-2.5
+CATEGORIES= mail x11
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= applications
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+
+MAN1= xmailbox.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xmailbox ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/xmailbox.man ${PREFIX}/man/man1/xmailbox.1
+ @ ${INSTALL_DATA} ${WRKSRC}/XMailbox.ad ${PREFIX}/lib/X11/app-defaults/XMailbox
+ @ ${MKDIR} ${PREFIX}/share/xmailbox
+ @ ${INSTALL_DATA} ${WRKSRC}/dingdong.au ${PREFIX}/share/xmailbox
+ @ ${INSTALL_DATA} ${WRKSRC}/ugotmail.au ${PREFIX}/share/xmailbox
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/xmailbox
+ @ ${INSTALL_DATA} ${WRKSRC}/DISCLAIMER ${PREFIX}/share/doc/xmailbox
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xmailbox
+.endif
+
+.include <bsd.port.mk>