aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-04 07:56:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-04 07:56:16 +0000
commit0a89b368327366c633431756886b0b74d05ffedc (patch)
tree378f9bd6520cc698ef6add9bf146137cdd328612 /mail
parentbf4c041c6343ee1d09450091b92937fbb0aa654b (diff)
downloadports-0a89b368327366c633431756886b0b74d05ffedc.tar.gz
ports-0a89b368327366c633431756886b0b74d05ffedc.zip
Add gnubiff 1.2.0,
gnubiff is a mail notification program that checks for mail, displays headers when new mail has arrived and allow to read first lines of new mails. It relies on the GNOME and GTK libraries but can be compiled and used with or without GNOME support. Supported protocols are pop3, apop, imap4, mh, qmail and mailfile. Furthermore, gnubiff is fully configurable with a lot of options like polltime, poptime, sounds, mail reader, mailbox names, etc. and can also filter spam. PR: ports/66226 Submitted by: Tim Bishop <tim@bishnet.net>
Notes
Notes: svn path=/head/; revision=108348
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/gnubiff/Makefile43
-rw-r--r--mail/gnubiff/distinfo2
-rw-r--r--mail/gnubiff/files/patch-configure20
-rw-r--r--mail/gnubiff/files/patch-src::Applet.cc13
-rw-r--r--mail/gnubiff/files/patch-src::Setup.cc13
-rw-r--r--mail/gnubiff/pkg-descr13
-rw-r--r--mail/gnubiff/pkg-plist60
8 files changed, 165 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index bd6c0b1e4d2f..601f0e6aa75f 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -101,6 +101,7 @@
SUBDIR += gmime
SUBDIR += gmime2
SUBDIR += gnarwl
+ SUBDIR += gnubiff
SUBDIR += gnumail
SUBDIR += gotmail
SUBDIR += grepmail
diff --git a/mail/gnubiff/Makefile b/mail/gnubiff/Makefile
new file mode 100644
index 000000000000..37c6610c8cd9
--- /dev/null
+++ b/mail/gnubiff/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: gnubiff
+# Date created: 3 May 2004
+# Whom: Tim Bishop <tim@bishnet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnubiff
+PORTVERSION= 1.2.0
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= tim@bishnet.net
+COMMENT= A mail notification program for Gnome
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+USE_X_PREFIX= yes
+USE_GNOME= libglade2 esound
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= gnubiff.1
+INFO= gnubiff
+
+.if defined(WITH_GNUBIFF_PASSWORD)
+CONFIGURE_ARGS+= --with-password
+.endif
+
+.if defined(WITH_GNUBIFF_GNOME)
+CONFIGURE_ARGS+= --with-gnome
+USE_GNOME+= gnomepanel gconf2 gnomeprefix gnomehack
+PLIST_SUB+= WITH_GNUBIFF_GNOME=""
+PLIST_SUB+= SHAREDIR="share/gnome"
+.else
+PLIST_SUB+= WITH_GNUBIFF_GNOME="@comment "
+PLIST_SUB+= SHAREDIR="share"
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/gnubiff/distinfo b/mail/gnubiff/distinfo
new file mode 100644
index 000000000000..338c8572d464
--- /dev/null
+++ b/mail/gnubiff/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnubiff-1.2.0.tar.gz) = 63910d7656916b59f4ab18a33a92ff78
+SIZE (gnubiff-1.2.0.tar.gz) = 519590
diff --git a/mail/gnubiff/files/patch-configure b/mail/gnubiff/files/patch-configure
new file mode 100644
index 000000000000..4385a11a52ca
--- /dev/null
+++ b/mail/gnubiff/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.bak Mon May 3 19:00:27 2004
++++ configure Mon May 3 19:01:08 2004
+@@ -3868,7 +3868,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lssl $LIBS"
++LIBS="-lssl -lcrypto $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -3931,7 +3931,7 @@
+ #define HAVE_LIBSSL 1
+ _ACEOF
+
+- LIBS="-lssl $LIBS"
++ LIBS="-lssl -lcrypto $LIBS"
+
+ fi
+
diff --git a/mail/gnubiff/files/patch-src::Applet.cc b/mail/gnubiff/files/patch-src::Applet.cc
new file mode 100644
index 000000000000..d304607f25e0
--- /dev/null
+++ b/mail/gnubiff/files/patch-src::Applet.cc
@@ -0,0 +1,13 @@
+--- src/Applet.cc.bak Mon May 3 22:05:00 2004
++++ src/Applet.cc Mon May 3 22:05:19 2004
+@@ -108,9 +108,7 @@
+ else if (_owner->_sound_type == SOUND_FILE) {
+ std::stringstream s;
+ s << _owner->_sound_volume/100.0;
+- std::string command = "play \"" + _owner->_sound_file + std::string ("\" -v ");
+- command += s.str();
+- command += " &";
++ std::string command = "esdplay \"" + _owner->_sound_file + std::string ("\" &");
+ system (command.c_str());
+ }
+ }
diff --git a/mail/gnubiff/files/patch-src::Setup.cc b/mail/gnubiff/files/patch-src::Setup.cc
new file mode 100644
index 000000000000..c1c055692edc
--- /dev/null
+++ b/mail/gnubiff/files/patch-src::Setup.cc
@@ -0,0 +1,13 @@
+--- src/Setup.cc.bak Mon May 3 22:05:03 2004
++++ src/Setup.cc Mon May 3 22:05:14 2004
+@@ -765,9 +765,7 @@
+ gchar *data = (gchar *) g_object_get_data (G_OBJECT(get("soundfile")), "_file_");
+ std::stringstream s;
+ s << gfloat(gtk_range_get_value (GTK_RANGE (get ("volume"))))/100.0;
+- std::string command = "play \"" + std::string (data) + std::string ("\" -v ");
+- command += s.str();
+- command += " &";
++ std::string command = "esdplay \"" + std::string (data) + std::string ("\" &");
+ system (command.c_str());
+ }
+ }
diff --git a/mail/gnubiff/pkg-descr b/mail/gnubiff/pkg-descr
new file mode 100644
index 000000000000..ea77cffa9be6
--- /dev/null
+++ b/mail/gnubiff/pkg-descr
@@ -0,0 +1,13 @@
+gnubiff is a mail notification program that checks for mail, displays
+headers when new mail has arrived and allow to read first lines of
+new mails.
+
+It relies on the GNOME and GTK libraries but can be compiled and
+used with or without GNOME support. Supported protocols are pop3,
+apop, imap4, mh, qmail and mailfile.
+
+Furthermore, gnubiff is fully configurable with a lot of options
+like polltime, poptime, sounds, mail reader, mailbox names, etc.
+and can also filter spam.
+
+WWW: http://gnubiff.sourceforge.net/
diff --git a/mail/gnubiff/pkg-plist b/mail/gnubiff/pkg-plist
new file mode 100644
index 000000000000..4e629827cd0e
--- /dev/null
+++ b/mail/gnubiff/pkg-plist
@@ -0,0 +1,60 @@
+bin/gnubiff
+share/locale/fr/LC_MESSAGES/gnubiff.mo
+share/locale/de/LC_MESSAGES/gnubiff.mo
+share/locale/nl/LC_MESSAGES/gnubiff.mo
+share/locale/ro/LC_MESSAGES/gnubiff.mo
+share/locale/es/LC_MESSAGES/gnubiff.mo
+share/locale/sv/LC_MESSAGES/gnubiff.mo
+%%SHAREDIR%%/gnubiff/Setup.glade2
+%%SHAREDIR%%/gnubiff/AppletGTK.glade2
+%%SHAREDIR%%/gnubiff/AppletGNOME.glade2
+%%SHAREDIR%%/gnubiff/Popup.glade2
+%%SHAREDIR%%/gnubiff/BiffCredits.png
+%%SHAREDIR%%/gnubiff/BiffFont.png
+%%SHAREDIR%%/gnubiff/BiffGeometry.png
+%%SHAREDIR%%/gnubiff/BiffLayout.png
+%%SHAREDIR%%/gnubiff/BiffMailbox.png
+%%SHAREDIR%%/gnubiff/BiffOptions.png
+%%SHAREDIR%%/gnubiff/entry-list.png
+%%SHAREDIR%%/gnubiff/gnome-mail.png
+%%SHAREDIR%%/gnubiff/gnome-nomail.png
+%%SHAREDIR%%/gnubiff/gnubiff.png
+%%SHAREDIR%%/gnubiff/gnubiff_icon.png
+%%SHAREDIR%%/gnubiff/gtk-mail.png
+%%SHAREDIR%%/gnubiff/gtk-nomail.png
+%%SHAREDIR%%/gnubiff/logo.png
+%%SHAREDIR%%/gnubiff/menu-mode-RGB-alt.png
+%%SHAREDIR%%/gnubiff/menu_about.png
+%%SHAREDIR%%/gnubiff/menu_mail_read.png
+%%SHAREDIR%%/gnubiff/menu_mail_start.png
+%%SHAREDIR%%/gnubiff/stock-adress.png
+%%SHAREDIR%%/gnubiff/stock-alarm.png
+%%SHAREDIR%%/gnubiff/stock-biff.png
+%%SHAREDIR%%/gnubiff/stock-clock.png
+%%SHAREDIR%%/gnubiff/stock-file.png
+%%SHAREDIR%%/gnubiff/stock-mailbox.png
+%%SHAREDIR%%/gnubiff/stock-network.png
+%%SHAREDIR%%/gnubiff/stock-nossl.png
+%%SHAREDIR%%/gnubiff/stock-panel.png
+%%SHAREDIR%%/gnubiff/stock-password.png
+%%SHAREDIR%%/gnubiff/stock-popup.png
+%%SHAREDIR%%/gnubiff/stock-sound.png
+%%SHAREDIR%%/gnubiff/stock-soundfile.png
+%%SHAREDIR%%/gnubiff/stock-ssl-file-small.png
+%%SHAREDIR%%/gnubiff/stock-ssl-file.png
+%%SHAREDIR%%/gnubiff/stock-ssl.png
+%%SHAREDIR%%/gnubiff/stock-timer-stopped.png
+%%SHAREDIR%%/gnubiff/stock-timer.png
+%%SHAREDIR%%/gnubiff/stock-users.png
+%%SHAREDIR%%/gnubiff/stock-volume.png
+%%SHAREDIR%%/gnubiff/stock_left.png
+%%SHAREDIR%%/gnubiff/stock_right.png
+%%SHAREDIR%%/gnubiff/gnome-mail.gif
+%%SHAREDIR%%/gnubiff/gtk-mail.gif
+%%SHAREDIR%%/pixmaps/gnubiff_icon.png
+%%SHAREDIR%%/sounds/gnubiff/mail.wav
+%%SHAREDIR%%/sounds/gnubiff/coin.wav
+%%WITH_GNUBIFF_GNOME%%libdata/bonobo/servers/GNOME_gnubiffApplet.server
+%%WITH_GNUBIFF_GNOME%%%%SHAREDIR%%/gnome-2.0/ui/GNOME_gnubiffApplet.xml
+@dirrm %%SHAREDIR%%/gnubiff
+@dirrm %%SHAREDIR%%/sounds/gnubiff