aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-11-29 00:49:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-11-29 00:49:28 +0000
commit5a0513f1acb5a777b02c9378d45b4b1eb9c29c7e (patch)
tree114e796b6109883a5ce4117bbe8d6d757e18b5f5 /mail
parent3b8e68d1c510385f351df0451f2c7a40ae543944 (diff)
downloadports-5a0513f1acb5a777b02c9378d45b4b1eb9c29c7e.tar.gz
ports-5a0513f1acb5a777b02c9378d45b4b1eb9c29c7e.zip
MFH: r427291
gecko: fix Hunspell ABI mismatch PR: 214849 Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2016Q4/; revision=427351
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-bug132062139
2 files changed, 40 insertions, 1 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 4329dccc1639..bf2c7bef942d 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 45.5.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1320621 b/mail/thunderbird/files/patch-bug1320621
new file mode 100644
index 000000000000..170d2eba8baf
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1320621
@@ -0,0 +1,39 @@
+Make sure --enable-system-hunspell picks up system headers
+
+--- mozilla/extensions/spellcheck/hunspell/glue/moz.build
++++ mozilla/extensions/spellcheck/hunspell/glue/moz.build
+@@ -11,12 +11,14 @@ UNIFIED_SOURCES += [
+ 'RemoteSpellCheckEngineParent.cpp',
+ ]
+
+-CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
+-
+ FINAL_LIBRARY = 'xul'
+
++if CONFIG['MOZ_NATIVE_HUNSPELL']:
++ CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
++else:
++ LOCAL_INCLUDES += ['../src']
++
+ LOCAL_INCLUDES += [
+- '../src',
+ '/dom/base',
+ '/extensions/spellcheck/src',
+ ]
+--- mozilla/extensions/spellcheck/src/moz.build
++++ mozilla/extensions/spellcheck/src/moz.build
+@@ -17,9 +17,13 @@ UNIFIED_SOURCES += [
+
+ FINAL_LIBRARY = 'xul'
+
++if CONFIG['MOZ_NATIVE_HUNSPELL']:
++ CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
++else:
++ LOCAL_INCLUDES += ['../hunspell/src']
++
+ LOCAL_INCLUDES += [
+ '../hunspell/glue',
+- '../hunspell/src',
+ '/dom/base',
+ ]
+ EXPORTS.mozilla += [