aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 08:13:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 08:13:58 +0000
commitf329319eb51eb2930a53eb96f5f2932c737a71b8 (patch)
treeb57a522e4d6bc4ba4d5d17beaecdca9c5bc59d88 /mail
parent06af334ab9027f9aaad087ad2a4f1e684dc5cec7 (diff)
downloadports-f329319eb51eb2930a53eb96f5f2932c737a71b8.tar.gz
ports-f329319eb51eb2930a53eb96f5f2932c737a71b8.zip
Fix some non default LIB_DEPENDS
With hat: portmgr
Notes
Notes: svn path=/head/; revision=362049
Diffstat (limited to 'mail')
-rw-r--r--mail/avenger/Makefile2
-rw-r--r--mail/dspam/Makefile2
-rw-r--r--mail/mboxgrep/Makefile2
-rw-r--r--mail/mpop/Makefile2
-rw-r--r--mail/nullmailer/Makefile2
-rw-r--r--mail/opendkim/Makefile.features8
-rw-r--r--mail/opensmtpd-devel/Makefile2
-rw-r--r--mail/py-milter/Makefile2
-rw-r--r--mail/qsf/Makefile2
-rw-r--r--mail/sqwebmail/Makefile2
-rw-r--r--mail/tpop3d/Makefile2
-rw-r--r--mail/wmbiff/Makefile4
12 files changed, 16 insertions, 16 deletions
diff --git a/mail/avenger/Makefile b/mail/avenger/Makefile
index f0cb3d93f23c..27c043fae492 100644
--- a/mail/avenger/Makefile
+++ b/mail/avenger/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ARGS= --enable-ssl=${OPENSSLBASE} \
OPTIONS_DEFINE= SASL DOCS
SASL_CONFIGURE_ON= --enable-sasl
-SASL_LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2
+SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index cb33dbf15762..dcd37ad18d9e 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -369,7 +369,7 @@ RUN_DEPENDS+= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
. else
USE_APACHE_RUN= 22+
. endif
-LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
RUN_DEPENDS+= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
RUN_DEPENDS+= p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph
RUN_DEPENDS+= p5-GD-Graph3d>=0:${PORTSDIR}/graphics/p5-GD-Graph3d
diff --git a/mail/mboxgrep/Makefile b/mail/mboxgrep/Makefile
index 01e5939a6a8e..4167c6dd92a1 100644
--- a/mail/mboxgrep/Makefile
+++ b/mail/mboxgrep/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= anders@FreeBSD.org
COMMENT= Utility to scan mailboxes for messages matching a regular expression
-PCRE_LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
OPTIONS_DEFINE= DOCS PCRE
diff --git a/mail/mpop/Makefile b/mail/mpop/Makefile
index 77b8ed3c01d2..6e3bf3b5fe80 100644
--- a/mail/mpop/Makefile
+++ b/mail/mpop/Makefile
@@ -23,7 +23,7 @@ OPTIONS_RADIO_SSL= GNUTLS OPENSSL
OPTIONS_DEFAULT= IDN OPENSSL
OPTIONS_SUB= yes
-GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring:${PORTSDIR}/security/libgnome-keyring
+GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
GNOMEKEYRING_CONFIGURE_WITH= gnome-keyring
GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
GNUTLS_CONFIGURE_ON= --with-ssl=gnutls
diff --git a/mail/nullmailer/Makefile b/mail/nullmailer/Makefile
index 02e77ea62228..44e4716870d2 100644
--- a/mail/nullmailer/Makefile
+++ b/mail/nullmailer/Makefile
@@ -49,7 +49,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lgnutls
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/mail/opendkim/Makefile.features b/mail/opendkim/Makefile.features
index 656130129c59..b2af387aa483 100644
--- a/mail/opendkim/Makefile.features
+++ b/mail/opendkim/Makefile.features
@@ -36,7 +36,7 @@ CONFIGURE_ARGS+= --enable-default_sender
.if ${PORT_OPTIONS:MDIFFHEADERS}
CONFIGURE_ARGS+= --enable-diffheaders
-LIB_DEPENDS+= tre:${PORTSDIR}/textproc/libtre
+LIB_DEPENDS+= libtre.so:${PORTSDIR}/textproc/libtre
.else
CONFIGURE_ARGS+= --without-tre
.endif
@@ -112,14 +112,14 @@ PLIST_SUB+= REPRRD="@comment "
.if ${PORT_OPTIONS:MREPUTATION}
CONFIGURE_ARGS+= --enable-reputation \
--with-libcurl
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
. if ${PORT_OPTIONS:MXML}
CONFIGURE_ARGS+= --without-libjansson --with-libxml2
-LIB_DEPENDS+= xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= libxml2.so:${PORTSDIR}/textproc/libxml2
PLIST_SUB+= JANSSON="@comment "
. else
CONFIGURE_ARGS+= --with-libjansson
-LIB_DEPENDS+= jansson:${PORTSDIR}/devel/jansson
+LIB_DEPENDS+= libjansson.so:${PORTSDIR}/devel/jansson
MAN8+= autobuild.8
PLIST_SUB+= JANSSON=""
. endif
diff --git a/mail/opensmtpd-devel/Makefile b/mail/opensmtpd-devel/Makefile
index 51c2c94eba87..df97de55ecd5 100644
--- a/mail/opensmtpd-devel/Makefile
+++ b/mail/opensmtpd-devel/Makefile
@@ -59,7 +59,7 @@ LDAP_CONFIGURE_ON= --with-experimental-ldap
PAM_CONFIGURE_ON= --with-pam --with-pam-service=smtpd
-REDIS_LIB_DEPENDS= hiredis:${PORTSDIR}/databases/hiredis
+REDIS_LIB_DEPENDS= libhiredis.so:${PORTSDIR}/databases/hiredis
REDIS_CONFIGURE_ON= --with-experimental-redis
USE_OPENSSL= yes
diff --git a/mail/py-milter/Makefile b/mail/py-milter/Makefile
index 264d4cf8b480..341ee6bd477a 100644
--- a/mail/py-milter/Makefile
+++ b/mail/py-milter/Makefile
@@ -16,7 +16,7 @@ COMMENT= Python interface to Sendmail milter API
LICENSE= GPLv2
.if !exists(/usr/lib/libmilter.so)
-LIB_DEPENDS= milter:${PORTSDIR}/mail/sendmail
+LIB_DEPENDS= libmilter.so:${PORTSDIR}/mail/sendmail
.endif
PYPORTNAME= ${PKGNAMEPREFIX:C/[0-9]+-//}${PORTNAME}
diff --git a/mail/qsf/Makefile b/mail/qsf/Makefile
index 46e45211318e..2f20e3088a7c 100644
--- a/mail/qsf/Makefile
+++ b/mail/qsf/Makefile
@@ -25,7 +25,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGDBM}
-LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
.else
CONFIGURE_ARGS+= --without-gdbm
.endif
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 20f862533c4a..b82ac7b982eb 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -160,7 +160,7 @@ CONFIGURE_ARGS+= --enable-maxpurge=${WITH_MAXPURGE}
.if ${PORT_OPTIONS:MGDBM}
CONFIGURE_ARGS+=--with-db=gdbm
-LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
.else
CONFIGURE_ARGS+=--with-db=db
.endif
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index a5b1186150a2..8c5acc81f897 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -41,7 +41,7 @@ PASSWDAUTH_CONFIGURE_ENABLE= auth-passwd
MBOXINDICES_CONFIGURE_ENABLE= mbox-bsd-save-indices
DRAC_BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
-GDBMAUTH_LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm
+GDBMAUTH_LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm
.include <bsd.port.options.mk>
diff --git a/mail/wmbiff/Makefile b/mail/wmbiff/Makefile
index 0e4b3fced4b9..b5ee8dbdb77b 100644
--- a/mail/wmbiff/Makefile
+++ b/mail/wmbiff/Makefile
@@ -31,8 +31,8 @@ PLIST_DIRS= %%DATADIR%%/skins \
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt \
- gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgnutls.so:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --with-libgnutls-prefix=${LOCALBASE} \
--with-libgcrypt-prefix=${LOCALBASE}
.else