aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-08-09 15:46:23 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-08-09 15:46:23 +0000
commit09b53e83887a51d2a7869e6d700e4bece18c6dae (patch)
tree6474e5dd4794a5e01a54741f77fb55987fb99bc9 /mail
parentc6946a09a33ce3b995baf2488cde66f54fed7334 (diff)
downloadports-09b53e83887a51d2a7869e6d700e4bece18c6dae.tar.gz
ports-09b53e83887a51d2a7869e6d700e4bece18c6dae.zip
- Trim Makefile header
- Remove NO_PACKAGE, it needs manual configuration post installation but it packages fine and BSD license allows it - Unbreak with clang (reported by pkg-fallout) - Remove obsolete MAKE_JOBS_SAFE - Mute MKDIR - Remove loop in DOCS installation - Pad PKGMESSAGE
Notes
Notes: svn path=/head/; revision=324446
Diffstat (limited to 'mail')
-rw-r--r--mail/smtpfeed/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/mail/smtpfeed/Makefile b/mail/smtpfeed/Makefile
index 6635d569fb1f..2d546e07e940 100644
--- a/mail/smtpfeed/Makefile
+++ b/mail/smtpfeed/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: smtpfeed
-# Date created: 17 January 1998
-# Whom: itojun@itojun.org
-#
+# Created by: itojun@itojun.org
# $FreeBSD$
-#
PORTNAME= smtpfeed
PORTVERSION= 1.21
@@ -16,12 +12,10 @@ COMMENT= SMTP Fast Exploding External Deliverer for Sendmail
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-NO_PACKAGE= complex configuration for sendmail.cf needed
-
OPTIONS_DEFINE= DOCS
+CFLAGS+= -Wno-error=return-type
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message
@@ -37,11 +31,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/smtpfeed ${PREFIX}/libexec
${INSTALL_MAN} ${WRKSRC}/smtpfeed.8 ${MAN8PREFIX}/man/man8
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.mk>