aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-09 05:08:38 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-09 05:08:38 +0000
commit09e82cb728a7a06fb7469a6ed15b2a01c4903f30 (patch)
tree56fe13af63b2f54eea7561a00e6db35409dfdbc2 /mail
parent5ff0e91908e73b2edfbbe782cf08afcdd43c8328 (diff)
downloadports-09e82cb728a7a06fb7469a6ed15b2a01c4903f30.tar.gz
ports-09e82cb728a7a06fb7469a6ed15b2a01c4903f30.zip
mail/p5-Mail-Box: p5-File-Spec should only be used if perl < 5.8
PR: ports/44722 Submitted by: Alan Eldridge <alane@geeksrus.net> Approved by: tobez
Notes
Notes: svn path=/head/; revision=75157
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-Box/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/mail/p5-Mail-Box/Makefile b/mail/p5-Mail-Box/Makefile
index dff9ecc5e149..5411c19b4c83 100644
--- a/mail/p5-Mail-Box/Makefile
+++ b/mail/p5-Mail-Box/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
-BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
- ${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+BUILD_DEPENDS= ${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -43,4 +42,10 @@ post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@]\w+)/use vars qw($$1);$$1/' \
${WRKSRC}/Message.pm
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+.include <bsd.port.post.mk>