aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-02-20 16:33:26 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-02-20 16:33:26 +0000
commit628b215647a7f7c1e3232ad55bb67fd7cbdb9f14 (patch)
tree9dee99152b7b92fefea393e2a79a64b07ab74dff /mail
parent029b209d330e5082cbae2c7100c55eed692fafd2 (diff)
downloadports-628b215647a7f7c1e3232ad55bb67fd7cbdb9f14.tar.gz
ports-628b215647a7f7c1e3232ad55bb67fd7cbdb9f14.zip
Conditionalise several dependencies on PERL_LEVEL to make those ports more
friendly for perl-5.8.0, which has those dependencies included into the base distribution. Sponsired by: Porta Software Ltd
Notes
Notes: svn path=/head/; revision=75949
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-MIME-Tools/Makefile9
-rw-r--r--mail/p5-Mail-Tools/Makefile12
2 files changed, 15 insertions, 6 deletions
diff --git a/mail/p5-MIME-Tools/Makefile b/mail/p5-MIME-Tools/Makefile
index 11209cce15e2..03a8d8b610a4 100644
--- a/mail/p5-MIME-Tools/Makefile
+++ b/mail/p5-MIME-Tools/Makefile
@@ -16,7 +16,6 @@ DISTNAME= MIME-tools-${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Mail/Header.pm:${PORTSDIR}/mail/p5-Mail-Tools \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/IO/Wrap.pm:${PORTSDIR}/devel/p5-IO-stringy
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -46,8 +45,14 @@ MAN3= MIME::Body.3 \
MIME::WordDecoder.3 \
MIME::Words.3
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
post-patch:
@${RM} -f ${WRKSRC}/lib/MIME/Field/ParamVal.pm.orig \
${WRKSRC}/lib/MIME/Words.pm.orig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-Tools/Makefile b/mail/p5-Mail-Tools/Makefile
index b0408c1e6fc9..fa0a95506ff4 100644
--- a/mail/p5-Mail-Tools/Makefile
+++ b/mail/p5-Mail-Tools/Makefile
@@ -15,9 +15,6 @@ DISTNAME= MailTools-${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
-BUILD_DEPENDS= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -32,4 +29,11 @@ MAN3= Mail::Address.3 \
Mail::Send.3 \
Mail::Util.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>