aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-20 19:06:29 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-20 19:06:29 +0000
commit68edbeeaae964d81a4b96aea76974015371e7b07 (patch)
tree3686bc2aca372d50de8d274ce1e86a1d8116f741 /mail
parent6c829b8efd7cb4bfc790ad69a46f7638be9160d4 (diff)
downloadports-68edbeeaae964d81a4b96aea76974015371e7b07.tar.gz
ports-68edbeeaae964d81a4b96aea76974015371e7b07.zip
- Display a stage-qa warning when ports use PREFIX/var instead of /var
- Add --localstatedir=/var to _LATE_CONFIGURE_ARGS (like --mandir) but not when CONFIGURE_ARGS already sets it. (GNU configure scripts set it to PREFIX/var when PREFIX != /usr.) - Add --localstatedir="${PREFIX}/var" to CONFIGURE_ARGS in some ports so they aren't affected by this change (for now at least). This commit is meant to ensure that new ports don't make the same mistake. - games/acm: the configure script in this port is very old; instead of patching it more, just replace GNU_CONFIGURE with HAS_CONFIGURE. - irc/charybdis: it already used /var but adding --localstatedir=/var changed the behaviour of the configure script; adjust the port to this. PR: 199506 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=384380
Diffstat (limited to 'mail')
-rw-r--r--mail/courier-imap/Makefile1
-rw-r--r--mail/gnarwl/Makefile2
2 files changed, 2 insertions, 1 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 29b2c87c7bfa..90c5f6f2695b 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -49,6 +49,7 @@ PLIST_SUB= CONFDIR=${CONFDIR:S,^${PREFIX}/,,} \
LIBEXECDIR=${LIBEXECDIR:S,^${PREFIX}/,,}
CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
+ --localstatedir="${PREFIX}/var" \
--datadir=${DATADIR} \
--libexecdir=${LIBEXECDIR} \
--enable-workarounds-for-imap-client-bugs \
diff --git a/mail/gnarwl/Makefile b/mail/gnarwl/Makefile
index a6eec21456c1..b8cf5d2292f1 100644
--- a/mail/gnarwl/Makefile
+++ b/mail/gnarwl/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
USES= iconv gmake tar:tgz
USE_OPENLDAP= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
+CONFIGURE_ARGS= --with-docdir=${DOCSDIR} --localstatedir="${PREFIX}/var"
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}