aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-01-23 13:32:09 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-01-23 13:32:09 +0000
commit7db03c9a369dd09a09104efdb4071b513e84abf5 (patch)
tree60aa16afd47a08300d1bf78c927a60973974a5fc /mail
parentf7747a8f6221b68dd54a6f54780973a982390852 (diff)
downloadports-7db03c9a369dd09a09104efdb4071b513e84abf5.tar.gz
ports-7db03c9a369dd09a09104efdb4071b513e84abf5.zip
- add a patch so we have sensible defaults for freebsd
- bump PORTREVISION PR: 47137 Submitted by: Marco Molteni <molter@tin.it>
Notes
Notes: svn path=/head/; revision=73860
Diffstat (limited to 'mail')
-rw-r--r--mail/qmHandle/Makefile5
-rw-r--r--mail/qmHandle/files/patch-qmHandle34
-rw-r--r--mail/qmhandle/Makefile5
-rw-r--r--mail/qmhandle/files/patch-qmHandle34
4 files changed, 76 insertions, 2 deletions
diff --git a/mail/qmHandle/Makefile b/mail/qmHandle/Makefile
index ff331832a24e..cc618a1fbbb4 100644
--- a/mail/qmHandle/Makefile
+++ b/mail/qmHandle/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qmHandle
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.italpro.net/mb/soft/
@@ -17,6 +18,7 @@ RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-qstat:${PORTSDIR}/mail/qmail
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_BZIP2= yes
+USE_PERL5= yes
.if exists(${LOCALBASE}/qmail/bin/qmail-qstat)
QMAIL_DIR?= ${LOCALBASE}/qmail
@@ -25,7 +27,8 @@ QMAIL_DIR?= /var/qmail
.endif
post-patch:
- @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/qmHandle
+ @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},; \
+ s,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/qmHandle
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/qmHandle ${PREFIX}/bin
diff --git a/mail/qmHandle/files/patch-qmHandle b/mail/qmHandle/files/patch-qmHandle
new file mode 100644
index 000000000000..f894d23c0365
--- /dev/null
+++ b/mail/qmHandle/files/patch-qmHandle
@@ -0,0 +1,34 @@
+$FreeBSD$
+
+--- qmHandle.orig Thu Jan 16 10:05:21 2003
++++ qmHandle Thu Jan 16 10:31:33 2003
+@@ -26,8 +26,12 @@
+ #my ($startqmail) = '/usr/local/bin/svc -u /service/qmail-send';
+
+ # While this is if you have a Debian GNU/Linux with its qmail package
+-my ($stopqmail) = '/etc/init.d/qmail stop';
+-my ($startqmail) = '/etc/init.d/qmail start';
++#my ($stopqmail) = '/etc/init.d/qmail stop';
++#my ($startqmail) = '/etc/init.d/qmail start';
++
++# This is if you have FreeBSD with its qmail package
++my ($stopqmail) = '%%LOCALBASE%%/etc/rc.d/qmail.sh stop';
++my ($startqmail) = '%%LOCALBASE%%/etc/rc.d/qmail.sh start';
+
+ # If you don't have scripts, leave $stopqmail blank (the process will
+ # be hunted and killed by qmHandle):
+@@ -43,7 +47,10 @@
+ #####
+ # Enter here the system command which returns qmail PID. The following
+ # should work on most Unixes:
+-my ($pidcmd) = 'pidof qmail-send';
++#my ($pidcmd) = 'pidof qmail-send';
++# This is for FreeBSD with a standard qmail installation:
++my ($pidcmd) = 'ps -U qmails | grep qmail-send | cut -s -d " " -f 3';
++
+
+ #################### USER CONFIGURATION END ####################
+
+
+
+
diff --git a/mail/qmhandle/Makefile b/mail/qmhandle/Makefile
index ff331832a24e..cc618a1fbbb4 100644
--- a/mail/qmhandle/Makefile
+++ b/mail/qmhandle/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qmHandle
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.italpro.net/mb/soft/
@@ -17,6 +18,7 @@ RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-qstat:${PORTSDIR}/mail/qmail
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_BZIP2= yes
+USE_PERL5= yes
.if exists(${LOCALBASE}/qmail/bin/qmail-qstat)
QMAIL_DIR?= ${LOCALBASE}/qmail
@@ -25,7 +27,8 @@ QMAIL_DIR?= /var/qmail
.endif
post-patch:
- @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/qmHandle
+ @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},; \
+ s,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/qmHandle
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/qmHandle ${PREFIX}/bin
diff --git a/mail/qmhandle/files/patch-qmHandle b/mail/qmhandle/files/patch-qmHandle
new file mode 100644
index 000000000000..f894d23c0365
--- /dev/null
+++ b/mail/qmhandle/files/patch-qmHandle
@@ -0,0 +1,34 @@
+$FreeBSD$
+
+--- qmHandle.orig Thu Jan 16 10:05:21 2003
++++ qmHandle Thu Jan 16 10:31:33 2003
+@@ -26,8 +26,12 @@
+ #my ($startqmail) = '/usr/local/bin/svc -u /service/qmail-send';
+
+ # While this is if you have a Debian GNU/Linux with its qmail package
+-my ($stopqmail) = '/etc/init.d/qmail stop';
+-my ($startqmail) = '/etc/init.d/qmail start';
++#my ($stopqmail) = '/etc/init.d/qmail stop';
++#my ($startqmail) = '/etc/init.d/qmail start';
++
++# This is if you have FreeBSD with its qmail package
++my ($stopqmail) = '%%LOCALBASE%%/etc/rc.d/qmail.sh stop';
++my ($startqmail) = '%%LOCALBASE%%/etc/rc.d/qmail.sh start';
+
+ # If you don't have scripts, leave $stopqmail blank (the process will
+ # be hunted and killed by qmHandle):
+@@ -43,7 +47,10 @@
+ #####
+ # Enter here the system command which returns qmail PID. The following
+ # should work on most Unixes:
+-my ($pidcmd) = 'pidof qmail-send';
++#my ($pidcmd) = 'pidof qmail-send';
++# This is for FreeBSD with a standard qmail installation:
++my ($pidcmd) = 'ps -U qmails | grep qmail-send | cut -s -d " " -f 3';
++
+
+ #################### USER CONFIGURATION END ####################
+
+
+
+