aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-04 09:48:54 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-04 09:48:54 +0000
commit4c7f7c366c05f95c8de1a04a28a10edb2520a8d3 (patch)
tree953022d190d94b7533bdc20a56ca5c5bc39761c5 /mail
parent890a5c28b9179800069ccab16b7696ec0b0687f5 (diff)
downloadports-4c7f7c366c05f95c8de1a04a28a10edb2520a8d3.tar.gz
ports-4c7f7c366c05f95c8de1a04a28a10edb2520a8d3.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Notes
Notes: svn path=/head/; revision=326265
Diffstat (limited to 'mail')
-rw-r--r--mail/anomy-sanitizer/Makefile2
-rw-r--r--mail/couriergraph/Makefile2
-rw-r--r--mail/cyrus2dovecot/Makefile2
-rw-r--r--mail/gotmail/Makefile2
-rw-r--r--mail/p5-CGP-CLI/Makefile3
-rw-r--r--mail/p5-Dancer-Plugin-Email/Makefile3
-rw-r--r--mail/p5-Data-Validate-Email/Makefile3
-rw-r--r--mail/p5-Email-AddressParser/Makefile3
-rw-r--r--mail/p5-Email-MIME-Creator-ISO_2022_JP/Makefile3
-rw-r--r--mail/p5-Email-Sender-Transport-SQLite/Makefile3
-rw-r--r--mail/p5-GMail-IMAPD/Makefile3
-rw-r--r--mail/p5-Mail-Alias/Makefile3
-rw-r--r--mail/p5-Mail-DeliveryStatus-BounceParser/Makefile3
-rw-r--r--mail/p5-Mail-Verify/Makefile3
-rw-r--r--mail/p5-Net-IMAP-Server/Makefile3
-rw-r--r--mail/pflogsumm/Makefile2
-rw-r--r--mail/qar-bufo/Makefile2
-rw-r--r--mail/qmqtool/Makefile2
-rw-r--r--mail/sastatd/Makefile3
19 files changed, 31 insertions, 19 deletions
diff --git a/mail/anomy-sanitizer/Makefile b/mail/anomy-sanitizer/Makefile
index 0d02302b00d7..f64109085e12 100644
--- a/mail/anomy-sanitizer/Makefile
+++ b/mail/anomy-sanitizer/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://mailtools.anomy.net/dist/
MAINTAINER= jmohacsi@bsd.hu
COMMENT= Sanitize and clean incoming/outgoing mail
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
WRKSRC= ${WRKDIR}/anomy
diff --git a/mail/couriergraph/Makefile b/mail/couriergraph/Makefile
index 1bb49bb9a11b..c56d9f1f0edd 100644
--- a/mail/couriergraph/Makefile
+++ b/mail/couriergraph/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= rrdtool>=0:${PORTSDIR}/databases/rrdtool \
p5-File-Tail>=0:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
DATADIR?= /var/db/couriergraph
COURIERGRAPH_USER?= ${WWWOWN}
diff --git a/mail/cyrus2dovecot/Makefile b/mail/cyrus2dovecot/Makefile
index 3163d436042e..895b79dddf4d 100644
--- a/mail/cyrus2dovecot/Makefile
+++ b/mail/cyrus2dovecot/Makefile
@@ -14,7 +14,7 @@ COMMENT= Convert Cyrus folders to Dovecot
PLIST_FILES= bin/${PORTNAME}
MAN1= ${PORTNAME}.1
-USE_PERL5= yes
+USES= perl5
NO_WRKSUBDIR= yes
post-extract:
diff --git a/mail/gotmail/Makefile b/mail/gotmail/Makefile
index 42f58f2cd495..7505ffdc912b 100644
--- a/mail/gotmail/Makefile
+++ b/mail/gotmail/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
p5-Net>=0:${PORTSDIR}/net/p5-Net
MAN1= ${PORTNAME}.1
-USE_PERL5= yes
+USES= perl5
do-install:
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man \
diff --git a/mail/p5-CGP-CLI/Makefile b/mail/p5-CGP-CLI/Makefile
index 67feb9b0343c..57c8e2127086 100644
--- a/mail/p5-CGP-CLI/Makefile
+++ b/mail/p5-CGP-CLI/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= avk@vl.ru
COMMENT= CommunigatePro Command Line Interface perl module
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGP::CLI.3
diff --git a/mail/p5-Dancer-Plugin-Email/Makefile b/mail/p5-Dancer-Plugin-Email/Makefile
index 8bc689471bf3..b0f76b0e3ca9 100644
--- a/mail/p5-Dancer-Plugin-Email/Makefile
+++ b/mail/p5-Dancer-Plugin-Email/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Dancer>=1.2:${PORTSDIR}/www/p5-Dancer \
p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dancer::Plugin::Email.3
diff --git a/mail/p5-Data-Validate-Email/Makefile b/mail/p5-Data-Validate-Email/Makefile
index 83628579313b..1c680a0c1848 100644
--- a/mail/p5-Data-Validate-Email/Makefile
+++ b/mail/p5-Data-Validate-Email/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-Data-Validate-Domain>=0:${PORTSDIR}/dns/p5-Data-Validate-Domain
p5-Email-Address>=0:${PORTSDIR}/mail/p5-Email-Address \
p5-Net-Domain-TLD>=0:${PORTSDIR}/dns/p5-Net-Domain-TLD
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Validate::Email.3
diff --git a/mail/p5-Email-AddressParser/Makefile b/mail/p5-Email-AddressParser/Makefile
index 60b6b2d24fbb..f35f62be579a 100644
--- a/mail/p5-Email-AddressParser/Makefile
+++ b/mail/p5-Email-AddressParser/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dliakh@ukr.net
COMMENT= RFC 2822 Address Parsing and Creation
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::AddressParser.3
diff --git a/mail/p5-Email-MIME-Creator-ISO_2022_JP/Makefile b/mail/p5-Email-MIME-Creator-ISO_2022_JP/Makefile
index 904f474c580b..51a71ed0e853 100644
--- a/mail/p5-Email-MIME-Creator-ISO_2022_JP/Makefile
+++ b/mail/p5-Email-MIME-Creator-ISO_2022_JP/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Classy>=0:${PORTSDIR}/devel/p5-Test-Classy \
p5-Test-UseAllModules>=0:${PORTSDIR}/devel/p5-Test-UseAllModules
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::MIME::Creator::ISO_2022_JP.3
diff --git a/mail/p5-Email-Sender-Transport-SQLite/Makefile b/mail/p5-Email-Sender-Transport-SQLite/Makefile
index 94478be41ff8..c8970efc8f6c 100644
--- a/mail/p5-Email-Sender-Transport-SQLite/Makefile
+++ b/mail/p5-Email-Sender-Transport-SQLite/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-Email-Sender>=0.091660:${PORTSDIR}/mail/p5-Email-Sender
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Sender::Transport::SQLite.3
diff --git a/mail/p5-GMail-IMAPD/Makefile b/mail/p5-GMail-IMAPD/Makefile
index f77ed8d1d147..0d70eebf4020 100644
--- a/mail/p5-GMail-IMAPD/Makefile
+++ b/mail/p5-GMail-IMAPD/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl IMAP4 gateway to Google's webmail service
BUILD_DEPENDS= p5-Mail-Webmail-Gmail>=0:${PORTSDIR}/mail/p5-Mail-Webmail-Gmail
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GMail::IMAPD.3
diff --git a/mail/p5-Mail-Alias/Makefile b/mail/p5-Mail-Alias/Makefile
index 6c982ef4a3b4..3c444e7e3317 100644
--- a/mail/p5-Mail-Alias/Makefile
+++ b/mail/p5-Mail-Alias/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= chifeng@gmail.com
COMMENT= Mail::Alias
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mail::Alias.3
diff --git a/mail/p5-Mail-DeliveryStatus-BounceParser/Makefile b/mail/p5-Mail-DeliveryStatus-BounceParser/Makefile
index 9c28f3fe22ee..8d30a96a4c04 100644
--- a/mail/p5-Mail-DeliveryStatus-BounceParser/Makefile
+++ b/mail/p5-Mail-DeliveryStatus-BounceParser/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= p5-MIME-Tools>=5.418:${PORTSDIR}/mail/p5-MIME-Tools \
p5-Mail-Tools>=2.04:${PORTSDIR}/mail/p5-Mail-Tools
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mail::DeliveryStatus::BounceParser.3
diff --git a/mail/p5-Mail-Verify/Makefile b/mail/p5-Mail-Verify/Makefile
index 01bb635fc88c..96ded3612358 100644
--- a/mail/p5-Mail-Verify/Makefile
+++ b/mail/p5-Mail-Verify/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl module to verify email addresses
BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mail::Verify.3
diff --git a/mail/p5-Net-IMAP-Server/Makefile b/mail/p5-Net-IMAP-Server/Makefile
index a2a348b06cd9..7ac46f7201fa 100644
--- a/mail/p5-Net-IMAP-Server/Makefile
+++ b/mail/p5-Net-IMAP-Server/Makefile
@@ -26,7 +26,8 @@ BUILD_DEPENDS= p5-Net-Server-Coro>=0.6:${PORTSDIR}/net/p5-Net-Server-Coro \
p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::IMAP::Server.3 \
Net::IMAP::Server::Command.3 \
diff --git a/mail/pflogsumm/Makefile b/mail/pflogsumm/Makefile
index 2a240c67ab14..e82f0e6c906a 100644
--- a/mail/pflogsumm/Makefile
+++ b/mail/pflogsumm/Makefile
@@ -18,7 +18,7 @@ COMMENT= Postfix Log Entry Summarizer
RUN_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/pflogsumm
.if !defined(NOPORTDOCS)
PORTDOCS= README ToDo pflogsumm-faq.txt
diff --git a/mail/qar-bufo/Makefile b/mail/qar-bufo/Makefile
index 023fa86da89b..99fd534139f1 100644
--- a/mail/qar-bufo/Makefile
+++ b/mail/qar-bufo/Makefile
@@ -16,7 +16,7 @@ EXTRACT_ONLY=
MAINTAINER= vvelox@vvelox.net
COMMENT= Generates the Qmail assign and recipients file based on unix groups
-USE_PERL5= yes
+USES= perl5
NO_WRKSUBDIR= yes
MAN1= qar-bufo.1
diff --git a/mail/qmqtool/Makefile b/mail/qmqtool/Makefile
index 27a1e039d9fb..6d82dcba0754 100644
--- a/mail/qmqtool/Makefile
+++ b/mail/qmqtool/Makefile
@@ -18,7 +18,7 @@ COMMENT= Tool to manipulate contents of a qmail queue
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/qmqtool ${PREFIX}/bin
diff --git a/mail/sastatd/Makefile b/mail/sastatd/Makefile
index 64bbf5a33e9f..2e50398e2c78 100644
--- a/mail/sastatd/Makefile
+++ b/mail/sastatd/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
SASTATD_DBDIR?= /var/db/sastatd
SASTATD_RUNDIR?= /var/run/sastatd