aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-26 12:05:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-26 12:05:08 +0000
commit40a447e03038b654543d6f22b837324de0f2cdcd (patch)
tree7efaab9aa4fa87e5b9b9b0dfec72930d0783cc0d /mail
parentfd494c530d248475a4f2a94866d24b150be448b2 (diff)
downloadports-40a447e03038b654543d6f22b837324de0f2cdcd.tar.gz
ports-40a447e03038b654543d6f22b837324de0f2cdcd.zip
New sibling bogofilter port to use the sqlite3 database backend.
PR: ports/81448 Submitted by: Matthias Andree <matthias.andree@gmx.de>
Notes
Notes: svn path=/head/; revision=136161
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/bogofilter-sqlite/Makefile27
2 files changed, 28 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index c57c3bab81bb..6ded375a2b85 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -29,6 +29,7 @@
SUBDIR += bmf
SUBDIR += bogofilter
SUBDIR += bogofilter-qdbm
+ SUBDIR += bogofilter-sqlite
SUBDIR += bogofilter-tdb
SUBDIR += bsfilter
SUBDIR += bsmtp
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
new file mode 100644
index 000000000000..99e160676745
--- /dev/null
+++ b/mail/bogofilter-sqlite/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: bogofilter-sqlite
+# Date created: 2005-05-24
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bogofilter
+PORTREVISION= 0
+CATEGORIES= mail
+PKGNAMESUFFIX= -sqlite
+
+MAINTAINER= matthias.andree@gmx.de
+
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+CONFLICTS= bogofilter-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tdb-[0-9]* \
+ [a-z][a-z]-bogofilter-[0-9]* bogofilter-current-[0-9]*
+
+CONFIGURE_ARGS= --with-database=sqlite
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+DESCR= ${PKGDIR}/pkg-descr
+
+MASTERDIR= ${.CURDIR}/../bogofilter
+
+.include "${MASTERDIR}/Makefile"