aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /mail
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'mail')
-rw-r--r--mail/balsa/Makefile3
-rw-r--r--mail/courier/Makefile2
-rw-r--r--mail/crashecho/Makefile2
-rw-r--r--mail/cyrus-imapd22/Makefile3
-rw-r--r--mail/cyrus-imapd23/Makefile3
-rw-r--r--mail/cyrus-imapd24/Makefile3
-rw-r--r--mail/dspam-devel/Makefile2
-rw-r--r--mail/dspam/Makefile2
-rw-r--r--mail/evolution-sharp/Makefile2
-rw-r--r--mail/gmime/Makefile2
-rw-r--r--mail/gmime2/Makefile2
-rw-r--r--mail/jamlib/Makefile2
-rw-r--r--mail/libesmtp/Makefile2
-rw-r--r--mail/libetpan/Makefile2
-rw-r--r--mail/libnewmail/Makefile3
-rw-r--r--mail/libspf/Makefile2
-rw-r--r--mail/libspf2-10/Makefile2
-rw-r--r--mail/libspf2/Makefile2
-rw-r--r--mail/libsrs2/Makefile2
-rw-r--r--mail/libvmime/Makefile2
-rw-r--r--mail/mail-notification/Makefile2
-rw-r--r--mail/mutt-devel/Makefile3
-rw-r--r--mail/mutt/Makefile3
-rw-r--r--mail/mutt14/Makefile3
-rw-r--r--mail/nmh/Makefile2
-rw-r--r--mail/perdition/Makefile2
-rw-r--r--mail/pfqueue/Makefile2
-rw-r--r--mail/pop3lite/Makefile2
-rw-r--r--mail/pop3proxy/Makefile2
-rw-r--r--mail/popular/Makefile2
-rw-r--r--mail/postfix-gps-devel/Makefile3
-rw-r--r--mail/postfix-gps/Makefile3
-rw-r--r--mail/qpopper/Makefile2
-rw-r--r--mail/quickml/Makefile2
-rw-r--r--mail/rabl_client/Makefile2
-rw-r--r--mail/rabl_server/Makefile2
-rw-r--r--mail/sccmilter/Makefile2
-rw-r--r--mail/sqwebmail/Makefile2
-rw-r--r--mail/sylpheed/Makefile2
-rw-r--r--mail/sylpheed2-devel/Makefile2
-rw-r--r--mail/sylpheed2/Makefile2
-rw-r--r--mail/sylpheed3/Makefile2
-rw-r--r--mail/xfmail/Makefile2
43 files changed, 43 insertions, 53 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 0e62ae3218bb..4e838d2467d4 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -32,8 +32,7 @@ USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui libgnomeprintui \
gtkhtml3
USE_REINPLACE= yes
USE_GCC= 3.4+
-USE_LIBTOOL_VER=15
-USE_LIBLTDL= yes
+USE_AUTOTOOLS= libltdl:15 libtool:15
USE_ICONV= yes
CONFIGURE_ARGS= --enable-threads \
--enable-gtkhtml \
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index 829c04b5fc96..4887bc1ae1e5 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -66,7 +66,7 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_OPENSSL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
.if defined(WITH_RCORDER)
USE_RCORDER= courier.sh
diff --git a/mail/crashecho/Makefile b/mail/crashecho/Makefile
index fc1c45c0ba4d..7786aefef592 100644
--- a/mail/crashecho/Makefile
+++ b/mail/crashecho/Makefile
@@ -25,7 +25,7 @@ EXTRACT_CMD= rpm2cpio
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= | ${CPIO} -i
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= crashecho.1 \
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index e12ca954a4c6..a92756663d7c 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -176,8 +176,7 @@ CONFIGURE_ARGS+=--enable-netscapehack
EXTRA_PATCHES+= ${WRKSRC}/contrib/drac_auth.patch
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aclocal.m4 \
${FILESDIR}/extra-patch-configure.in
-USE_AUTOCONF_VER=259
-USE_AUTOHEADER_VER=259
+USE_AUTOTOOLS= autoconf:259 autoheader:259
CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index e12ca954a4c6..a92756663d7c 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -176,8 +176,7 @@ CONFIGURE_ARGS+=--enable-netscapehack
EXTRA_PATCHES+= ${WRKSRC}/contrib/drac_auth.patch
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aclocal.m4 \
${FILESDIR}/extra-patch-configure.in
-USE_AUTOCONF_VER=259
-USE_AUTOHEADER_VER=259
+USE_AUTOTOOLS= autoconf:259 autoheader:259
CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index e12ca954a4c6..a92756663d7c 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -176,8 +176,7 @@ CONFIGURE_ARGS+=--enable-netscapehack
EXTRA_PATCHES+= ${WRKSRC}/contrib/drac_auth.patch
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aclocal.m4 \
${FILESDIR}/extra-patch-configure.in
-USE_AUTOCONF_VER=259
-USE_AUTOHEADER_VER=259
+USE_AUTOTOOLS= autoconf:259 autoheader:259
CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 096c637d10d9..08d6c408c966 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -88,7 +88,7 @@ OPTIONS+= QMAIL "Play nice with Qmail mail server" off
OPTIONS+= CGI "Install CGI (pulls in apache)" off
OPTIONS+= TRAIN_SCRIPT "Install trainning script (needs perl)" off
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 8f0d8f1477d3..4a03b233131a 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -90,7 +90,7 @@ OPTIONS+= QMAIL "Play nice with Qmail mail server" off
OPTIONS+= CGI "Install CGI (pulls in apache)" off
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/mail/evolution-sharp/Makefile b/mail/evolution-sharp/Makefile
index 17354e00b273..cafa39afd7a0 100644
--- a/mail/evolution-sharp/Makefile
+++ b/mail/evolution-sharp/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
USE_GNOME= gnomehack evolutiondataserver
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/mail/gmime/Makefile b/mail/gmime/Makefile
index 52e45fbd5c31..a6d4d2ac0316 100644
--- a/mail/gmime/Makefile
+++ b/mail/gmime/Makefile
@@ -19,7 +19,7 @@ GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_GNOME= glib12
USE_ICONV= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CFLAGS+= -L${LOCALBASE}/lib # req'd to find iconv
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/mail/gmime2/Makefile b/mail/gmime2/Makefile
index 8fc8e1fb262f..7d137da32c13 100644
--- a/mail/gmime2/Makefile
+++ b/mail/gmime2/Makefile
@@ -18,7 +18,7 @@ CONFLICTS= gmime-1.0.*
USE_ICONV= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget glib20
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS?= --with-libiconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc \
--enable-mono=no
diff --git a/mail/jamlib/Makefile b/mail/jamlib/Makefile
index 8a0356fb17b3..57131be4d211 100644
--- a/mail/jamlib/Makefile
+++ b/mail/jamlib/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A JAM subroutine library
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
NO_INSTALL_MANPAGES= yes
INSTALLS_SHLIB= yes
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index 0c8e08310ebd..39377f293285 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -19,7 +19,7 @@ COMMENT= A library for posting electronic mail
USE_BZIP2= yes
USE_GMAKE= yes
USE_OPENSSL= yes
-USE_INC_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15:inc
USE_PERL5_BUILD=yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index 16c985d541d2..a5de60552914 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A mail library
USE_ICONV= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/mail/libnewmail/Makefile b/mail/libnewmail/Makefile
index d1cc37bc9e57..23eefe5cd107 100644
--- a/mail/libnewmail/Makefile
+++ b/mail/libnewmail/Makefile
@@ -17,9 +17,8 @@ COMMENT= Generic mail checking library
LIB_DEPENDS= gnutls.12:${PORTSDIR}/security/gnutls \
oop.4:${PORTSDIR}/devel/liboop
-USE_LIBLTDL= yes
+USE_AUTOTOOLS= libltdl:15 libtool:15
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/libspf/Makefile b/mail/libspf/Makefile
index a628576683a8..ae3edb44802b 100644
--- a/mail/libspf/Makefile
+++ b/mail/libspf/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= mnag@FreeBSD.org
COMMENT= Sender Policy Framework (SPF) library and client
USE_BZIP2= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
OPTIONS= RFC_RECURSION "Change SPF recursion to 20 (as per RFC)" off \
diff --git a/mail/libspf2-10/Makefile b/mail/libspf2-10/Makefile
index c940ff47aca4..4bdd70a878eb 100644
--- a/mail/libspf2-10/Makefile
+++ b/mail/libspf2-10/Makefile
@@ -20,7 +20,7 @@ LATEST_LINK= libspf2-10
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/mail/libspf2/Makefile b/mail/libspf2/Makefile
index 821fbcd1ba4f..e363815bfb10 100644
--- a/mail/libspf2/Makefile
+++ b/mail/libspf2/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= ${PORTNAME}-1.0.*
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/mail/libsrs2/Makefile b/mail/libsrs2/Makefile
index bb65c3151185..7678c199de20 100644
--- a/mail/libsrs2/Makefile
+++ b/mail/libsrs2/Makefile
@@ -16,7 +16,7 @@ COMMENT= Sender Rewriting Scheme 2 C Implementation
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/mail/libvmime/Makefile b/mail/libvmime/Makefile
index 1a6020f41a48..aafd1cef3aaa 100644
--- a/mail/libvmime/Makefile
+++ b/mail/libvmime/Makefile
@@ -19,7 +19,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_GCC= 3.3+
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-debug
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
index 6f98c7e4080f..025ca7a4c959 100644
--- a/mail/mail-notification/Makefile
+++ b/mail/mail-notification/Makefile
@@ -18,7 +18,7 @@ COMMENT= A mail notification for freedesktop.org-compliant system trays
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack eel2
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index d6a142efeac4..9bb7d56374cf 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -146,8 +146,7 @@ CONFIGURE_ARGS+= ${MUTT_CONFIGURE_ARGS}
.endif
USE_REINPLACE= yes
-USE_AUTOMAKE_VER= 19
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= automake:19 autoconf:259
USE_OPENSSL= yes
PLIST= ${WRKDIR}/PLIST
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 0cc696500f68..4dc64607a688 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -78,8 +78,7 @@ DIST_SUBDIR= mutt
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_AUTOMAKE_VER= 19 # configure.in is patched by <PATCHFILES>
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= automake:19 autoconf:259
USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 0cc696500f68..4dc64607a688 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -78,8 +78,7 @@ DIST_SUBDIR= mutt
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_AUTOMAKE_VER= 19 # configure.in is patched by <PATCHFILES>
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= automake:19 autoconf:259
USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/mail/nmh/Makefile b/mail/nmh/Makefile
index 74283d1a0b49..f10856bac142 100644
--- a/mail/nmh/Makefile
+++ b/mail/nmh/Makefile
@@ -63,7 +63,7 @@ MAINTAINER= scott+ports@sabami.seaslug.org
COMMENT= A cleaned up MH mailer suite
USE_REINPLACE= yes
-USE_AUTOCONF_VER=213
+USE_AUTOTOOLS= autoconf:213
CONFIGURE_ARGS= --libdir=${PREFIX}/libexec/nmh \
--sysconfdir=${PREFIX}/etc/nmh
.ifdef NMH_EDITOR
diff --git a/mail/perdition/Makefile b/mail/perdition/Makefile
index af46a72e48f7..bead780e260b 100644
--- a/mail/perdition/Makefile
+++ b/mail/perdition/Makefile
@@ -24,7 +24,7 @@ MAN8= perdition.8
MANCOMPRESSED= no
USE_GETTEXT= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" BDB_LIB=db3
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= DOCSDIR=${DOCSDIR}
diff --git a/mail/pfqueue/Makefile b/mail/pfqueue/Makefile
index b56d383c211b..c10df276e1e1 100644
--- a/mail/pfqueue/Makefile
+++ b/mail/pfqueue/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= mnag@FreeBSD.org
COMMENT= A console-based tool for handling Postfix 1, Postfix 2 and Exim queues
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
diff --git a/mail/pop3lite/Makefile b/mail/pop3lite/Makefile
index 17e776a78567..941e60d4cc68 100644
--- a/mail/pop3lite/Makefile
+++ b/mail/pop3lite/Makefile
@@ -17,7 +17,7 @@ COMMENT= A flexible, modular RFC-compliant POP3 daemon
USE_GNOME= glib12
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
MAN5= pop3lite.conf.5
diff --git a/mail/pop3proxy/Makefile b/mail/pop3proxy/Makefile
index efa94d06e132..9abcaf2e1d7e 100644
--- a/mail/pop3proxy/Makefile
+++ b/mail/pop3proxy/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= mbr@FreeBSD.org
COMMENT= POP3 Proxy Server derived from UP IMAP Proxy
GNU_CONFIGURE= YES
-USE_AUTOCONF_VER=213
+USE_AUTOTOOLS= autoconf:213
USE_RC_SUBR= YES
SAMPLE_EXT= sample
diff --git a/mail/popular/Makefile b/mail/popular/Makefile
index 3686348b0df1..9057e8b94614 100644
--- a/mail/popular/Makefile
+++ b/mail/popular/Makefile
@@ -16,7 +16,7 @@ COMMENT= Suite of programs for setting up large POP3 server systems
BUILD_DEPENDS= ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_OPENSSL= yes
USE_PERL5= yes
PDM_MODULES= any master
diff --git a/mail/postfix-gps-devel/Makefile b/mail/postfix-gps-devel/Makefile
index 376c52a515de..e09eb9f7db8b 100644
--- a/mail/postfix-gps-devel/Makefile
+++ b/mail/postfix-gps-devel/Makefile
@@ -23,8 +23,7 @@ SCRIPT_FILES= gps-maintain.pl gps-db-update.pl
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_AUTOCONF_VER= 259
-USE_AUTOMAKE_VER= 19
+USE_AUTOTOOLS= automake:19 autoconf:259
USE_GCC= 3.4
CONFIGURE_ARGS= --bindir=${PREFIX}/libexec --includedir=${PREFIX}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
diff --git a/mail/postfix-gps/Makefile b/mail/postfix-gps/Makefile
index 6725ba1fc8fd..b0b85789b037 100644
--- a/mail/postfix-gps/Makefile
+++ b/mail/postfix-gps/Makefile
@@ -24,8 +24,7 @@ SCRIPT_FILES= gps-maintain.pl gps-db-update.pl
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_AUTOCONF_VER= 259
-USE_AUTOMAKE_VER= 19
+USE_AUTOTOOLS= automake:19 autoconf:259
USE_GCC= 3.4
CONFIGURE_ARGS= --bindir=${PREFIX}/libexec --includedir=${PREFIX}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${PREFIX}/include" \
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index b02ef2557b66..e3162ed18f07 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Berkeley POP 3 server (now maintained by Qualcomm)
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
USE_REINPLACE= yes
USE_OPENSSL= yes
CONFIGURE_ENV= LIBS="-lcrypt -lmd -lutil -L${LOCALBASE}/lib" \
diff --git a/mail/quickml/Makefile b/mail/quickml/Makefile
index 2c662767ac6d..80f37da4ba3a 100644
--- a/mail/quickml/Makefile
+++ b/mail/quickml/Makefile
@@ -22,7 +22,7 @@ PKGINSTALL= ${WRKDIR}/pkg-install
QUICKML_USER= quickml
QUICKML_GROUP= quickml
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
USE_RUBY= yes
diff --git a/mail/rabl_client/Makefile b/mail/rabl_client/Makefile
index e5939fa11e95..7fb3a7b886f6 100644
--- a/mail/rabl_client/Makefile
+++ b/mail/rabl_client/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.nuclearelephant.com/projects/rabl/sources/ \
MAINTAINER= itetcu@people.tecnik93.com
COMMENT= Reactive Autonomous Blackhole List client
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/mail/rabl_server/Makefile b/mail/rabl_server/Makefile
index 16bee5845bf6..58dfc58cd34f 100644
--- a/mail/rabl_server/Makefile
+++ b/mail/rabl_server/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.nuclearelephant.com/projects/rabl/sources/ \
MAINTAINER= itetcu@people.tecnik93.com
COMMENT= Reactive Autonomous Blackhole List server
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/mail/sccmilter/Makefile b/mail/sccmilter/Makefile
index b513f1e4559a..2448d6cd25ca 100644
--- a/mail/sccmilter/Makefile
+++ b/mail/sccmilter/Makefile
@@ -20,7 +20,7 @@ IGNORE= requires Sendmail 8.12; upgrade the base system
USE_BZIP2= yes
USE_GETOPT_LONG= yes
USE_RC_SUBR= yes
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --localstatedir=/var
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index a6f763b96672..836886fc54c5 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -71,7 +71,7 @@ USE_REINPLACE= YES
USE_GETTEXT= YES
USE_GMAKE= YES
USE_RC_SUBR= YES
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
--enable-imagedir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR} \
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 7c2a848fbfae..ee88ddffe998 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
NO_LATEST_LINK= yes
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index fb47236e2745..1645dce70470 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -25,7 +25,7 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index caa614a61cfa..33161b070196 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -22,7 +22,7 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
# Sylpheed needs pthread if GnomeVFS is installed (GtkFileChooser uses it)
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index caa614a61cfa..33161b070196 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -22,7 +22,7 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
# Sylpheed needs pthread if GnomeVFS is installed (GtkFileChooser uses it)
diff --git a/mail/xfmail/Makefile b/mail/xfmail/Makefile
index a261fc0608d8..4f872fa0dd80 100644
--- a/mail/xfmail/Makefile
+++ b/mail/xfmail/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms \
USE_BZIP2= yes
USE_GNOME= glib12
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
USE_X_PREFIX= yes
USE_XPM= yes
INSTALLS_SHLIB= yes