aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-07 13:20:32 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-07 13:20:32 +0000
commitca70e439c2cab3afa6b1f158853e01058c1fac47 (patch)
tree1d8dce4b39a3357f2e6741d55cb1b9a1fa54d346 /mail
parentbd0fca35b5f21e0a664069b2d0448565e1830160 (diff)
downloadports-ca70e439c2cab3afa6b1f158853e01058c1fac47.tar.gz
ports-ca70e439c2cab3afa6b1f158853e01058c1fac47.zip
- Convert to new perl framework
per port extra changes: devel/p5-Perl-Version remove outage PERL_LEVEL check devel/p5-Devel-LeakTrace-Fast remove perl version requiment 5.12.0- (no need in current version) Approved by: lth@ (maintainer)
Notes
Notes: svn path=/head/; revision=324352
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Email-Abstract/Makefile3
-rw-r--r--mail/p5-Email-Delete/Makefile3
-rw-r--r--mail/p5-Email-Folder-IMAP/Makefile3
-rw-r--r--mail/p5-Email-Folder-IMAPS/Makefile3
-rw-r--r--mail/p5-Email-Folder-POP3/Makefile3
-rw-r--r--mail/p5-Email-Folder/Makefile3
-rw-r--r--mail/p5-Email-FolderType-Net/Makefile3
-rw-r--r--mail/p5-Email-FolderType/Makefile3
-rw-r--r--mail/p5-Email-LocalDelivery-Ezmlm/Makefile3
-rw-r--r--mail/p5-Email-MIME-Attachment-Stripper/Makefile3
-rw-r--r--mail/p5-Email-MIME-ContentType/Makefile3
-rw-r--r--mail/p5-Email-MIME-Encodings/Makefile3
-rw-r--r--mail/p5-Email-MIME/Makefile3
-rw-r--r--mail/p5-Net-IMAP-Simple-SSL/Makefile3
-rw-r--r--mail/p5-URI-imap/Makefile3
-rw-r--r--mail/p5-URI-imaps/Makefile3
16 files changed, 32 insertions, 16 deletions
diff --git a/mail/p5-Email-Abstract/Makefile b/mail/p5-Email-Abstract/Makefile
index b4c66dbdf767..08a99a2af29e 100644
--- a/mail/p5-Email-Abstract/Makefile
+++ b/mail/p5-Email-Abstract/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-Email-Simple>=1.91:${PORTSDIR}/mail/p5-Email-Simple \
p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Abstract.3 \
Email::Abstract::EmailMIME.3 \
diff --git a/mail/p5-Email-Delete/Makefile b/mail/p5-Email-Delete/Makefile
index d048954623f8..b7b43106a5fe 100644
--- a/mail/p5-Email-Delete/Makefile
+++ b/mail/p5-Email-Delete/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-Email-Folder>=0.84:${PORTSDIR}/mail/p5-Email-Folder \
p5-File-Find-Rule>=0.28:${PORTSDIR}/devel/p5-File-Find-Rule
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Delete.3 \
Email::Delete::Maildir.3 \
diff --git a/mail/p5-Email-Folder-IMAP/Makefile b/mail/p5-Email-Folder-IMAP/Makefile
index ab7c89302201..cb7c808651d7 100644
--- a/mail/p5-Email-Folder-IMAP/Makefile
+++ b/mail/p5-Email-Folder-IMAP/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-Email-FolderType-Net>=0:${PORTSDIR}/mail/p5-Email-FolderType-Net
p5-URI-imap>=0:${PORTSDIR}/mail/p5-URI-imap
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Folder::IMAP.3
diff --git a/mail/p5-Email-Folder-IMAPS/Makefile b/mail/p5-Email-Folder-IMAPS/Makefile
index 95695189b435..a14f9d2e1a6c 100644
--- a/mail/p5-Email-Folder-IMAPS/Makefile
+++ b/mail/p5-Email-Folder-IMAPS/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-Email-FolderType-Net>=0:${PORTSDIR}/mail/p5-Email-FolderType-Net
p5-URI-imaps>=0:${PORTSDIR}/mail/p5-URI-imaps
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Folder::IMAPS.3
diff --git a/mail/p5-Email-Folder-POP3/Makefile b/mail/p5-Email-Folder-POP3/Makefile
index 5e89409c094f..043504db206d 100644
--- a/mail/p5-Email-Folder-POP3/Makefile
+++ b/mail/p5-Email-Folder-POP3/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
p5-Net>=1.19:${PORTSDIR}/net/p5-Net
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Folder::POP3.3
diff --git a/mail/p5-Email-Folder/Makefile b/mail/p5-Email-Folder/Makefile
index 3bc75d089609..9879daa47058 100644
--- a/mail/p5-Email-Folder/Makefile
+++ b/mail/p5-Email-Folder/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Email-Simple>0:${PORTSDIR}/mail/p5-Email-Simple \
p5-Email-FolderType>=0.6:${PORTSDIR}/mail/p5-Email-FolderType
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Folder.3 \
Email::Folder::MH.3 \
diff --git a/mail/p5-Email-FolderType-Net/Makefile b/mail/p5-Email-FolderType-Net/Makefile
index 21f32744a0e7..3d11bab2b711 100644
--- a/mail/p5-Email-FolderType-Net/Makefile
+++ b/mail/p5-Email-FolderType-Net/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
p5-Email-FolderType>=0.8:${PORTSDIR}/mail/p5-Email-FolderType
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::FolderType::Net.3
diff --git a/mail/p5-Email-FolderType/Makefile b/mail/p5-Email-FolderType/Makefile
index 98fb5fb9ef9e..23f9ebfd02ca 100644
--- a/mail/p5-Email-FolderType/Makefile
+++ b/mail/p5-Email-FolderType/Makefile
@@ -16,7 +16,8 @@ DISTNAME= ${PORTNAME}-0.813
MAINTAINER= lth@FreeBSD.org
COMMENT= Determine the type of a mail folder
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::FolderType.3 \
Email::FolderType::Ezmlm.3 \
diff --git a/mail/p5-Email-LocalDelivery-Ezmlm/Makefile b/mail/p5-Email-LocalDelivery-Ezmlm/Makefile
index 9425e92f9edf..eccaa0c86ccd 100644
--- a/mail/p5-Email-LocalDelivery-Ezmlm/Makefile
+++ b/mail/p5-Email-LocalDelivery-Ezmlm/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-Email-LocalDelivery>=0:${PORTSDIR}/mail/p5-Email-LocalDelivery
p5-Email-FolderType>=0:${PORTSDIR}/mail/p5-Email-FolderType
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::LocalDelivery::Ezmlm.3
diff --git a/mail/p5-Email-MIME-Attachment-Stripper/Makefile b/mail/p5-Email-MIME-Attachment-Stripper/Makefile
index 98b2948d547f..fb3179a5e297 100644
--- a/mail/p5-Email-MIME-Attachment-Stripper/Makefile
+++ b/mail/p5-Email-MIME-Attachment-Stripper/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Email-MIME>=1.861:${PORTSDIR}/mail/p5-Email-MIME \
p5-Email-MIME-ContentType>=1.0:${PORTSDIR}/mail/p5-Email-MIME-ContentType
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::MIME::Attachment::Stripper.3
diff --git a/mail/p5-Email-MIME-ContentType/Makefile b/mail/p5-Email-MIME-ContentType/Makefile
index 6f0df5d2aa9a..ed6849f60232 100644
--- a/mail/p5-Email-MIME-ContentType/Makefile
+++ b/mail/p5-Email-MIME-ContentType/Makefile
@@ -16,7 +16,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C|\.([0-9])$|\1|}
MAINTAINER= lth@FreeBSD.org
COMMENT= Parse a MIME Content-Type Header
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::MIME::ContentType.3
diff --git a/mail/p5-Email-MIME-Encodings/Makefile b/mail/p5-Email-MIME-Encodings/Makefile
index 8185ec4aff34..378700056950 100644
--- a/mail/p5-Email-MIME-Encodings/Makefile
+++ b/mail/p5-Email-MIME-Encodings/Makefile
@@ -12,7 +12,8 @@ COMMENT= A unified interface to MIME encoding and decoding
RUN_DEPENDS= p5-MIME-Base64>3.05:${PORTSDIR}/converters/p5-MIME-Base64
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::MIME::Encodings.3
diff --git a/mail/p5-Email-MIME/Makefile b/mail/p5-Email-MIME/Makefile
index 5841646dcdf8..55640cf43147 100644
--- a/mail/p5-Email-MIME/Makefile
+++ b/mail/p5-Email-MIME/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Email-Simple>=2.102:${PORTSDIR}/mail/p5-Email-Simple \
p5-MIME-Types>=1.13:${PORTSDIR}/mail/p5-MIME-Types
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::MIME.3 \
Email::MIME::Creator.3 \
diff --git a/mail/p5-Net-IMAP-Simple-SSL/Makefile b/mail/p5-Net-IMAP-Simple-SSL/Makefile
index de671f26568f..412df4de6b4d 100644
--- a/mail/p5-Net-IMAP-Simple-SSL/Makefile
+++ b/mail/p5-Net-IMAP-Simple-SSL/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-Net-IMAP-Simple>=0:${PORTSDIR}/mail/p5-Net-IMAP-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::IMAP::Simple::SSL.3
diff --git a/mail/p5-URI-imap/Makefile b/mail/p5-URI-imap/Makefile
index ec854be2cfe6..ebc1a89f9211 100644
--- a/mail/p5-URI-imap/Makefile
+++ b/mail/p5-URI-imap/Makefile
@@ -17,7 +17,8 @@ COMMENT= URI::imap - Support IMAP URI
BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::imap.3
diff --git a/mail/p5-URI-imaps/Makefile b/mail/p5-URI-imaps/Makefile
index efc40482fccd..da526a931ec8 100644
--- a/mail/p5-URI-imaps/Makefile
+++ b/mail/p5-URI-imaps/Makefile
@@ -18,7 +18,8 @@ COMMENT= Support IMAPS URI
BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::imaps.3