aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorGeorge C A Reid <greid@FreeBSD.org>2002-01-21 14:46:17 +0000
committerGeorge C A Reid <greid@FreeBSD.org>2002-01-21 14:46:17 +0000
commit3698da56e1c5d518a73eda3d71169a71fbbb5566 (patch)
tree361d6c090bbf9fc2f052fb10456f05a91ba3a97c /mail
parent8a7b64758504a0aa9646efd5e6ff0b1b34a3a7ad (diff)
downloadports-3698da56e1c5d518a73eda3d71169a71fbbb5566.tar.gz
ports-3698da56e1c5d518a73eda3d71169a71fbbb5566.zip
Add ecartis 1.0.0b, the Ecartis Listserver \ Mailing List Manager.
This replaces the mail/listar port, which is currently FORBIDDEN due to a remote exploit. PR: 34087 Submitted by: Trish Lynch <trish@bsdunix.net>
Notes
Notes: svn path=/head/; revision=53453
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/ecartis/Makefile43
-rw-r--r--mail/ecartis/distinfo1
-rw-r--r--mail/ecartis/files/patch-aa56
-rw-r--r--mail/ecartis/pkg-comment1
-rw-r--r--mail/ecartis/pkg-descr13
-rw-r--r--mail/ecartis/pkg-install63
-rw-r--r--mail/ecartis/pkg-plist69
8 files changed, 247 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index e6a5fabf8f43..5619e7d0727d 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -27,6 +27,7 @@
SUBDIR += distribute
SUBDIR += dkimap4
SUBDIR += drac
+ SUBDIR += ecartis
SUBDIR += elm
SUBDIR += elm+ME
SUBDIR += emh
diff --git a/mail/ecartis/Makefile b/mail/ecartis/Makefile
new file mode 100644
index 000000000000..bd8e21791103
--- /dev/null
+++ b/mail/ecartis/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: ecartis
+# Date created: 20 January 2002
+# Whom: Trish Lynch <trish@bsdunix.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ecartis
+PORTVERSION= 1.0.0b
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.ecartis.org/pub/ecartis/snapshots/tar/
+DISTNAME= ecartis-1.0.0-snap20020118
+
+MAINTAINER= trish@bsdunix.net
+
+USE_GMAKE= yes
+
+NO_PACKAGE= "Requires ecartis uid"
+WRKSRC= ${WRKDIR}/ecartis-1.0.0/src
+
+pre-patch:
+ @${CP} ${WRKSRC}/Makefile.dist ${WRKSRC}/Makefile
+
+pre-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${MKDIR} ${PREFIX}/${PORTNAME}
+ @${CP} -R ${WRKDIR}/${PORTNAME}-1.0.0/* ${PREFIX}/ecartis
+ @${RM} -R ${PREFIX}/${PORTNAME}/src/
+ @${RM} -R ${PREFIX}/${PORTNAME}/debian/
+ @${CHOWN} -R ecartis:ecartis ${PREFIX}/${PORTNAME}/*
+
+post-install:
+ @${ECHO_MSG} "---------------------------------------------------"
+ @${ECHO_MSG} "- Thank You for installing the Ecartis Listserver -"
+ @${ECHO_MSG} "- package. Please read the documentation located -"
+ @${ECHO_MSG} "- in ${PREFIX}/ecartis/, or online at: -"
+ @${ECHO_MSG} "- -"
+ @${ECHO_MSG} "- http://www.listar.org/ -"
+ @${ECHO_MSG} "- -"
+ @${ECHO_MSG} "- -The Listar/Ecartis Developers -"
+ @${ECHO_MSG} "---------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/mail/ecartis/distinfo b/mail/ecartis/distinfo
new file mode 100644
index 000000000000..3ed06aa1bf7f
--- /dev/null
+++ b/mail/ecartis/distinfo
@@ -0,0 +1 @@
+MD5 (ecartis-1.0.0-snap20020118.tar.gz) = 9f3c60e2786212f73feb2f9366f491f3
diff --git a/mail/ecartis/files/patch-aa b/mail/ecartis/files/patch-aa
new file mode 100644
index 000000000000..0253d5103d08
--- /dev/null
+++ b/mail/ecartis/files/patch-aa
@@ -0,0 +1,56 @@
+--- Makefile.orig Sun Jun 17 22:13:03 2001
++++ Makefile Sun Jun 17 22:14:19 2001
+@@ -6,8 +6,8 @@
+ # they should be set. All of them are conditional on options set in this
+ # file, so it should be relatively easy to determine which branch is correct
+
+-BINDIR = ..
+-MODDIR = ../modules
++BINDIR = ${PREFIX}/ecartis
++MODDIR = ${PREFIX}/ecartis/modules
+
+ # First things first we need to set up some various options since OS's aren't
+ # as nice about things are they could be.
+@@ -38,7 +38,7 @@
+ # Uncomment this if you are on a BSD system AND you want dynamic modules
+ # SunOS (4 and 5 both) also needs this setting.
+ #
+-#BSDMOD = 1
++BSDMOD = 1
+
+ # Uncomment this if you are compiling on OpenBSD with modules (BSDMOD = 1)
+ #OBSDMOD = 1
+@@ -60,7 +60,7 @@
+ # Uncomment this if you have the GNU strftime() function. This version
+ # of the function understands %z to return the numerical offset. It's better
+ # to use that if it's available for RFC822 date headers
+-GNU_STRFTIME=-DGNU_STRFTIME
++#GNU_STRFTIME=-DGNU_STRFTIME
+
+ # Uncomment this if you are on a machine that doesn't have strerror()
+ #
+@@ -125,7 +125,6 @@
+ ifdef BSDIMOD
+ CC=shlicc
+ else
+-CC=gcc
+ endif
+
+ # Warning-level flags. Under SunOS (4 and 5), this NEEDS TO BE BLANK.
+@@ -134,7 +133,7 @@
+ #
+ # It appears that IRIX is also rather stupid, and may require this
+ # to be removed.
+-WFLAGS=-Wall -Werror
++WFLAGS:=${CFLAGS}
+
+ # Now set up the initial command line. SUNOS_5 makes this a bit wierd.
+ ifndef SUNOS_5
+@@ -321,6 +320,7 @@
+ install: targets
+ cp build/ecartis ${BINDIR}
+ chmod ug+s ${BINDIR}/ecartis
++ chown -R ecartis:ecartis ${BINDIR}
+ ifdef DYNMOD
+ @for dir in ${MODULES}; do \
+ cp build/$${dir}.lpm ${MODDIR}/$${dir}.lpm; \
diff --git a/mail/ecartis/pkg-comment b/mail/ecartis/pkg-comment
new file mode 100644
index 000000000000..53a1be9e5475
--- /dev/null
+++ b/mail/ecartis/pkg-comment
@@ -0,0 +1 @@
+The Ecartis Listserver \ Mailing List Manager
diff --git a/mail/ecartis/pkg-descr b/mail/ecartis/pkg-descr
new file mode 100644
index 000000000000..4bee231c93ad
--- /dev/null
+++ b/mail/ecartis/pkg-descr
@@ -0,0 +1,13 @@
+Listar is a open-source (GNU Licence) software package that adminsters
+mailing lists (similar to Majordomo and Listserv). Some of Listar's
+features include:
+
+ - A modular design structure, so that you can compile what you
+ need (and don't)
+ - The ability to strip down MIME messages and remove their
+ attachments.
+ - Ability to be run in a multi-Virtual Host configuration.
+
+Take a look at Listar's website to get a full feature list:
+
+WWW: http://www.listar.org/
diff --git a/mail/ecartis/pkg-install b/mail/ecartis/pkg-install
new file mode 100644
index 000000000000..760c03db6fab
--- /dev/null
+++ b/mail/ecartis/pkg-install
@@ -0,0 +1,63 @@
+#!/bin/sh
+
+user=ecartis
+group=ecartis
+
+ask() {
+ local question default answer
+
+ question=$1
+ default=$2
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ read -p "${question} [${default}]? " answer
+ fi
+ if [ x${answer} = x ]; then
+ answer=${default}
+ fi
+ echo ${answer}
+}
+
+yesno() {
+ local dflt question answer
+
+ question=$1
+ dflt=$2
+ while :; do
+ answer=$(ask "${question}" "${dflt}")
+ case "${answer}" in
+ [Yy]*) return 0;;
+ [Nn]*) return 1;;
+ esac
+ echo "Please answer yes or no."
+ done
+}
+
+if [ x"$2" = xPRE-INSTALL ]; then
+ if pw groupshow "${group}" 2>/dev/null; then
+ echo "You already have a group \"${group}\", so I will use it."
+ else
+ echo "You need a group \"${group}\"."
+ if yesno "Would you like me to create it" y; then
+ pw groupadd ${group} -h - || exit
+ echo "Done."
+ else
+ echo "Please create it, and try again."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${user}" 2>/dev/null; then
+ echo "You already have a user \"${user}\", so I will use it."
+ else
+ echo "You need a user \"${user}\"."
+ if yesno "Would you like me to create it" y; then
+ pw useradd ${user} -g ${group} -h - -d /nonexistent \
+ -s /nonexistent -c "Listar Listserver" || exit
+ echo "Done."
+ else
+ echo "Please create it, and try again."
+ exit 1
+ fi
+ fi
+
+fi
diff --git a/mail/ecartis/pkg-plist b/mail/ecartis/pkg-plist
new file mode 100644
index 000000000000..4b1163a8ce54
--- /dev/null
+++ b/mail/ecartis/pkg-plist
@@ -0,0 +1,69 @@
+ecartis/ecartis
+ecartis/banned
+ecartis/queue/README
+ecartis/modules/README
+ecartis/modules/bouncer.lpm
+ecartis/modules/listarchive.lpm
+ecartis/modules/filearchive.lpm
+ecartis/modules/admin.lpm
+ecartis/modules/acctmgr.lpm
+ecartis/modules/stat.lpm
+ecartis/modules/send.lpm
+ecartis/modules/base.lpm
+ecartis/modules/digest.lpm
+ecartis/modules/antispam.lpm
+ecartis/modules/administrivia.lpm
+ecartis/modules/toolbox.lpm
+ecartis/modules/pantomime.lpm
+ecartis/modules/lsg2.lpm
+ecartis/modules/password.lpm
+ecartis/modules/peruser.lpm
+ecartis/scripts/lsg2.cgi.dist
+ecartis/lists/test/text/blacklist.txt
+ecartis/lists/test/text/closed-post.txt
+ecartis/lists/test/text/footer.txt
+ecartis/lists/test/text/intro.txt
+ecartis/lists/test/config
+ecartis/lists/test/cookies
+ecartis/lists/test/users
+ecartis/templates/userlist.lsc
+ecartis/templates/admin-usersetinfo.lsc
+ecartis/templates/adminmenu.lsc
+ecartis/templates/config.lsc
+ecartis/templates/error.lsc
+ecartis/templates/fileedit.lsc
+ecartis/templates/flagedit.lsc
+ecartis/templates/footer.lsc
+ecartis/templates/frontpage.lsc
+ecartis/templates/generic.lsc
+ecartis/templates/header.lsc
+ecartis/templates/listmenu.lsc
+ecartis/templates/logincookie.lsc
+ecartis/templates/mainmenu.lsc
+ecartis/templates/subscribe.lsc
+ecartis/templates/textfile.lsc
+ecartis/templates/unsubscribe.lsc
+ecartis/templates/userinfo.lsc
+ecartis/templates/userlist-deny.lsc
+ecartis/templates/admin-userinfo.lsc
+ecartis/README.LISTS
+ecartis/README.DIGEST
+ecartis/README.ANTISPAM
+ecartis/README
+ecartis/NOTE
+ecartis/LICENSE
+ecartis/ECARTIS.TODO
+ecartis/COPYRIGHT
+ecartis/spam-regexp.sample
+ecartis/ecartis.spec
+ecartis/ecartis.hlp
+ecartis/ecartis.cfg.dist
+ecartis/ecartis.aliases.dist
+@dirrm ecartis/lists/test/text
+@dirrm ecartis/lists/test
+@dirrm ecartis/lists
+@dirrm ecartis/templates
+@dirrm ecartis/scripts
+@dirrm ecartis/queue
+@dirrm ecartis/modules
+@dirrm ecartis