aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-05-24 01:46:01 +0000
committerPatrick Li <pat@FreeBSD.org>2002-05-24 01:46:01 +0000
commit4fa49367de37f023624d1813a963cb9e1d5c06f1 (patch)
tree4d48995679b6e50706aec025b709a63e8d34fb7c /mail
parent5d481d76fce0eed52065a08124dcf83abd486a71 (diff)
downloadports-4fa49367de37f023624d1813a963cb9e1d5c06f1.tar.gz
ports-4fa49367de37f023624d1813a963cb9e1d5c06f1.zip
Fix display of pkg-message when installing as package
Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59840
Diffstat (limited to 'mail')
-rw-r--r--mail/nocc/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/mail/nocc/Makefile b/mail/nocc/Makefile
index 0a7426ce1e16..afe6e374334e 100644
--- a/mail/nocc/Makefile
+++ b/mail/nocc/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= sysadmin@alexdupre.com
RUN_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
+PKGMESSAGE= ${WRKDIR}/pkg-message
NO_BUILD= yes
pre-everything:
@@ -26,6 +27,10 @@ pre-everything:
@${ECHO} "press CTRL+C now and rebuild it before installing Nocc."
@${ECHO} ""
+pre-patch:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' \
+ ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+
do-install:
${MKDIR} ${PREFIX}/www/nocc
${CP} -Rp ${WRKSRC}/html ${WRKSRC}/lang ${WRKSRC}/themes \
@@ -43,6 +48,6 @@ do-install:
.endif
post-install:
- @${SED} 's|%%PREFIX%%|${PREFIX}|' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>