aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
commit17e550ca2fd180b150f6645ced5f3bb45bc32292 (patch)
treee856fa025c5b15bbef21f621e347c51780662a47 /mail
parentb4599e3d63c3a94b17026b18d1f8ac27faac53fc (diff)
downloadports-17e550ca2fd180b150f6645ced5f3bb45bc32292.tar.gz
ports-17e550ca2fd180b150f6645ced5f3bb45bc32292.zip
Explicitly depend on p5-Digest-MD5 only if PERL_LEVEL < 500703
Explicitly depend on p5-Digest-SHA only if PERL_LEVEL < 501000
Notes
Notes: svn path=/head/; revision=261560
Diffstat (limited to 'mail')
-rw-r--r--mail/majordomo/Makefile14
-rw-r--r--mail/mlmmj/Makefile13
-rw-r--r--mail/p5-FuzzyOcr/Makefile11
-rw-r--r--mail/p5-Mail-DKIM/Makefile10
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile2
5 files changed, 38 insertions, 12 deletions
diff --git a/mail/majordomo/Makefile b/mail/majordomo/Makefile
index b16906c5ec20..4dc9b0393b1e 100644
--- a/mail/majordomo/Makefile
+++ b/mail/majordomo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= majordomo
PORTVERSION= 1.94.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= ftp://ftp.nuug.no/pub/anders/distfiles/ \
ftp://ftp.sgi.com/other/majordomo/1.94.5/ \
@@ -19,8 +19,6 @@ COMMENT= A mailing list manager
.if defined(WITH_SHA1_COOKIES)
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
-.else
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
.endif
USE_PERL5= yes
@@ -33,6 +31,14 @@ PKGMESSAGE= ${FILESDIR}/post-install-notes
DOCSDIR= ${PREFIX}/${PORTNAME}/doc
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_SHA1_COOKIES)
+. if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+. endif
+.endif
+
pre-fetch:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
${DIALOG} --yesno "WARNING: Majordomo is a really old mail list manager. The last version was released in january 2000, and there does not seem to be any updates coming. You might want to consider using mailman instead. Are you sure you want to install majordomo?" 8 70 no || ${FALSE}
@@ -103,4 +109,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/mlmmj/Makefile b/mail/mlmmj/Makefile
index 20be7abf8510..fd19cee054cb 100644
--- a/mail/mlmmj/Makefile
+++ b/mail/mlmmj/Makefile
@@ -25,8 +25,7 @@ WANT_PHP_WEB= yes
.if defined(WITH_PERL_WEBINTERFACE)
RUN_DEPENDS+= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/CGI/FastTemplate.pm:${PORTSDIR}/www/p5-CGI-FastTemplate \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+ ${SITE_PERL}/CGI/FastTemplate.pm:${PORTSDIR}/www/p5-CGI-FastTemplate
.endif
.if defined(WITH_PERL_WEBINTERFACE)
@@ -55,6 +54,14 @@ MAKE_JOBS_SAFE= yes
MAN1= mlmmj-bounce.1 mlmmj-list.1 mlmmj-maintd.1 mlmmj-make-ml.sh.1 mlmmj-process.1 mlmmj-recieve.1 mlmmj-send.1 mlmmj-sub.1 mlmmj-unsub.1
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PERL_WEBINTERFACE)
+. if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+. endif
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/src/mlmmj-make-ml.sh
@@ -86,4 +93,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/contrib/web/php-admin/conf/* ${PREFIX}/www/mlmmj/php-admin/conf
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/p5-FuzzyOcr/Makefile b/mail/p5-FuzzyOcr/Makefile
index eb5b7ddb5e72..baec84b4d48a 100644
--- a/mail/p5-FuzzyOcr/Makefile
+++ b/mail/p5-FuzzyOcr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= FuzzyOcr
DISTVERSION= 2.3b
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 1
CATEGORIES= mail perl5
MASTER_SITES= http://users.own-hero.net/~decoder/${PORTNAME:L}/
@@ -22,7 +22,6 @@ RUN_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm \
gocr:${PORTSDIR}/graphics/gocr \
gif2ps:${PORTSDIR}/graphics/libungif \
spamassassin:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/String/Approx.pm:${PORTSDIR}/devel/p5-String-Approx
CONFLICTS= p5-FuzzyOcr-devel-[0-9]*
@@ -51,6 +50,12 @@ PLIST_FILES= ${SA_CONFIGDIR}/FuzzyOcr.pm \
%%EXAMPLESDIR%%/FuzzyOcr.cf %%EXAMPLESDIR%%/FuzzyOcr.words
PLIST_DIRS= %%EXAMPLESDIR%%
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/bin,${LOCALBASE}/bin,g' \
-e 's,/bin/grep,/usr/bin/grep,g' \
@@ -77,4 +82,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-DKIM/Makefile b/mail/p5-Mail-DKIM/Makefile
index f77cc05e8e40..d31301e3bd04 100644
--- a/mail/p5-Mail-DKIM/Makefile
+++ b/mail/p5-Mail-DKIM/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= yanagisawa@csg.is.titech.ac.jp
COMMENT= Perl5 module to process and/or create DKIM email
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools
BUILD_DEPENDS= ${RUN_DEPENDS}
@@ -44,4 +43,11 @@ MAN3= Mail::DKIM.3 \
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/dkim*.pl ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+BUILD_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index 67b73244e077..42c49c183932 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -116,7 +116,9 @@ BUILD_DEPENDS+= p5-Digest-SHA1>=2.11:${PORTSDIR}/security/p5-Digest-SHA1
.if defined(WITH_DKIM)
BUILD_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+. if ${PERL_LEVEL} < 501000
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA
+. endif
BUILD_DEPENDS+= p5-Mail-DKIM>=0.37:${PORTSDIR}/mail/p5-Mail-DKIM
BUILD_DEPENDS+= p5-Crypt-OpenSSL-RSA>=0.24:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA
.endif