aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-14 13:13:51 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-14 13:13:51 +0000
commit36b89598f38b4484b7531189230aedbe94af7889 (patch)
treedd82dd8d7986737d63678dc8896d8205c6b24a9b /mail
parent6bf2f24676a570eb56d3535698fbc77b16f93492 (diff)
downloadports-36b89598f38b4484b7531189230aedbe94af7889.tar.gz
ports-36b89598f38b4484b7531189230aedbe94af7889.zip
Update to 0.94.14
PR: ports/82208 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=137437
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter-qdbm/Makefile2
-rw-r--r--mail/bogofilter/Makefile4
-rw-r--r--mail/bogofilter/distinfo4
-rw-r--r--mail/bogofilter/files/patch-src_datastore__db__trans.c14
-rw-r--r--mail/bogofilter/files/patch-src_datastore__tdb.c42
5 files changed, 61 insertions, 5 deletions
diff --git a/mail/bogofilter-qdbm/Makefile b/mail/bogofilter-qdbm/Makefile
index 921344c97dd4..6aa11b327e98 100644
--- a/mail/bogofilter-qdbm/Makefile
+++ b/mail/bogofilter-qdbm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bogofilter
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= mail
PKGNAMESUFFIX= -qdbm
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index bfc03225c9aa..32d8cfed2b74 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= bogofilter
-PORTVERSION= 0.94.13
-PORTREVISION?= 1
+PORTVERSION= 0.94.14
+PORTREVISION?= 0
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/mail/bogofilter/distinfo b/mail/bogofilter/distinfo
index 4b1e7cd83464..6aea04747ac7 100644
--- a/mail/bogofilter/distinfo
+++ b/mail/bogofilter/distinfo
@@ -1,2 +1,2 @@
-MD5 (bogofilter-0.94.13.tar.bz2) = 1b3c6f192a361f0825a3decaa7f65e6b
-SIZE (bogofilter-0.94.13.tar.bz2) = 724255
+MD5 (bogofilter-0.94.14.tar.bz2) = 59fa3eefc510458f786c893de271b819
+SIZE (bogofilter-0.94.14.tar.bz2) = 723279
diff --git a/mail/bogofilter/files/patch-src_datastore__db__trans.c b/mail/bogofilter/files/patch-src_datastore__db__trans.c
new file mode 100644
index 000000000000..d57206a38c3c
--- /dev/null
+++ b/mail/bogofilter/files/patch-src_datastore__db__trans.c
@@ -0,0 +1,14 @@
+--- a/src/datastore_db_trans.c 8 Jun 2005 12:18:59 -0000 1.31.4.1
++++ b/src/datastore_db_trans.c 9 Jun 2005 07:54:35 -0000 1.31.4.2
+@@ -943,8 +943,10 @@
+ #else
+ r = ENOENT;
+ #endif
+- if (r == DB_RUNRECOVERY)
++ if (r == DB_RUNRECOVERY) {
++ dbe->close(dbe, 0);
+ return T_ENABLED;
++ }
+
+ if (r == ENOENT) {
+ struct stat st;
diff --git a/mail/bogofilter/files/patch-src_datastore__tdb.c b/mail/bogofilter/files/patch-src_datastore__tdb.c
new file mode 100644
index 000000000000..549b1de7b689
--- /dev/null
+++ b/mail/bogofilter/files/patch-src_datastore__tdb.c
@@ -0,0 +1,42 @@
+--- a/src/datastore_tdb.c 31 May 2005 15:04:05 -0000 1.51.22.1
++++ b/src/datastore_tdb.c 10 Jun 2005 08:19:30 -0000 1.51.22.2
+@@ -268,20 +268,34 @@
+ dbv_t dbv_key, dbv_data;
+ userdata_t *hookdata = userdata;
+
+- /* Question: Is there a way to avoid using malloc/free? */
+-
+- /* switch to "dbv_t *" variables */
++ /* TDB happily returns data from odd addresses, so we need to
++ * memcpy() everything to properly aligned storage (malloc() is
++ * fine) if our callee wishes to perform word-sized access - without
++ * memcpy(), the callee will die with SIGBUS (SPARC, m68k) or get
++ * extremely slow (i386). */
++
++ /* XXX FIXME: Possible optimization if this function is only used by
++ * one caller at a time (i. e. no threads): allocate buffers
++ * statically and reuse them as long as they are of sufficient size
++ * and reallocate otherwise. */
++
++ /* copy key */
++ /* XXX FIXME: do we really need to use C-string compatible keys?
++ * Looks wasteful. */
+ dbv_key.leng = key.dsize;
+ dbv_key.data = xmalloc(dbv_key.leng+1);
+ memcpy(dbv_key.data, key.dptr, dbv_key.leng);
+ ((char *)dbv_key.data)[dbv_key.leng] = '\0';
+
+- dbv_data.data = data.dptr;
+- dbv_data.leng = data.dsize; /* read count */
++ /* copy data */
++ dbv_data.leng = data.dsize;
++ dbv_data.data = xmalloc(dbv_data.leng);
++ memcpy(dbv_data.data, data.dptr, dbv_data.leng);
+
+ /* call user function */
+ rc = hookdata->hook(&dbv_key, &dbv_data, hookdata->userdata);
+
++ xfree(dbv_data.data);
+ xfree(dbv_key.data);
+
+ return rc;