aboutsummaryrefslogtreecommitdiff
path: root/math/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-18 11:12:40 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-18 11:12:40 +0000
commit6afaa267f3ef73e3d07e034bac5761248cb3ecc1 (patch)
tree8a713ab4c475c2ac5bc846e2fc6fff1dfa7134a3 /math/Makefile
parent8b022e8e233f466e0a5cd96008ad6def99c8c5ca (diff)
downloadports-6afaa267f3ef73e3d07e034bac5761248cb3ecc1.tar.gz
ports-6afaa267f3ef73e3d07e034bac5761248cb3ecc1.zip
math/py-fastcluster: Python functions for hierarchical clustering
Fastcluster provides Python functions for hierarchical clustering. It generates hierarchical clusters from distance matrices or from vector data. Part of this module is intended to replace the functions linkage, single, complete, average, weighted, centroid, median, ward in the module scipy.cluster.hierarchy with the same functionality but much faster algorithms. Moreover, the function 'linkage_vector' provides memory-efficient clustering for vector data. The interface is very similar to MATLAB's Statistics Toolbox API to make code easier to port from MATLAB to Python/Numpy. The core implementation of this library is in C++ for efficiency. WWW: http://danifold.net/fastcluster.html PR: ports/184931 Submitted by: Johannes Jost Meixner <xmj chaot.net>
Notes
Notes: svn path=/head/; revision=336815
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 924f32508080..3caabb25a5dd 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -542,6 +542,7 @@
SUBDIR += py-basemap-data
SUBDIR += py-bitvector
SUBDIR += py-bottleneck
+ SUBDIR += py-fastcluster
SUBDIR += py-ffc
SUBDIR += py-fiat
SUBDIR += py-fpconst