aboutsummaryrefslogtreecommitdiff
path: root/math/asir2000/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-09 01:34:32 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-09 01:34:32 +0000
commit8aae4286760db19ee636b7f8846501b98e02cce2 (patch)
tree01317b6252b4941c0197385566e5f551921496e2 /math/asir2000/Makefile
parent355186cc55aae9f57b02c45b4bfb9ac8c84fa7be (diff)
downloadports-8aae4286760db19ee636b7f8846501b98e02cce2.tar.gz
ports-8aae4286760db19ee636b7f8846501b98e02cce2.zip
Update to 20020108
PR: 33677 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=52782
Diffstat (limited to 'math/asir2000/Makefile')
-rw-r--r--math/asir2000/Makefile40
1 files changed, 35 insertions, 5 deletions
diff --git a/math/asir2000/Makefile b/math/asir2000/Makefile
index 06f616db2d1b..b199971d9e97 100644
--- a/math/asir2000/Makefile
+++ b/math/asir2000/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asir
-PORTVERSION= 20010830
+PORTVERSION= 20020108
CATEGORIES= math
MASTER_SITES= ftp://ftp.asir.org/pub/asir/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ASIR_DOC}
@@ -14,20 +14,50 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= saito@asir.org
-LIB_DEPENDS= pari.1:${PORTSDIR}/math/pari \
- lapack.3:${PORTSDIR}/math/lapack
+.if defined(USE_LAPACK)
+LIB_DEPENDS= lapack.3:${PORTSDIR}/math/lapack
+.endif
+.if defined(USE_OLDPARI)
+LIB_DEPENDS+= pari.1:${PORTSDIR}/math/pari
+.else
+LIB_DEPENDS+= pari-2.2.0:${PORTSDIR}/math/pari-devel
+.endif
+.if defined(USE_LAPACK)
+LAPACK= -lapack
+.else
+LAPACK=
+.endif
+.if defined(USE_OLDPARI)
+PARI= -oldpari
+.else
+PARI= -pari
+.endif
WRKSRC= ${WRKDIR}/asir2000
PREFIX?= ${LOCALBASE}
USE_IMAKE= YES
HAS_CONFIGURE= YES
-CONFIGURE_ARGS= -oxhome ${PREFIX} -plot -pari -fep -interval -lapack
-
+CONFIGURE_ARGS= -oxhome ${PREFIX} -plot ${PARI} -fep -interval ${LAPACK}
ASIR_DOC= asirdoc-${PORTVERSION}.tar.gz
+
LIB_DATA= alpi bfct bgk const cyclic defs.h dfff dmul fctrdata fctrtest \
fff gr ifplot katsura launch mat nf num primdec \
ratint robot solve sp sturm xm
+pre-everything::
+ @${ECHO_MSG} ""
+.if !defined(USE_OLDPARI)
+ @${ECHO_MSG} "If you build with the older pari 2.1.1 library,"
+ @${ECHO_MSG} " make USE_OLDPARI=yes"
+ @${ECHO_MSG} "otherwise it will link the newer pari 2.2.0 library."
+.endif
+ @${ECHO_MSG} ""
+.if !defined(USE_LAPACK)
+ @${ECHO_MSG} "To build with the \"LAPACK\" library,"
+ @${ECHO_MSG} " make USE_LAPACK=yes"
+.endif
+ @${ECHO_MSG} ""
+
pre-install:
@${MKDIR} ${DATADIR}
@${MKDIR} ${DOCSDIR}