aboutsummaryrefslogtreecommitdiff
path: root/math/blocksolve95
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-07-23 08:37:53 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-07-23 08:37:53 +0000
commit221f0f729559dfa0c3a7f0422f90f9130d240230 (patch)
tree9e1676718031199adbece0f7a9f734036f1b65af /math/blocksolve95
parentf088c380604ae478ac84f474d26938142e594596 (diff)
downloadports-221f0f729559dfa0c3a7f0422f90f9130d240230.tar.gz
ports-221f0f729559dfa0c3a7f0422f90f9130d240230.zip
Switch to MPICH2.
Notes
Notes: svn path=/head/; revision=168538
Diffstat (limited to 'math/blocksolve95')
-rw-r--r--math/blocksolve95/Makefile15
-rw-r--r--math/blocksolve95/files/patch-bmake::freebsd::freebsd.site6
-rw-r--r--math/blocksolve95/files/patch-examples::makefile31
3 files changed, 42 insertions, 10 deletions
diff --git a/math/blocksolve95/Makefile b/math/blocksolve95/Makefile
index 20f18b6ffb5b..4ea45f29e6d3 100644
--- a/math/blocksolve95/Makefile
+++ b/math/blocksolve95/Makefile
@@ -7,6 +7,7 @@
PORTNAME= blocksolve95
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= math parallel
MASTER_SITES= ftp://info.mcs.anl.gov/pub/BlockSolve95/ \
ftp://ftp.irisa.fr/pub/mirrors/BlockSolve95/
@@ -17,8 +18,9 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Sofware for the efficient solution of large, sparse linear systems
-BUILD_DEPENDS= ${MPIDIR}/lib/libmpich.a:${PORTSDIR}/net/mpich
-RUN_DEPENDS= ${MPIDIR}/bin/mpirun:${PORTSDIR}/net/mpich
+BUILD_DEPENDS= ${MPIDIR}/lib/libmpich.a:${PORTSDIR}/net/mpich2
+LIB_DEPENDS= f2c.2:${PORTSDIR}/lang/f2c
+RUN_DEPENDS= ${MPIDIR}/bin/mpirun:${PORTSDIR}/net/mpich2
USE_XLIB= yes
USE_GMAKE= yes
@@ -26,7 +28,7 @@ MAKEFILE= makefile
MAKE_ARGS= GMAKE=${GMAKE} PETSC_ARCH=${PETSC_ARCH} BOPT=${BOPT} \
BLAS_LIB=${BLAS_LIB} LAPACK_LIB=${LAPACK_LIB}
-MPIDIR= ${LOCALBASE}/mpich
+MPIDIR= ${LOCALBASE}/mpich2
PETSC_ARCH= freebsd
BOPT?= O
@@ -65,8 +67,15 @@ do-install:
.if defined(MAINTAINER_MODE)
regression-test: build
+. if !exists(${HOME}/.mpd.conf)
+ @${ECHO_CMD} "MPD_SECRETWORD=change_on_install" > ${HOME}/.mpd.conf
+ ${CHMOD} go-r ${HOME}/.mpd.conf
+ @${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
+. endif
+ ${LOCALBASE}/mpich2/bin/mpd &
@(cd ${BUILD_WRKSRC}/examples; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} bsrunexamples clean)
+ ${LOCALBASE}/mpich2/bin/mpdallexit
.endif
.include "${FILESDIR}/BSman3.inc"
diff --git a/math/blocksolve95/files/patch-bmake::freebsd::freebsd.site b/math/blocksolve95/files/patch-bmake::freebsd::freebsd.site
index d903cf2aa95e..e93294ca5546 100644
--- a/math/blocksolve95/files/patch-bmake::freebsd::freebsd.site
+++ b/math/blocksolve95/files/patch-bmake::freebsd::freebsd.site
@@ -20,9 +20,9 @@
-MPI_LIB = /usr/local/mpi/lib/freebsd/ch_p4/libmpi.a
-MPI_INCLUDE = -I/usr/local/mpi/include
-MPIRUN = /usr/local/mpi/bin/mpirun
-+MPI_LIB = $(LOCALBASE)/mpich/lib/libmpich.a
-+MPI_INCLUDE = -I$(LOCALBASE)/mpich/include
-+MPIRUN = $(LOCALBASE)/mpich/bin/mpirun
++MPI_LIB = $(LOCALBASE)/mpich2/lib/libmpich.a
++MPI_INCLUDE = -I$(LOCALBASE)/mpich2/include
++MPIRUN = $(LOCALBASE)/mpich2/bin/mpirun
#
# Location of BlockSolve95
#
diff --git a/math/blocksolve95/files/patch-examples::makefile b/math/blocksolve95/files/patch-examples::makefile
index d79080a58e17..fab4c12b501b 100644
--- a/math/blocksolve95/files/patch-examples::makefile
+++ b/math/blocksolve95/files/patch-examples::makefile
@@ -1,11 +1,34 @@
--- examples/makefile.orig Thu Oct 17 22:15:08 1996
-+++ examples/makefile Sun Oct 3 21:38:26 2004
-@@ -19,7 +19,7 @@
++++ examples/makefile Sat Jul 22 16:50:24 2006
+@@ -19,19 +19,19 @@
$(MPI_LIB) $(FC_LIB) $(SYS_LIB) -lm
LINCLUDE = $(SOURCEH)
-bsrunexamples:
+bsrunexamples: $(EXAMPLES_1)
-@echo ">>>>>> Running examples in example directory <<<<<<"
- -@$(MPIRUN) -np 4 grid0.$(PETSC_ARCH) 2 2 1 10 10 10
- -@$(MPIRUN) -np 4 grid1.$(PETSC_ARCH) 2 2 1 10 10 10
+- -@$(MPIRUN) -np 4 grid0.$(PETSC_ARCH) 2 2 1 10 10 10
+- -@$(MPIRUN) -np 4 grid1.$(PETSC_ARCH) 2 2 1 10 10 10
+- -@$(MPIRUN) -np 4 grid2.$(PETSC_ARCH) 2 2 10 10 10
+- -@$(MPIRUN) -np 4 grid3.$(PETSC_ARCH) 10 9
+- -@$(MPIRUN) -np 4 grid4.$(PETSC_ARCH) 2 2 1 10 10 10
+- -@$(MPIRUN) -np 1 grid5.$(PETSC_ARCH) 1 1 1 10 10 10 1 3 1 1 1 1 2
+- -@$(MPIRUN) -np 1 grid5.$(PETSC_ARCH) 1 1 1 10 10 10 0 3 1 0 0 1 2
+- -@$(MPIRUN) -np 1 grid6.$(PETSC_ARCH) 1 1 1 10 10 10 1 1 3
+- -@$(MPIRUN) -np 1 grid6.$(PETSC_ARCH) 1 1 1 10 10 10 0 1 3
+- -@$(MPIRUN) -np 4 grid7.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 1 0.01
+- -@$(MPIRUN) -np 4 grid8.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 0.01
++ -@$(MPIRUN) -np 4 ./grid0.$(PETSC_ARCH) 2 2 1 10 10 10
++ #@$(MPIRUN) -np 4 ./grid1.$(PETSC_ARCH) 2 2 1 10 10 10
++ #@$(MPIRUN) -np 4 ./grid2.$(PETSC_ARCH) 2 2 10 10 10
++ -@$(MPIRUN) -np 4 ./grid3.$(PETSC_ARCH) 10 9
++ -@$(MPIRUN) -np 4 ./grid4.$(PETSC_ARCH) 2 2 1 10 10 10
++ -@$(MPIRUN) -np 1 ./grid5.$(PETSC_ARCH) 1 1 1 10 10 10 1 3 1 1 1 1 2
++ -@$(MPIRUN) -np 1 ./grid5.$(PETSC_ARCH) 1 1 1 10 10 10 0 3 1 0 0 1 2
++ -@$(MPIRUN) -np 1 ./grid6.$(PETSC_ARCH) 1 1 1 10 10 10 1 1 3
++ -@$(MPIRUN) -np 1 ./grid6.$(PETSC_ARCH) 1 1 1 10 10 10 0 1 3
++ -@$(MPIRUN) -np 4 ./grid7.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 1 0.01
++ -@$(MPIRUN) -np 4 ./grid8.$(PETSC_ARCH) 2 2 1 8 8 8 0 1 3 0.01
+
+ deletelibs:
+